Microsoft Dynamics CRM -valikko on edelleen Outlookin valikkopalkissa sen jälkeen, kun Microsoft Dynamics CRM 3.0 for Outlook -asiakasohjelman asennus on poistettu

Artikkeleiden käännökset Artikkeleiden käännökset
Artikkelin tunnus: 949087 - Näytä tuotteet, joita tämä artikkeli koskee.
Tärkeää Tässä artikkelissa käsitellään rekisterin muokkaamista. Muista varmuuskopioida rekisteri ennen sen muokkaamista. Varmista, että osaat palauttaa rekisterin, jos ongelmia ilmenee. Lisätietoja rekisterin varmuuskopioimisesta, palauttamisesta ja muokkaamisesta saat napsauttamalla seuraavaa artikkelin numeroa, jolloin pääset lukemaan artikkelin Microsoft Knowledge Base -tietokannassa:
322756 Rekisterin varmuuskopioiminen ja palauttaminen Windowsissa
Laajenna kaikki | Kutista kaikki

Oire

Ongelma 1

Kun olet poistanut Microsoft Office Outlookin Microsoft Dynamics CRM 3.0 -asiakkaan asennuksen, Microsoft Dynamics CRM 3.0 -valikko on edelleen Outlookin valikkopalkissa.

Vaihtoehtoisesti poistat Microsoft Dynamics CRM 3.0 for Outlook -asiakasohjelman asennuksen ja yrität asentaa Microsoft Dynamics CRM 4.0 for Outlook -asiakasohjelman, jolloin Microsoft Dynamics CRM 4.0 -asiakkaan asennus yrittää suorittaa päivityksen.

Ongelma 2

Kun avaat Microsoft Dynamics CRM 4.0 for Outlook -asiakasohjelman, näyttöön tulee seuraava virhesanoma:
Virhe ladattaessa Microsoft Dynamics CRM -toimintoja. Yritä käynnistää Microsoft Outlook uudelleen. Ota yhteyttä järjestelmänvalvojaan, jos virheet toistuvat.
Jos valitset virhesanomassa OK, CRM-työkalurivi näkyy Outlookin valikkopalkissa kahdesti.

Syy

Tämä ongelma ilmenee, koska Microsoft Dynamics CRM 3.0 -asiakkaan asennusta ei ole poistettu kokonaan.

Ratkaisu

Varoitus Vakavia ongelmia saattaa ilmetä, jos muokkaat rekisteriä virheellisesti Rekisterieditorilla tai jollakin muulla tavalla. Näiden ongelmien ilmetessä saatat joutua asentamaan käyttöjärjestelmäsi uudelleen. Microsoft ei takaa, että nämä ongelmat voidaan ratkaista. Muokkaat rekisteriä omalla vastuulla.

Voit korjata tämän ongelman seuraavasti:
  1. Sulje Outlook. Tarkista Tehtävienhallinnassa, että Outlook.exe- ja Microsoft.crm.application.hoster.exe-prosessit eivät ole käynnissä.
  2. Poista Lisää tai poista sovellus -työkalussa Microsoft Dynamics CRM 4.0 for Outlook -asiakasohjelman tai Microsoft Dynamics CRM 3.0 for Outlook -asiakasohjelman asennus.
  3. Poista seuraavat asiakastietokoneen hakemistot, jos ne ovat tietokoneessa:
    • Asema:\Program Files\Microsoft Dynamics CRM
    • Asema:\Program Files\Microsoft CRM
  4. Napsauta Käynnistä-painiketta, valitse Suorita, kirjoita regedit ja valitse sitten OK.
  5. Avaa seuraava rekisteriavain:
    HKEY_Current_User\SOFTWARE\Microsoft
  6. Poista MSCRMClient-rakenne, jos se on olemassa.
  7. Kaksoisnapsauta Ohjauspaneelissa Sähköposti-kuvaketta ja valitse sitten Sähköpostitilit.
  8. Valitse Osoitteistot-välilehti, valitse Microsoft Dynamics CRM -osoitteisto ja valitse sitten Poista.
  9. Valitse Datatiedostot-välilehti, valitse Microsoft Dynamics CRM -datatiedosto, jos sellainen on, ja valitse sitten Poista.
  10. Napsauta Käynnistä-painiketta, valitse Suorita, kirjoita regedit ja valitse sitten OK.
  11. Avaa seuraava rekisteriavain:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates
  12. Poista Microsoft Dynamics CRM 3.0 -rekisterirakenne, jos se on olemassa.
  13. Nimeä Outcmd.dat-tiedosto uudelleen nimellä Outcmd.old.

    Huomautus Oletusarvon mukaan Outcmd.dat-tiedosto on seuraavassa kansiossa:
    C:\Documents and Settings\Käyttäjä\Application Data\Microsoft\Outlook
    Huomautus Outlook luo Outcmd.dat-tiedoston uudelleen. Kaikki Outlookin valikkoriville luodut mukautetut valikot kuitenkin poistetaan.
  14. Tarkista, että Outlookin Microsoft Dynamics CRM -apuohjelma on poistettu. Voit tehdä tämän seuraavasti:

    Outlook 2003
    1. Avaa Outlook, valitse Työkalut, valitse Asetukset, valitse Muu-välilehti, valitse Lisäasetukset ja valitse sitten COM-apuohjelmat.
    2. Valitse Microsoft Dynamics CRM, valitse Poista ja valitse sitten OK.
    3. Valitse Työkalut ja valitse sitten Mukauta.
    4. Valitse Microsoft Dynamics CRM ja valitse sitten Poista.
    5. Valitse Palauta ja valitse sitten Sulje.
    6. Sulje Outlook.
    7. Napsauta Käynnistä-painiketta, valitse Kaikki ohjelmat, valitse Microsoft Dynamics CRM 4.0 ja valitse sitten Diagnostiikka.
    8. Valitse Suorita diagnostiikka.
    9. Avaa Outlook.
    Outlook 2007
    1. Avaa Outlook, valitse Työkalut, valitse Valvontakeskus, valitse Apuohjelmat ja valitse sitten Siirry.
    2. Valitse Microsoft Dynamics CRM, valitse Poista ja valitse sitten OK.
    3. Valitse Työkalut ja valitse sitten Mukauta.
    4. Valitse Microsoft Dynamics CRM ja valitse sitten Poista.
    5. Valitse Palauta ja valitse sitten Sulje.
    6. Sulje Outlook.
    7. Napsauta Käynnistä-painiketta, valitse Kaikki ohjelmat, valitse Microsoft Dynamics CRM 4.0 ja valitse sitten Diagnostiikka.
    8. Avaa Outlook.

Suositukset

Saat lisätietoja napsauttamalla seuraavaa artikkelin numeroa, jolloin pääset lukemaan artikkelin Microsoft Knowledge Base -tietokannassa:
948312 Virhesanoma yritettäessä asentaa, päivittää tai määrittää Microsoft Dynamics CRM for Outlook -asiakasohjelman tietokone

Ominaisuudet

Artikkelin tunnus: 949087 - Viimeisin tarkistus: 12. syyskuuta 2011 - Versio: 2.0
Artikkelin tiedot koskevat seuraavia tuotteita:
  • Microsoft Dynamics CRM 4.0
  • Microsoft CRM client for Microsoft Office Outlook seuraavilla käyttöjärjestelmillä
    • Microsoft Dynamics CRM 4.0
Hakusanat: 
kbexpertisebeginner kbtshoot kbmbsmigrate kbprb kbexpertiseinter KB949087

Anna palautetta

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com