Article ID: 949295 - Last Review: March 7, 2008 - Revision: 1.1

You may experience poor performance when Outlook 2007 connects to an Exchange Server 2003 server

System TipThis article applies to a different operating system than the one you are using. Article content that may not be relevant to you is disabled.

On This Page

Expand all | Collapse all

SYMPTOMS

When Microsoft Office Outlook 2007 connects to a server that is running Microsoft Exchange Server 2003, you may experience poor performance. Additionally, you may receive the following message:
Outlook is retrieving data from the Microsoft Exchange Server ServerName. You can cancel the request or minimize this message to the Windows taskbar until Outlook closes the message automatically.
If you start Outlook 2007 by using the /RPCDIAG switch, there will be too many mail connections to the Exchange Server 2003 server. Additionally, the offline folder file is significantly larger than the mailbox to which you are connecting.

CAUSE

This issue occurs if the following conditions are true:
  • Outlook 2007 uses MAPI to connect to an Exchange Server 2003 server.
  • Outlook 2007 is running in Cached Exchange Mode.
  • The Outlook 2007 profile contains many shared calendars under People's Calendars in the Calendar section of the Outlook 2007 navigation pane.
  • Outlook 2007 caches the shared calendars.

RESOLUTION

To resolve this issue, use one of the following methods.

Method 1

Reduce the number of shared calendars that are cached in Outlook 2007.

Note You can use the scheduling functionality to check the free/busy information in shared calendars instead of opening individual calendars.

Method 2

Upgrade to Microsoft Exchange Server 2007.

MORE INFORMATION

Steps to reproduce the behavior

  1. Create many mailboxes on the Exchange Server 2003 server.

    Note The number of cached mailboxes that are required to reproduce the problem varies depending on each environment.
  2. Give one user the Full Control permission to the rest of the mailboxes.
  3. Use Outlook 2007 to log on to the Exchange Server 2003 mailbox.
  4. In Outlook 2007, click Calendar in the navigation pane.
  5. Open a shared calendar.
  6. Press and hold CTRL, and then click the Microsoft Office Outlook icon in the notification area.
  7. Click Connection Status. Notice the number of mail connections.
  8. Continue to open shared calendars while you monitor the connection status. Notice that the number of mail connections continues to increase
This is an expected behavior. The ability to cache shared calendars is new to Outlook 2007. For each shared calendar that is cached, an additional mail connection is opened to the Exchange Server 2003 server. The additional connections exceed the number of initial connections that are required to access a mailbox on the Exchange Server 2003 server. Opening additional connections will increase network traffic to the Exchange Server 2003 server. Additionally, the other remote procedure calls (RPC) connections create a performance burden on the Exchange Server 2003 server.

This behavior is not present in Microsoft Office Outlook 2003. Shared calendars are not cached in versions of Outlook that are earlier than Outlook 2007.

Note Mail connections are opened regardless of whether a shared calendar is checked in Outlook 2007.

The hotfix (903158) mentioned in KB 839862 may not resolve the problem because the source of this behavior is in how Outlook 2007 connects to the Exchange Server 2003 server.

REFERENCES

For more information, visit the following Microsoft Web site:
http://technet2.microsoft.com/Office/en-us/library/7586f740-eef7-4ab4-8608-30b6af23c5951033.mspx?mfr=true (http://technet2.microsoft.com/Office/en-us/library/7586f740-eef7-4ab4-8608-30b6af23c5951033.mspx?mfr=true)
For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
839862  (http://support.microsoft.com/kb/839862/ ) How to troubleshoot the RPC Cancel Request dialog box in Outlook 2003 or in Outlook 2002
932086  (http://support.microsoft.com/kb/932086/ ) You may experience performance problems when you are working with items in a large .pst file or in a large .ost file in Outlook 2007

APPLIES TO
  • Microsoft Office Outlook 2007
Keywords: 
kbtshoot kbexpertisebeginner kbprb KB949295