FIX: You receive an HTTP 500 error message or a blank page appears when you request an ASP.NET resource or WCF resource that is hosted on a server that is running IIS 7.0

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Article ID: 949350 - View products that this article applies to.
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SYMPTOMS

When you request an ASP.NET resource or a Windows Communication Foundation (WCF) resource that is hosted on Internet Information Services (IIS) 7.0, you incorrectly receive a HTTP 500 error message or the Web page is blank.

CAUSE

This problem occurs if the following conditions are true:
  • There is a configuration error in the <httpErrors> section of the Web.config file or a global error in the IIS configuration files.
  • An error occurs when the ASP.NET resource or the WCF resource is processed.

RESOLUTION

The most common cause of this problem is that the Error Pages feature in Feature Delegation is set to Read Only on the server that is running IIS 7.0. Additionally, a Web.config file is trying to modify the settings. To resolve this problem, set the Error Pages feature in Feature Delegation to Read/Write.

If this method does not resolve the problem, see the "More Information" section.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Windows Server 2008 or Windows Vista Service Pack 1 (SP1) installed to apply this hotfix.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
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File nameFile versionFile sizeDateTimePlatform
Custerr.dll 7.0.6001.22149 40,44803-Apr-2008 03:11x86
Custerr.dll 7.0.6001.22149 46,592 03-Apr-2008 03:49 x64
Custerr.dll 7.0.6001.22149 40,44803-Apr-200803:11 WOW64
Custerr.dll 7.0.6001.22149 92,160 03-Apr-200803:32 IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

If an error occurs when an ASP.NET resource is processed, the HTTP Detailed Errors feature should let the response that ASP.NET returns appear in the browser. However, in the scenario that this article describes, the HTTP Detailed Errors feature incorrectly tries to handle the error. If the HTTP Detailed Errors feature encounters an error when the HTTP Detailed Errors feature reads the <httpErrors> section of the Web.config file, the HTTP Detailed Errors feature returns a 500 error message. This 500 error message causes a blank page or a generic 500 error message to appear in the browser, depending on the browser that is used and on how the browser is configured.

To troubleshoot this problem, review the HTTP detailed error information that you receive when you request a non-ASP.NET resource locally from a server that is running IIS 7.0. For example, request a Web page that does not exist on the server that is running IIS. When you request a Web page that does not exist on the server, you receive an HTTP 500.19 error message. The HTTP 500.19 error message explains the problem with the configuration.

Note The event log may also contain information that you can use to troubleshoot the problem.

Steps to reproduce the problem

  1. Start Internet Information Services Manager.
  2. Click the server that you want.
  3. On the Features View tab, double-click Feature Delegation.
  4. Right-click Error Pages, and then click Read Only.
  5. In the Web.config file for the ASP.NET resource, add the following configuration section:
    <?xml version="1.0" encoding="UTF-8"?>
    <configuration>
    <system.webServer>
    <httpErrors>
    <remove statusCode="404" subStatusCode="-1" />
    <error statusCode="404" prefixLanguageFilePath="" path="/index.aspx" responseMode="ExecuteURL" />
    </httpErrors>
    </system.webServer>
    </configuration>
    
  6. Request an ASP.NET resource that does not exist. For example, request Doesnotexist.aspx.

REFERENCES

For more information about how to use the HTTP Detailed Errors feature in IIS, visit the following Web site:
http://learn.iis.net/page.aspx/267/how-to-use-http-detailed-errors-in-iis7/

Properties

Article ID: 949350 - Last Review: April 22, 2008 - Revision: 2.2
APPLIES TO
  • Microsoft Internet Information Services 7.0
Keywords: 
kbautohotfix kbhotfixserver kbfix kbbug kbqfe kbtshoot kbprb KB949350

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