Help and Support
 

powered byLive Search

Error message when you try to install Windows XP Service Pack 3: "Access is denied" or “Service Pack installation did not complete”

Article ID:949377
Last Review:May 13, 2008
Revision:3.0
On This Page

SYMPTOMS

When you install Windows XP Service Pack 3 (SP3), you may receive one of the following error messages:
Service Pack 3 setup error. Access is denied.
Service Pack 3 setup error. Service Pack installation did not complete
Or, the Svcpack.log file may contain the following error message:
DoRegistryUpdates failed

Back to the top

CAUSE

You may receive these error messages if permissions for one or more registry keys are restricted in a way that prevents the update of those registry keys.

Some programs change the system access control lists (SACL) in the Registry so that administrator accounts cannot alter them. The service pack installer runs under the user (admin) account and not under the SYSTEM account. Failure to update a registry key causes the Setup program to fail.

To verify that there is a failure to update the registry, see the "More Information" section.

Back to the top

RESOLUTION

To resolve the issue, follow the methods that are described in this section in order until the issue is resolved. After you complete one of the methods, install Windows XP SP3 to determine whether the issue is resolved before you try the next method.

Back to the top

Method 1: Download and then install the full Windows XP Service Pack 3 download package from the Microsoft Download Center

Download and then try to install the full Windows XP Service Pack 3 download package from the Microsoft Download Center.

For more information about how to download Windows XP Service Pack 3, click the following article number to view the article in the Microsoft Knowledge Base:
322389 (http://support.microsoft.com/kb/322389/) How to obtain the latest Windows XP service pack

Back to the top

Method 2: Restart the computer, and then close or disable any antivirus or antispyware program that may be running

Warning This workaround may make a computer or a network more vulnerable to attack by malicious users or by malicious software such as viruses. We do not recommend this workaround but are providing this information so that you can implement this workaround at your own discretion. Use this workaround at your own risk.

One of the most common causes of installation failure is when a third-party program holds a file open or locks a file that the service pack installer needs. To help prevent this issue, follow these steps before you install Windows XP SP3:
1.Exit all programs on the computer, and then restart the computer.
2.After you restart the computer, close or disable any antivirus or any antispyware programs that may be running.

Note You can disable the programs from the notification area. To disable a program from the notification area, right-click the third-party program icon, and then click an option to close or to disable the application.
3.After you close the antivirus program or the antispyware program, install Windows XP SP3 from the full download package that you downloaded in Method 1.

Note You may also install Windows XP SP3 from the Windows Update site or from the Microsoft Update site.
4.After Windows XP SP3 installation is complete, enable the antivirus program or the antispyware program that you disabled in step 2.
Note An antivirus program is designed to help protect your computer from viruses. You must not download or open files from sources that you do not trust, visit Web sites that you do not trust, or open e-mail attachments when your antivirus program is disabled. For additional information about computer viruses, click the following article number to view the article in the Microsoft Knowledge Base:
129972 (http://support.microsoft.com/kb/129972/) Computer viruses: description, prevention, and recovery

Back to the top

Method 3: Reset the registry and the file permissions

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 (http://support.microsoft.com/kb/322756/) How to back up and restore the registry in Windows

Important This method is intended for advanced computer users. If you are not comfortable with advanced workarounds, you might want to ask someone for help, or you might want to contact Microsoft Customer Support Services. To contact Microsoft Customer Support Services, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/ (http://support.microsoft.com/contactus/)
1.Download and then install the Subinacl.exe file. To do this, visit the following Microsoft Web site:
http://www.microsoft.com/downloads/details.aspx?FamilyID=e8ba3e56-d8fe-4a91-93cf-ed6985e3927b&displaylang=en (http://www.microsoft.com/downloads/details.aspx?FamilyID=e8ba3e56-d8fe-4a91-93cf-ed6985e3927b&displaylang=en)
2.Start Notepad.
3.Copy and then paste the following text into Notepad.
cd /d "%ProgramFiles%\Windows Resource Kits\Tools"
subinacl /subkeyreg HKEY_LOCAL_MACHINE /grant=administrators=f /grant=system=f
subinacl /subkeyreg HKEY_CURRENT_USER /grant=administrators=f /grant=system=f
subinacl /subkeyreg HKEY_CLASSES_ROOT /grant=administrators=f /grant=system=f
subinacl /subdirectories %SystemDrive% /grant=administrators=f /grant=system=f
subinacl /subdirectories %windir%\*.* /grant=administrators=f /grant=system=f
secedit /configure /cfg %windir%\repair\secsetup.inf /db secsetup.sdb /verbose
Microsoft provides programming examples for illustration only, without warranty either expressed or implied. This includes, but is not limited to, the implied warranties of merchantability or fitness for a particular purpose. This article assumes that you are familiar with the programming language that is being demonstrated and with the tools that are used to create and to debug procedures. Microsoft support engineers can help explain the functionality of a particular procedure. However, they will not modify these examples to provide added functionality or construct procedures to meet your specific requirements.
4.Save this Notepad file as Reset.cmd.
5. Double-click the Reset.cmd file to run the script.

Note This script file may take a long time to run. Additionally, you have to run this script as an administrator.
6.Install Windows XP SP3.

Back to the top

MORE INFORMATION

How to verify that the registry update has failed

1.Open the Svcpack.log file. By default, this file is located in the C:\Windows folder. To open the Svcpack.log file, click Start, click Run, type %windir%\svcpack.log, and then click OK.
2.On the Edit menu, click Find.
3.In the Find what box, type DoRegistryUpdates failed, and then click Find Next.
A "DoRegistryUpdates failed" error message in the file indicates that an issue is preventing the registry update. The error message will resemble the following error message:
xxxx.xxx: DoInstallation:DoRegistryUpdates failed.
xxxx.xxx: Access is denied.
xxxx.xxx: Message displayed to the user: Access is denied.
Note In this message, xxxx.xxx represents the time stamp of each entry.

Back to the top


APPLIES TO
Microsoft Windows XP Service Pack 3

Back to the top

Keywords: 
kbexpertisebeginner kbregistry kberrmsg kbtshoot kbprb KB949377

Back to the top

Article Translations

 

Related Support Centers

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.