Při pokusu nainstalovat aktualizaci Windows XP Service Pack se zobrazí chybová zpráva Přístup odepřen nebo Instalace aktualizace Service Pack nebyla dokončena

Překlady článku Překlady článku
ID článku: 949377 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Při pokusu o instalaci aktualizace Microsoft Windows XP Service Pack 2 (SP2) nebo Service Pack 3 (SP3) se může zobrazit chybová zpráva podobná následující:
Chyba instalace aktualizace Service Pack 3. Přístup byl odepřen.
Chyba instalace aktualizace Service Pack 3. Instalace aktualizace Service Pack nebyla dokončena.
Nebo může soubor protokolu Svcpack.log obsahovat následující chybovou zprávu:
DoRegistryUpdates failed

Příčina

Tyto chyby mohou nastat v případě, že oprávnění některých klíčů registru jsou omezena způsobem, který aktualizaci Service Pack brání v aktualizaci těchto klíčů. Klíče registru mohou být omezeny některými programy, které mohou změnit seznamy řízení přístupu k systému souborů (SACL) v registru, a zamezit tak změnám ze správcovských účtů. Instalační služba aktualizace Service Pack běží pod správcovským účtem (Uživatel), a proto nemá přístup ke klíčům registru s omezeným přístupem. Pokud aktualizace Windows XP Service Pack nemůže aktualizovat klíč registru, protože je omezen jiným programem, instalace této aktualizace Service Pack se nezdaří.

Chcete-li zjistit, zda došlo k chybě při aktualizaci registru, přejděte k části Další informace.

Řešení

K vyřešení tohoto problému použijte následující metody řešení potíží v pořadí, v jakém jsou uvedeny. Tyto metody jsou určeny pro středně pokročilé až pokročilé uživatele.

Poznámka: Chcete-li dokončit tyto metody, musíte být k systému Windows přihlášeni pomocí uživatelského účtu správce počítače. Pokud tyto kroky provádíte ve svém osobním počítači, jste již pravděpodobně prostřednictvím účtu správce přihlášeni. Pokud tyto kroky provádíte v pracovním počítači, bude možná nutné požádat o pomoc správce systému. Chcete-li ověřit, zda jste k systému Windows přihlášeni pomocí uživatelského účtu správce počítače, navštivte následující web společnosti Microsoft:
http://support.microsoft.com/gp/admin?ln=cs

Metoda 1: Restartování počítače a následný pokus o stažení a instalaci aktualizace Windows XP SP3 z webu služby Stažení softwaru

Pokud je program spuštěn s uzamčeným souborem, může restartování počítače způsobit jeho odemknutí. Chcete-li se pokusit soubor odemknout, ukončete všechny programy a restartujte počítač. Potom zkuste znovu stáhnout a nainstalovat aktualizaci Service Pack.

Pokud jste se nejprve neúspěšně pokoušeli nainstalovat aktualizaci Windows XP SP3 pomocí služby Windows Update, stáhněte celý balíček aktualizace Windows XP SP3 z webu služby Stažení softwaru. Po stažení se aktualizaci Service Pack pokuste nainstalovat. Další informace o stažení aktualizace Windows XP Service Pack 3 naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
322389 Jak získat nejnovější aktualizaci Service Pack pro systém Windows XP
Pokud tato metoda vyřešila potíže s chybovou zprávu a úspěšně jste nainstalovali aktualizaci Windows XP SP3, jste hotovi.

Další informace o obnovení výchozího nastavení zabezpečení pro systém Windows XP naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
313222 Postup při obnovení výchozího nastavení zabezpečení


Pokud tato metoda potíže nevyřešila, pokračujte metodou 2.

Metoda 2: Restartování počítače a ukončení nebo zakázání všech antivirových nebo antispywarových programů

Upozornění: Tento postup může oslabit zabezpečení počítače nebo sítě vůči útoku uživatelů se zlými úmysly nebo škodlivému softwaru, například virům. Toto řešení se nedoporučuje, jsou ale poskytnuty informace, s jejichž pomocí můžete řešení implementovat podle vlastního uvážení. Tento postup používáte na vlastní nebezpečí.

Riziko útoku uživatelů se zlými úmysly nebo škodlivému softwaru můžete omezit tím, že nebudete navštěvovat ostatní weby či stahovat soubory v době, kdy je antivirový nebo antispywarový program vypnut nebo zakázán.

Jednou z nejčastějších příčin selhání instalace je otevření nebo uzamčení souboru, který instalační program potřebuje, programem jiného výrobce, například antivirovým programem. Chcete-li této situaci zabránit, před instalací aktualizace Windows XP SP3 proveďte následující kroky:
  1. Ukončete všechny programy a restartujte počítač.
  2. Po restartování ukončete nebo zakažte všechny spuštěné antivirové a antispywarové programy.

    Poznámka: Tyto programy lze obvykle zakázat prostřednictvím oznamovací oblasti. Klikněte pravým tlačítkem myši na ikonu programu jiného výrobce a pak klikněte na příkaz k ukončení nebo zakázání tohoto programu. Pokud tato možnost není k dispozici, vyhledejte informace v dokumentaci k programu nebo požádejte o pokyny výrobce tohoto programu.
  3. Po ukončení antivirového nebo antispywarového programu nainstalujte aktualizaci Windows XP SP3 z úplného balíčku staženého v metodě 1.
  4. Po dokončení instalace aktualizace Windows XP SP3 restartujte antivirový nebo antispywarový program, který jste zakázali v kroku 2.
Pokud tato metoda vyřešila potíže s chybovou zprávu a úspěšně jste nainstalovali aktualizaci Windows XP SP3, jste hotovi.

Pokud tato metoda nebyla úspěšná a přitom se svými uživatelskými zkušenostmi zvládáte řešení potíží pro pokročilé uživatele, přejděte k části Řešení potíží pro pokročilé uživatele. Pokud si netroufáte na postupy řešení potíží pro pokročilé uživatele, můžete přejít k části Další kroky.

Řešení potíží pro pokročilé uživatele

Tato část obsahuje metody řešení potíží pro pokročilé uživatele, které lze vyzkoušet, pokud nefungují kroky v části Řešení. Tato metoda je určena pouze pro pokročilé uživatele.

Obnovení registru a přístupu k souborům

Chcete-li, abychom obnovili registr a přístup k souborům za vás, přejděte k části Automatická oprava. Chcete-li funkci Automatické aktualizace zapnout sami, přejděte k části Manuální oprava.


Automatická oprava

Chcete-li tyto potíže odstranit automaticky, klikněte na odkaz Opravit tyto potíže. Potom klikněte na příkaz Spustit v dialogovém okně Stažení souboru a postupujte podle kroků průvodce.
Opravit tyto potíže
Microsoft Fix it 50389

Poznámka: Je možné, že tento průvodce bude k dispozici pouze v angličtině, tato automatická oprava však funguje i pro ostatní jazykové verze systému Windows.

Poznámka: Pokud právě nejste u počítače, který má tyto potíže, můžete automatickou opravu uložit na jednotku USB flash nebo na disk CD a spustit ji v příslušném počítači později.

Manuální oprava

Důležité: Tato část, metoda nebo úkol obsahuje kroky, které popisují úpravu registru. V případě úpravy registru nesprávným způsobem však mohou nastat závažné problémy. Proto vždy pečlivě kontrolujte, zda postupujete přesně podle těchto kroků. Jako dodatečnou ochranu registr před úpravami zazálohujte. Potom můžete v případě problému registr obnovit. Další informace o zálohování a obnovení registru naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
322756 Postup zálohování a obnovení registru v systému Windows
Chcete-li obnovit oprávnění registru a souborů, postupujte takto:
  1. Stáhněte a nainstalujte soubor Subinacl.exe. Naleznete jej na následujícím webu společnosti Microsoft:
    http://www.microsoft.com/en-us/download/details.aspx?id=23510
  2. Spusťte program Poznámkový blok.
  3. Zkopírujte následující text a vložte jej do programu Poznámkový blok.
    cd /d "%ProgramFiles%\Windows Resource Kits\Tools"
    subinacl /subkeyreg HKEY_LOCAL_MACHINE /grant=administrators=f /grant=system=f
    subinacl /subkeyreg HKEY_CURRENT_USER /grant=administrators=f /grant=system=f
    subinacl /subkeyreg HKEY_CLASSES_ROOT /grant=administrators=f /grant=system=f
    subinacl /subdirectories %SystemDrive% /grant=administrators=f /grant=system=f
    subinacl /subdirectories %windir%\*.* /grant=administrators=f /grant=system=f
    secedit /configure /cfg %windir%\repair\secsetup.inf /db secsetup.sdb /verbose
    Společnost Microsoft poskytuje ukázky programování pouze pro ilustraci, bez žádné záruky výslovně uvedené nebo odvozené, včetně, bez omezení, odvozených záruk vztahujících se k obchodovatelnosti nebo vhodnosti pro určitý účel. Tento článek předpokládá, že uživatel je obeznámen s programovacím jazykem, který je předmětem ukázky, a s nástroji použitými pro vytvoření a ladění skriptu. Pracovníci technické podpory společnosti Microsoft mohou vysvětlit funkce určité procedury, nemohou však následující příklady rozšířit o další funkce nebo vytvářet procedury podle konkrétních požadavků uživatele.
  4. Uložte tento text v programu Poznámkový blok jako soubor Reset.cmd.
  5. Dvojím kliknutím na soubor Reset.cmd spusťte skript.

    Poznámka: Spuštění tohoto souboru může trvat dlouho. Tento skript je nutné spustit jako správce.
  6. Nainstalujte aktualizaci Windows XP SP3.
Pokud tato metoda vyřešila potíže s chybovou zprávu a úspěšně jste nainstalovali aktualizaci Windows XP SP3, jste hotovi.

Pokud tato metoda problém nevyřeší, přejděte k části Další kroky.

Další informace

Jak určit, zda došlo k chybě při aktualizaci registru

  1. Klikněte na tlačítko Start, potom na příkaz Spustit, zadejte příkaz %windir%\svcpack.log a klikněte na tlačítko OK. Otevře se soubor Svcpack.log.
  2. V nabídce Úpravy klepněte na příkaz Najít.
  3. Do pole Najít zadejte DoRegistryUpdates failed a klepněte na tlačítko Najít další.

    Pokud při aktualizaci registru došlo k chybě, zobrazí se v tomto souboru chybová zpráva DoRegistryUpdates failed. To znamená, že potíže brání aktualizaci registru. Chybová zpráva je podobná následující:
    xxxx.xxx: DoInstallation:DoRegistryUpdates failed.
    xxxx.xxx: Přístup byl odepřen.
    xxxx.xxx: Message displayed to the user: Přístup byl odepřen.
    Poznámka: Symbol xxxx.xxx v této zprávě představuje časové razítko položky.

Antivirový software

Antivirový program je navržen tak, aby napomáhal ochraně počítače před viry. Pokud je antivirový program vypnutý, nesmíte stahovat a otevírat soubory z nedůvěryhodných zdrojů, navštěvovat nedůvěryhodné weby ani otevírat přílohy e-mailů. Další informace o počítačových virech získáte v následujícím článku znalostní báze Microsoft Knowledge Base:
129972 Počítačové viry: popis, prevence a obnovení

DALŠÍ KROKY

Pokud uvedené metody nefungují, můžete k nalezení dalších řešení rovněž použít web služeb podpory zákazníků společnosti Microsoft. Mezi služby poskytované na webu služeb podpory zákazníků společnosti Microsoft patří například následující:
  • Znalostní báze Knowledge Base s možností prohledávání: Slouží k hledání v informacích o technické podpoře a nástrojích samoobslužné podpory pro produkty společnosti Microsoft.
  • Centra řešení: Slouží k zobrazení nejčastějších dotazů k jednotlivým produktům a problémů řešených službami podpory.
  • Další možnosti podpory: Tento web umožňuje klást dotazy související s podporou, obrátit se na služby podpory zákazníků společnosti Microsoft nebo zaslat svůj názor.
Pokud máte potíže i nadále, obraťte se na oddělení podpory:
http://support.microsoft.com/contactus/?ln=cs#tab0

Vlastnosti

ID článku: 949377 - Poslední aktualizace: 25. července 2013 - Revize: 12.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows XP Service Pack 3
  • Microsoft Windows XP Service Pack 2
Klíčová slova: 
kbexpertisebeginner kbregistry kberrmsg kbtshoot kbprb kbfixme kbmsifixme KB949377

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com