Fehlermeldungen, wenn Sie versuchen, Windows XP Service Pack 3 zu installieren: "Servicepack 3-Installation nicht abgeschlossen" und "ein interner Fehler ist aufgetreten"

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Problembeschreibung

Wenn Sie versuchen, Windows XP Service Pack 3 (SP3) installieren, erhalten Sie folgende Fehlermeldung:
Interner Fehler
Nachdem Sie in der Fehlermeldung auf OK klicken, wird die folgende Fehlermeldung:
Installation von Service Pack 3 wurde nicht abgeschlossen
Außerdem sehen Sie möglicherweise die folgenden Fehler, die in C protokolliert werden: \Windows\Svcpack.log Datei:
165.672: An internal error occurred.
165.672: Service Pack 3 installation did not complete.
165.672: Update.exe extended error code = 0x1ffe054f
165.672: Update.exe return code was masked to 0x643 for MSI custom action compliance
Hinweis in diesem Artikel C: \Windows Ordner darstellt, den Ordner, in denen Windows normalerweise installiert ist.

Ursache

Die im Abschnitt "Problembeschreibung" aufgeführten Fehler können auftreten, aufgrund von Dateien, die nicht vertrauenswürdig sind oder aufgrund von beschädigten Registrierungsschlüssel. Sie können die Ursache überprüfen, indem Sie nach entsprechenden Einträgen in die Datei Svcpack.log suchen. Spezifischen Einträge werden bestimmte Ursachen für das Problem identifiziert, wie in den folgenden Abschnitten "Ursache" beschrieben.

Ursache 1

Bestimmen, ob die folgenden Einträge in die Datei Svcpack.log protokolliert werden:
142.391: CheckVLKForBlock: LIC.dll not trust verified
142.578: Trying CheckVLKForBlock again
142.594: CheckVLKForBlock: LIC.dll not trust verified
142.594: Error: CheckVLKForBlock failed
diese Einträge ein Hinweis darauf sein, dass die Ursache des Problems die Licdll.dll-Datei ist. Die Licdll.dll-Datei wurde geändert, ist beschädigt oder ist nicht vertrauenswürdig. Die Datei Licdll.dll befindet sich im folgenden Ordner:
C: \Windows\System32\

Ursache 2

Bestimmen, ob die folgenden Einträge in die Datei Svcpack.log protokolliert werden:
211.890: IsSPBetaKey:pLA->lpVtbl->GetProductID Failed: 0x80004005 
213.125: Trying CheckVLKForBlock again
214.468: Error: CheckVLKForBlock failed
diese Einträge weisen darauf hin, dass falsche Product ID-Informationen in der Registrierung das Problem verursacht.

Ursache 3

Bestimmen, ob die folgenden Einträge in die Datei Svcpack.log protokolliert werden:
299.031: Trying CheckVLKForBlock again
299.531: Error: CheckVLKForBlock failed
diese Einträge weisen darauf hin, dass beschädigte oder geänderte Registrierungsschlüssel in vorinstallierte Programme das Problem verursachen.

Hinweis: Ein Programm, das dieses Problem verursacht ist Micrografx - Picture Publisher Professional 10. Um dieses Problem zu umgehen, finden Sie im Abschnitt "Abhilfe für Ursache 3".

Lösung

Zum Beheben oder zu dieser Ursachen umgehen, verwenden Sie die Lösung oder Problemumgehung, die die Ursache entspricht.

Lösung für Ursache 1

Um dieses Problem zu beheben, müssen Sie die aktuelle Kopie der Datei Licdll.dll mithilfe einer Kopie von den ursprünglichen Windows-Medien ersetzen. Gehen Sie hierzu folgendermaßen vor:
  1. Legen Sie die Windows XP-CD in das CD-Laufwerk ein.
  2. Klicken Sie auf der Setup-Assistenten Beenden , sobald er gestartet wird.
  3. Klicken Sie auf Start , und klicken Sie dann auf Ausführen .
  4. Kopieren und dann einfügen (oder Typ) folgende Befehl in das Feld Öffnen ein, und drücken Sie dann die EINGABETASTE:
    Explorer
  5. Klicken Sie auf Arbeitsplatz .
  6. Notieren Sie sich den Laufwerkbuchstaben, der die Windows XP-CD enthält.
  7. Klicken Sie auf Start , und klicken Sie dann auf Ausführen .
  8. Kopieren und dann einfügen (oder Typ) folgende Befehl in das Feld Öffnen ein, und drücken Sie dann die EINGABETASTE:
    cmd
  9. Geben Sie oder kopieren und fügen Sie den folgenden Text in das Fenster der Eingabeaufforderung und drücken Sie anschließend die [EINGABETASTE]:
    Erweitern Sie die CD_Drive_Letter: \i386\licdll.dl_ C: \Windows\system32\Licdll.dll
    Hinweis: Ersetzen Sie in den Befehl in Schritt 9 CD_Drive_Letter mithilfe von den eigentlichen Laufwerkbuchstaben für das Laufwerk, das Sie in Schritt 6 notiert haben.
  10. Zum Installieren von Windows XP SP3 finden Sie auf der folgenden Microsoft Windows Update--Website:
    http://windowsupdate.microsoft.com

Lösung für Ursache 2

Um dieses Problem zu beheben, müssen Sie den falschen Product ID-Registrierungseintrag mit der richtigen Product ID ersetzen. Dazu gehen Sie in den Abschnitten "Suchen und beachten Sie die Produkt-ID"und"identifizieren und Ändern der Produkt-ID-Registrierungseintrag".

Suchen Sie und notieren Sie die Produkt-ID

  1. Klicken Sie auf Start , und klicken Sie dann auf Ausführen .
  2. Kopieren und dann einfügen (oder Typ) folgende Befehl in das Feld Öffnen ein, und drücken Sie dann die EINGABETASTE:
    sysdm.cpl
  3. Suchen Sie auf der Registerkarte Allgemein die Produkt-ID Die Produkt-ID ist die 20-stelligen Nummer, die unter dem Abschnitt registrierte zu befindet.
  4. Beachten Sie die Produkt-ID für die Verwendung im Abschnitt "Identifizieren und Ändern der Produkt-ID-Registrierungseintrag".

Identifizieren Sie und ändern Sie den Produkt ID-Registrierungseintrag

wichtig In diesem Abschnitt, Methode oder Aufgabe enthält Hinweise zum Ändern der Registrierung. Allerdings können schwerwiegende Probleme auftreten, wenn Sie die Registrierung falsch ändern. Stellen Sie daher sicher, dass Sie diese Schritte sorgfältig ausführen. Für zusätzlichen Schutz sichern Sie der Registrierung, bevor Sie ihn ändern. Anschließend können Sie die Registrierung wiederherstellen, wenn ein Problem auftritt. Weitere Informationen zum Sichern und Wiederherstellen der Registrierung finden Sie im folgenden Artikel der Microsoft Knowledge Base:
322756Zum Sichern und Wiederherstellen der Registrierung in Windows
  1. Klicken Sie auf Start , und klicken Sie dann auf Ausführen .
  2. Kopieren und dann einfügen (oder Typ) folgende Befehl in das Feld Öffnen ein, und drücken Sie dann die EINGABETASTE:
    regedit
  3. Suchen Sie und klicken Sie auf den Registrierungsunterschlüssel, der den folgenden Registrierungsunterschlüssel ähnelt:
    HKEY_LOCAL_MACHINE\SYSTEM\WPA\Key-XXXXXXXXXXXXXXXXXXXXX
    Hinweis: Die Reihe der x darstellen einen Platzhalter für eine Zeichenfolge von 21 Zeichen.
  4. Kann es mehrere Unterschlüssel, die das Format Schritt 3 ähneln. Gehen Sie folgendermaßen vor um den richtigen Unterschlüssel zu ermitteln:
    1. Klicken Sie auf jeden Unterschlüssel im Navigationsbereich.
    2. Vergleichen Sie im Detailbereich den Wert der Zeichenfolge für den Registrierungseintrag ProductID unter der Spalte Daten auf die Zahl, die Sie in Schritt 4 im Abschnitt "Suchen und beachten Sie die Produkt-ID" notiert haben.
    3. Der Registrierungsunterschlüssel, dessen Wert des Registrierungseintrags ProductID der Anzahl, die Sie im Abschnitt entspricht "Finden die Produkt-ID" notiert haben, ist die Registrierungsunterschlüssel, den Sie möchten.
  5. Klicken Sie im Navigationsbereich klicken Sie mit der rechten Maustaste auf den Registrierungsunterschlüssel, den Sie im Schritt 4c identifiziert und klicken Sie dann auf Exportieren .
  6. Speichern Sie den Registrierungsunterschlüssel auf dem Desktop als temp.reg.
  7. Klicken Sie mit der rechten Maustaste auf die Datei temp.reg auf dem Desktop, und klicken Sie Öffnen mit .
  8. Klicken Sie auf Editor , und klicken Sie dann auf OK .
  9. Suchen Sie in der Datei geöffnet temp.reg den folgenden Text:
    [HKEY_LOCAL_MACHINE\SYSTEM\WPA\Key-XXXXXXXXXXXXXXXXXXXXX]
  10. Ersetzen Sie den Text, der im Schritt 9 erwähnt wird, mit den folgenden Text:
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion]
  11. Klicken Sie auf Datei , klicken Sie auf Speichern und schließen Sie Editor.
  12. Doppelklicken Sie auf die temp.reg-Datei, klicken Sie auf Ja in das Dialogfeld bei entsprechender Aufforderung die Registrierung die Informationen hinzu, und klicken Sie dann auf OK .
  13. Zum Installieren von Windows XP SP3 finden Sie auf der folgenden Microsoft Windows Update--Website:
    http://windowsupdate.microsoft.com

Lösung für Ursache 3

Um dieses Problem zu beheben, müssen Sie den Registrierungsunterschlüssel InprocServer32 löschen. Gehen Sie hierzu folgendermaßen vor:
  1. Klicken Sie auf Start , und klicken Sie dann auf Ausführen .
  2. Kopieren und dann einfügen (oder Typ) folgende Befehl in das Feld Öffnen ein, und drücken Sie dann die EINGABETASTE:
    regedit
  3. Suchen Sie und klicken Sie auf den Registrierungsunterschlüssel, der den folgenden Registrierungsunterschlüssel ähnelt:
    HKEY_CLASSES_ROOT\CLSID\ {00020420-0000-0000-C000-000000000046} \InprocServer32
  4. Klicken Sie auf InprocServer32 . Ein Zeichenfolgenwert mit dem Namen InprocServer32 ist im Detailfenster angezeigt. Klicken Sie auf diesen Wert.
  5. Klicken Sie im Menü Bearbeiten klicken Sie auf löschen, und klicken Sie dann auf Ja .
  6. Beenden Sie den Registrierungs-Editor.
  7. Zum Installieren von Windows XP SP3 finden Sie auf der folgenden Microsoft Windows Update--Website:
    http://windowsupdate.microsoft.com

Abhilfe für Ursache 3

Ein Programm, das verursacht das Problem, das erwähnte in 3 führt ist Micrografx - Picture Publisher Professional 10. Um dieses Problem zu umgehen, deinstallieren Sie vorübergehend Micrografx-Programm, und installieren Sie Windows XP SP3. Nachdem Windows XP SP3-Installation abgeschlossen ist, installieren Sie das Micrografx Programm neu.

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Eigenschaften

Artikel-ID: 949384 - Geändert am: Dienstag, 6. Mai 2008 - Version: 4.2
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows XP Service Pack 3
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