Mensajes de error cuando intenta instalar Windows XP Service Pack 3: "instalación del Service Pack 3 no finalizó" y "Error interno"

Seleccione idioma Seleccione idioma
Id. de artículo: 949384 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Cuando intenta instalar Windows XP Service Pack 3 (SP3), puede recibir el siguiente mensaje de error:
Error interno
Después de hacer clic en Aceptar en el mensaje de error, recibirá el siguiente mensaje de error:
No se completó la instalación de Service Pack 3
Además, puede ver los errores siguientes que se registran en el C: archivo \Windows\Svcpack.log:
165.672: An internal error occurred.
165.672: Service Pack 3 installation did not complete.
165.672: Update.exe extended error code = 0x1ffe054f
165.672: Update.exe return code was masked to 0x643 for MSI custom action compliance
Nota en este artículo, la C: carpeta \Windows representa la carpeta donde está instalado Windows XP normalmente.

Causa

Los errores que se mencionan en la sección "Síntomas" pueden producirse debido de archivos que no son de confianza o debido a claves del Registro dañadas de. Puede comprobar la causa buscando entradas relacionadas en el archivo Svcpack.log. Entradas específicas identificará las causas concretas del problema, como se indica en las siguientes secciones "Causa".

Causa 1

Determinar si las siguientes entradas se registran en el archivo Svcpack.log:
142.391: CheckVLKForBlock: LIC.dll not trust verified
142.578: Trying CheckVLKForBlock again
142.594: CheckVLKForBlock: LIC.dll not trust verified
142.594: Error: CheckVLKForBlock failed
estas entradas indicar que la causa del problema es el archivo Licdll.dll. El archivo Licdll.dll puede haberse alterado, está dañado o no es de confianza. El archivo Licdll.dll se encuentra en la carpeta siguiente:
C: \Windows\System32\

Causa 2

Determinar si las siguientes entradas se registran en el archivo Svcpack.log:
211.890: IsSPBetaKey:pLA->lpVtbl->GetProductID Failed: 0x80004005 
213.125: Trying CheckVLKForBlock again
214.468: Error: CheckVLKForBlock failed
estas entradas indican que la información de identificador de producto incorrecta en el registro está causando el problema.

Causa 3

Determinar si las siguientes entradas se registran en el archivo Svcpack.log:
299.031: Trying CheckVLKForBlock again
299.531: Error: CheckVLKForBlock failed
estas entradas indican que claves del registro dañado o alterado en programas preinstalados están causando el problema.

Nota Un programa que se sabe que causa este problema es Micrografx - imagen Publisher Professional 10. Para evitar este problema, consulte la sección "Solución para la causa 3".

Solución

Para resolver o para evitar estas causas, utilice la resolución o la solución que corresponde a la causa.

Resolución de la causa 1

Para resolver este problema, debe reemplazar la copia actual del archivo Licdll.dll utilizando una copia desde el medio original de Windows XP. Para ello, siga estos pasos:
  1. Inserte el CD de Windows XP en la unidad de CD-ROM.
  2. Haga clic en Salir en el Asistente para instalación en cuanto se inicia.
  3. Haga clic en Inicio y, a continuación, haga clic en Ejecutar .
  4. Copiar y pegar (o tipo) el comando siguiente en el cuadro Abrir y, a continuación, presione ENTRAR:
    explorador
  5. Haga clic en Mi PC .
  6. Anote la letra de unidad que contiene el CD de Windows XP.
  7. Haga clic en Inicio y, a continuación, haga clic en Ejecutar .
  8. Copiar y pegar (o tipo) el comando siguiente en el cuadro Abrir y, a continuación, presione ENTRAR:
    cmd
  9. Escriba o copie y pegue el texto siguiente en la ventana del símbolo del sistema y presione ENTRAR:
    expanda CD_Drive_Letter: \i386\licdll.dl_ C: \Windows\system32\Licdll.dll
    Nota En el comando en el paso 9, reemplace CD_Drive_Letter mediante la letra de unidad real para la unidad que anotó en el paso 6.
  10. Para instalar Windows XP SP3, visite el siguiente sitio Web de Microsoft Windows Update:
    http://windowsupdate.microsoft.com

Resolución de la causa 2

Para resolver este problema, debe reemplazar la entrada de registro de ID de producto incorrecta con el identificador de producto correcto. Para ello, siga los pasos en las secciones "Buscar Nota el identificador del producto"y"identificar y cambiar la entrada de registro de ID de producto".

Busque y anote el identificador del producto

  1. Haga clic en Inicio y, a continuación, haga clic en Ejecutar .
  2. Copiar y pegar (o tipo) el comando siguiente en el cuadro Abrir y, a continuación, presione ENTRAR:
    sysdm.cpl
  3. En la ficha General busque el identificador de producto. El identificador del producto es el número de 20 dígitos que se encuentra en la sección registrado a .
  4. Tenga en cuenta el ID. de producto para utilizar en la sección "Identificar y cambiar la entrada de registro de ID de producto".

Identificar y cambiar la entrada de registro de ID de producto

importante Esta sección, el método o la tarea contiene pasos que indican cómo modificar el registro. Sin embargo, pueden producirse problemas graves si modifica incorrectamente el registro. Por tanto, asegúrese de que siga estos pasos cuidadosamente. Realice una para agregar protección, copia de seguridad del registro antes de modificarlo. A continuación, puede restaurar el registro si se produce un problema. Para obtener más información acerca de cómo realizar una copia de seguridad y restaurar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756Cómo realizar una copia de seguridad y restaurar el registro de Windows
  1. Haga clic en Inicio y, a continuación, haga clic en Ejecutar .
  2. Copiar y pegar (o tipo) el comando siguiente en el cuadro Abrir y, a continuación, presione ENTRAR:
    regedit
  3. Busque y, a continuación, haga clic en la subclave del registro similar a la siguiente subclave del registro:
    HKEY_LOCAL_MACHINE\SYSTEM\WPA\Key-XXXXXXXXXXXXXXXXXXXXX
    Nota La serie de x representa un marcador de posición para una cadena de 21 caracteres.
  4. Puede haber varias subclaves que parecen creados con el formato en el paso 3. Para determinar la subclave correcta, siga estos pasos:
    1. Haga clic en cada subclave en el panel de exploración.
    2. En el panel de detalles, comparar el valor de la cadena para la entrada de registro de ProductID en la columna de datos para el número que anotó en el paso 4 en "Buscar y Nota el identificador del producto" sección.
    3. La subclave del registro cuyo valor de entrada de registro de ProductID coincide con el número que anotó en la sección "Buscar el identificador del producto" es la subclave del registro que desee.
  5. En el panel de exploración, haga clic con el botón secundario en la subclave del registro que identificó en el paso 4 c y, a continuación, haga clic en Exportar .
  6. Guarde la subclave del registro en el escritorio como temp.reg.
  7. Haga clic con el botón secundario en el archivo temp.reg en el escritorio y, a continuación, haga clic en Abrir con .
  8. Haga clic en el Bloc de notas y, a continuación, haga clic en Aceptar .
  9. En el archivo abierto temp.reg, busque el texto siguiente:
    [HKEY_LOCAL_MACHINE\SYSTEM\WPA\Key-XXXXXXXXXXXXXXXXXXXXX]
  10. Reemplace el texto que se menciona en el paso 9 utilizando el texto siguiente:
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion]
  11. Haga clic en archivo , haga clic en Guardar y salga de Bloc de notas.
  12. Haga doble clic en el archivo temp.reg, haga clic en en el cuadro de diálogo cuando se le pida para agregar la información en el registro y, a continuación, haga clic en Aceptar .
  13. Para instalar Windows XP SP3, visite el siguiente sitio Web de Microsoft Windows Update:
    http://windowsupdate.microsoft.com

Resolución de la causa 3

Para resolver este problema, debe eliminar la subclave InprocServer32. Para ello, siga estos pasos:
  1. Haga clic en Inicio y, a continuación, haga clic en Ejecutar .
  2. Copiar y pegar (o tipo) el comando siguiente en el cuadro Abrir y, a continuación, presione ENTRAR:
    regedit
  3. Busque y, a continuación, haga clic en la subclave del registro similar a la siguiente subclave del registro:
    HKEY_CLASSES_ROOT\CLSID\ {00020420-0000-0000-C000-000000000046} \InprocServer32
  4. Haga clic en InprocServer32 . Un valor de cadena con el nombre InprocServer32 se muestra en el panel de detalles. Haga clic en este valor.
  5. En el menú Edición , haga clic en Eliminar y, a continuación, haga clic en .
  6. Editor de registro de salida.
  7. Para instalar Windows XP SP3, visite el siguiente sitio Web de Microsoft Windows Update:
    http://windowsupdate.microsoft.com

Solución para la causa 3

Un programa que se sabe que causan el problema que se menciona en producir 3 es Micrografx - imagen Publisher Professional 10. Para evitar este problema, desinstale temporalmente el programa Micrografx y, a continuación, instalar Windows XP SP3. Una vez completada la instalación de Windows XP SP3, vuelva a instalar el programa Micrografx.

Los productos de terceros que se analizan en este artículo están fabricados por compañías independientes de Microsoft. Microsoft no otorga ninguna garantía, implícita o de otro tipo, sobre el rendimiento o confiabilidad de estos productos.

Propiedades

Id. de artículo: 949384 - Última revisión: martes, 6 de mayo de 2008 - Versión: 4.2
La información de este artículo se refiere a:
  • Service Pack 3 para Microsoft Windows XP
Palabras clave: 
kbmt kbdll kbservicepack kbregistry kbupdate kbexpertisebeginner kbprb kberrmsg kbtshoot KB949384 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 949384

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com