Pesan galat saat Anda mencoba untuk menginstal Windows XP Paket Layanan 3: "Instalasi Paket Layanan 3 tidak selesai" dan "Galat internal terjadi"

Terjemahan Artikel Terjemahan Artikel
ID Artikel: 949384 - Melihat produk di mana artikel ini berlaku.
Perbesar semua | Perkecil semua

Pada Halaman ini

GEJALA

Pada saat Anda mencoba menginstal Windows XP Paket Layanan 3 (SP3), Anda akan menerima pesan galat berikut:
Instalasi Paket Layanan 3 tidak selesai
Jika Anda meng-klik OK pada pesan galat, Anda akan menerima pesan galat berikut ini:
Galat internal terjadi
Lebih lanjut, Anda akan melihat galat berikut yang dilogin di C:\Windows\Svcpack.log file:
165.672: Galat internal terjadi. 165.672: Instalasi Paket Layanan 3 tidak selesai. 165.672: Update.exe extended error code = 0x1ffe054f 165.672: Kode kembali Update.exe dilindungi untuk 0x643 terhadap kepatuhan tindakan kustom MSI
Catatan Pada seluruh artikel ini, map C:\Windows mewakili map yang secara khusus menginstal Windows XP.

PENYEBAB

Galat yang disebutkan di bagian "Gejala" dapat terjadi karena berkas yang tidak dipercaya atau karena kunci registri rusak. Anda dapat memverifikasi penyebab dengan mencari entri terkait di dalam berkas Svcpack.log. Entri khusus akan mengenali penyebab khusus persoalan tersebut, seperti yang disebutkan di bagian "Penyebab" berikut.

Penyebab 1

Menentukan apakah entri berikut dilogin di dalam berkas Svcpack.log:
142.391: CheckVLKForBlock: LIC.dll tidak mempercayai 142.578: Mencoba lagi CheckVLKForBlock 142.594: CheckVLKForBlock: LIC.dll tidak mempercayai 142.594: Galat: CheckVLKForBlock gagal
Entri ini menunjukkan bahwa penyebab persoalan adalah berkas Licdll.dll. Berkas Licdll.dll mungkin telah diubah, rusak, atau tidak dipercaya. Berkas Licdll.dll berada di map berikut:
C:\Windows\System32\

Penyebab 2

Menentukan apakah entri berikut dilogin di dalam berkas Svcpack.log:
211.890: IsSPBetaKey:pLA->lpVtbl->GetProductID Gagal: 0x80004005 213.125: Mencoba lagi CheckVLKForBlock 214.468: Galat: CheckVLKForBlock gagal
Entri berikut meunjukkan informasi ID produk yang salah di dalam registri menyebabkan persoalan.

Penyebab 3

Menentukan apakah entri berikut dilogin di dalam berkas Svcpack.log:
299.031: Mencoba lagi CheckVLKForBlock 299.531: Galat: CheckVLKForBlock gagal
Entri tersebut menunjukkan bahwa kunci registri yang rusak atau diubah di dalam program prainstal menyebabkan persoalan.

Catatan Satu program yang diketahui menyebabkan persoalan ini adalah Micrografx - Picture Publisher Professional 10. Untuk menyelesaikan persoalan ini, baca bagian "Menyelesai\kan Penyebab 3".

PEMECAHAN MASALAH

Untuk menyelesaikan persoalan tersebut, gunakan resolusi atau penyelesaian masalah terkait dengan penyebab.

Resolusi untuk Penyebab 1

Untuk menyelesaikan persoalan ini, Anda harus mengganti salinan berkas Licdll.dll yang berlaku menggunakan salinan dari media Windows XP asli. Untuk melakukannya, ikuti langkah berikut:
  1. Masukkan CD Windows XP ke dalam pengandar CD.
  2. Klik Keluar di dalam Wisaya Penataan segera setelah dimulai.
  3. Klik Mulai menjalankan, dan kemudian klik Jalankan.
  4. Salin kemudian tempel (atau tipe) perintah berikut di kotak Buka, kemudian tekan ENTER:
    explorer
  5. Klik Komputer Saya.
  6. Catatan surat pengandar yang berisi CD Windows XP.
  7. Klik Mulai menjalankan, dan kemudian klik Jalankan.
  8. Salin kemudian tempel (atau tipe) perintah berikut di kotak Buka, kemudian tekan ENTER:
    cmd
  9. Masukkan atau salin dan tempel teks berikut ke dalam jendela Prompt Perintah, kemudian tekan ENTER:
    Rentangkan CD_Drive_Letter:\i386\licdll.dl_ C:\Windows\system32\Licdll.dll
    Catatan Pada perintah di dalam langkah 9, ganti CD_Drive_Letter menggunakan surat pengandar yang sebenarnya untuk pengandar yang tercantum di dalam langkah 6.
  10. Untuk menginstal Windows XP SP3, kunjungi website Pembaruan Microsoft Windows berikut:
    http://update.microsoft.com

Resolusi untuk Penyebab 2

Untuk menyelesaikan persoalan ini, Anda harus megganti entri registri ID produk yang salah dengan ID produk yang benar. Untuk melakukannya, ikuti langkah-langkah di bagian "Temukan dan catat ID produk" dan "Identifikasi dan ubah entri registri ID produk".

Temukan dan catat ID produk

  1. Klik Mulai menjalankan, dan kemudian klik Jalankan.
  2. Salin kemudian tempel (atau tipe) perintah berikut di kotak Buka, kemudian tekan ENTER:
    sysdm.cpl
  3. Di tab Umum temukan ID produk. ID produk berisi 20 nomor digit yang terletak di bawah bagian Terdaftar ke.
  4. Catat ID produk untuk peggunaan di bagian "Identifikasi dan ubah entri registri ID produk".

Identifikasi dan ubah entri registri ID produk

Penting Bagian ini, metode, atau tugas yang memuat langkah-langkah untuk mengubah registri. Namun, masalah yang serius dapat terjadi apabila Anda tidak tepat dalam mengubah registri. Oleh karena itu, pastikan Anda mengikuti langkah-langkah tersebut dengan seksama. Untuk perlindungan tambahan, buat cadangan registri sebelum Anda mengubahnya. Kemudian, Anda dapat memulihkan registri apabila terjadi kesalahan. Untuk informasi lebih lanjut mengenai cara membuat cadangan dan memulihkan registri, klik nomor artikel dibawah ini untuk melihat artikel pada Basis Pengetahuan Microsoft:
322756 Cara membuat cadangan dan memulihkan registri pada Windows (Artikel ini mungkin berisi link ke konten berbahasa Inggris (belum diterjemahkan)).
  1. Klik Mulai menjalankan, dan kemudian klik Jalankan.
  2. Salin kemudian tempel (atau tipe) perintah berikut di kotak Buka, kemudian tekan ENTER:
    regedit
  3. Temukan kemudian klik sub kunci registri yang mirip salah satu sub kunci registri berikut:
    HKEY_LOCAL_MACHINE\SYSTEM\WPA\Key-XXXXXXXXXXXXXXXXXXXXX
    Catatan Seri X mewakili simbol untuk rangkaian 21 karakter.
  4. Mungkin ada beberapa sub kunci yang mirip dengan format pada langkah 3. Untuk menentukan sub kunci yang benar, ikuti langkah-langkah ini:
    1. Klik setiap sub kunci pada jendela navigasi.
    2. Pada jendela terinci, bandingkan nilai string untuk entri registri ProductID pada kolom Data terhadap nomor yang Anda catat pada langkah 4 di bagian "Temukan dan catat ID porduk".
    3. Sub kunci registri yang nilai entri registri ProductID-nya cocok dengan nomor yang Anda catat di bagian "Temukan ID produk" merupakan sub kunci registri yang Anda inginkan.
  5. Di jendela navigasi, klik kanan sub kunci registri yang Anda tetapkan di langkah 4c, kemudian klik Ekspor.
  6. Simpan sub kunci registri ke Desktop sebagai temp.reg.
  7. Klik kanan berkas temp.reg di Desktop, kemudian klik Buka Dengan.
  8. Klik Notepad, dan kemudian klik OK.
  9. Di dalam berkas temp.reg buka, temukan teks berikut:
    [HKEY_LOCAL_MACHINE\SYSTEM\WPA\Key-XXXXXXXXXXXXXXXXXXXXX]
  10. Ganti teks yang ditemukan pada langkah 9 menggunakan teks berikut:
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion]
  11. Klik Berkas, klik Simpan, kemudian keluar dari Notepad.
  12. Klik dua kali berkas temp.reg, klik Ya pada kotak dialog jika Andadiminta untuk menambah informasi ke registri, kemudian klik OK.
  13. Untuk menginstal Windows XP SP3, kunjungi Website Pembaruan Microsoft Windows:
    http://update.microsoft.com

Resolusi untuk Penyebab 3

Untuk menyelesaikan persoalan ini, Anda harus menghapus sub kunci registri InprocServer32. Untuk melakukannya, ikuti langkah berikut:
  1. Klik Mulai menjalankan, dan kemudian klik Jalankan.
  2. Salin kemudian tempel (atau tipe) perintah berikut di kotak Buka, kemudian tekan ENTER:
    regedit
  3. Temukan dan klik sub kunci registri yang mirip dengan sub kunci registri berikut:
    HKEY_CLASSES_ROOT\CLSID\{00020420-0000-0000-C000-000000000046}\InprocServer32
  4. Klik InprocServer32. Nilai string dengan nama InprocServer32 muncul di jendela rincian. Klik nilai ini.
  5. Pada menu Edit , klik Hapus, kemudian klik Ya.
  6. Keluar dari Peninjau Suntingan Registri.
  7. Untuk menginstal Windows XP SP3, kunjungi Website Pembaruan Microsoft Windows:
    http://update.microsoft.com

Penyelesaian Persoaalan untuk Penyebab 3

Satu program yang diketahui menyebabkan persoalan yang disebutkan di Penyebab 3 adalah Micrografx - Picture Publisher Professional 10. Untuk menyelesaikan persoalan ini, sementara hapus dulu program Micrografx, kemudian intal Windows XP SP3. Setelah penginstalan Windows XP SP3 selesai, instal ulang program Micrografx.

Produk pihak ketiga yang dibahas di artikel ini dibuat oleh perusahaan yang independen terhadap Microsoft. Microsoft tidak memberikan garansi, secara tersirat maupun apa pun, berkenaan dengan kinerja atau keandalan produk.

Properti

ID Artikel: 949384 - Kajian Terakhir: 03 Februari 2011 - Revisi: 3.1
Berlaku bagi:
Kata kunci: 
kbdll kbservicepack kbregistry kbupdate kbexpertisebeginner kbprb kberrmsg kbtshoot KB949384

Berikan Masukan

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com