Article ID: 949708 - Last Review: April 10, 2008 - Revision: 1.1

Error message when you call the RenameUser procedure in Hosted Messaging and Collaboration 4.0: "There is no such object on the server"

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SYMPTOMS

You call the RenameUser procedure in the Hosted Active Directory namespace of Microsoft Solution for Hosted Messaging and Collaboration 4.0 to modify the common name of a user. When you do this, a 0x80072030 error is returned. This error corresponds to the following error message:
There is no such object on the server
Note This problem does not occur when you call the RenameUser procedure to modify the user principal name (UPN).

CAUSE

One of the Resource Manager procedures that are called as part of the operation tries to use the previous name of the user. This name was already changed in Active Directory.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Hotfix installation guide

To apply this hotfix, follow these steps:
  1. On the server that is running Microsoft Provisioning Server (MPS), stop the MPS services to make sure that no more requests can be performed on the server. To do this, follow these steps:
    1. Click Start, point to All Programs, point to Administrative Tools, and then click Component Services.
    2. Expand Component Services, expand Computers, expand My Computer, and then expand COM+ Applications.
    3. Right-click Provisioning Engine, click Disable, and then click Shut down.
  2. Start the MPS Deployment Tool.
  3. In the Requirements Status pane, expand Hosted Active Directory, right-click Hosted Active Directory, and then click Uninstall.
  4. Expand MPS Web Services, expand Hosted Active Directory Web Service, right-click the server name, and then click Uninstall.
  5. Click Start Deployment, and then wait for the Deployment Complete dialog box to appear.
  6. Locate the %SystemDrive%\MSIShare folder, and then rename or back up the following .msi files:
    • HostedActiveDirectoryNS.msi
    • HostedActiveDirectoryWS.msi
  7. Replace these two files with the .msi files that are included in the hotfix.
  8. In the MPS Deployment Tool, right-click Hosted Active Directory, and then click Install.
  9. Under Hosted Active Directory Web Service, right-click the MPS server name, and then click Install.
  10. Click Start Deployment, and then wait for the Deployment Complete dialog box to appear.
  11. In the Component Services console, right-click Provisioning Engine, and then click Enable and Start to restart the MPS engine.

Prerequisites

Microsoft Solution for Hosted Messaging and Collaboration 4.0 must be installed before you apply the hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
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File nameFile versionFile sizeDateTimePlatform
Hostedactivedirectoryns.msiNot applicable257,02429-Feb-200804:54Not applicable
Hostedactivedirectoryws.msiNot applicable473,60029-Feb-200804:54Not applicable

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/LN/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Solution for Hosted Messaging and Collaboration 4.0
Keywords: 
kbautohotfix kbexpertiseadvanced kbexpertiseinter kbbug kbfix kbhotfixserver kbqfe KB949708