Un poco el campo de tipo se inesperadamente vuelve a establece el valor predeterminado cuando se ejecuta una regla de flujo de trabajo para actualizar algunos otros campos de un registro de Microsoft Dynamics CRM 4.0 en

Seleccione idioma Seleccione idioma
Id. de artículo: 949732 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

Síntomas

Se produce cuando intenta asignar valores predeterminados a algunos campos de atributo de bit de Microsoft Dynamics CRM 4.0 Workflow Designer, uno o varios de los problemas siguientes:
  • Cuando ejecuta una regla de flujo de trabajo para actualizar algunos otros campos de un registro de Microsoft Dynamics CRM 4.0, un poco el campo de tipo inesperadamente regresará al valor predeterminado.
  • Cuando intenta asignar valores predeterminados a campos de atributo de bits de Microsoft Dynamics CRM 4.0 Workflow Designer, los valores predeterminados no se asignan a algunos campos como se esperaba.
    • Si el campo de atributo de bits está en el formato de cuadro de lista, el valor asignado al campo es indefinido o Nulo .
    • Si el campo de atributo bits está en el formato de casilla de verificación, no se asigna ningún valor al campo.
    • Puede asignar el valor predeterminado a un campo de atributo de bit sólo si el campo está en el formato de botón de opción.

Causa

Este problema se produce porque los campos de atributo de bit se restablecen cuando se desencadena una regla de flujo de trabajo con un registro que se actualiza un campo en otro formulario. Sin embargo, el código de JScript sólo asigna un valor predeterminado a un campo cuyo nombre de clase es el botón de opción. Por lo tanto, si el nombre de clase del campo es cuadro de lista o casilla de verificación, el valor predeterminado no está asignado al campo.

Solución

Este problema se corrigió en la actualización acumulativa de rollup más reciente para Microsoft Dynamics CRM 4.0. Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
949256Revisiones y actualizaciones de Microsoft Dynamics CRM 4.0

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

Para obtener más información sobre la terminología que se utiliza para describir las actualizaciones de software de Microsoft, haga clic en los números de artículo siguientes para verlos en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft
887283Los estándares de nomenclatura de paquete de actualización y revisiones de software de Microsoft Business Solutions CRM

Propiedades

Id. de artículo: 949732 - Última revisión: jueves, 12 de febrero de 2009 - Versión: 3.0
La información de este artículo se refiere a:
  • Microsoft Dynamics CRM 4.0
Palabras clave: 
kbmt kbfix kbautohotfix kbexpertiseinter kbmbsworkflow kbmbscustomization kbmbsmigrate kbqfe kbhotfixserver KB949732 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 949732

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com