Campo de tipo um pouco inesperadamente será definido novamente para o valor padrão quando você executa uma regra de fluxo de trabalho para atualizar outros campos de um registro no Microsoft Dynamics CRM 4.0

ID do artigo: 949732 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Sintomas

Quando você tenta atribuir valores padrão a alguns campos de atributo de bit no Microsoft Dynamics CRM 4.0 Workflow Designer, um ou mais dos seguintes problemas ocorre:
  • Quando você executa uma regra de fluxo de trabalho para atualizar outros campos de um registro no Microsoft Dynamics CRM 4.0, um pouco campo do tipo inesperadamente é definido volta para o valor padrão.
  • Quando você tenta atribuir valores padrão para campos de atributo de bit no criador de fluxo de trabalho do Microsoft Dynamics CRM 4.0, os valores padrão não são atribuídos a alguns campos conforme o esperado.
    • Se o campo atributo bits estiver no formato de caixa de listagem, o valor que é atribuído ao campo é indefinido ou Nulo .
    • Se o campo de atributo de bit estiver no formato de caixa de seleção, nenhum valor é atribuído ao campo.
    • Você pode atribuir o valor padrão para um campo de atributo de bit somente se o campo estiver em formato de botão de opção.

Causa

Esse problema ocorre porque os campos de atributo de bit são redefinidos quando uma regra de fluxo de trabalho é disparada em relação a um registro que atualiza um campo em outro formulário. No entanto, o código JScript apenas atribui um valor padrão a um campo cujo nome de classe é o botão de opção. Portanto, se o nome de classe do campo for caixa de listagem ou caixa de seleção, o valor padrão não é atribuído ao campo.

Resolução

Esse problema é corrigido no pacote cumulativo de atualização cumulativa mais recente para o Microsoft Dynamics CRM 4.0. Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
949256Hotfixes e atualizações do Microsoft Dynamics CRM 4.0

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

Para obter mais informações sobre a terminologia que é usada para descrever as atualizações de software da Microsoft, clique nos números abaixo para ler os artigos na Base de dados de Conhecimento da Microsoft:
824684Descrição da terminologia padrão que é usada para descrever as atualizações de software
887283Padrões de nomenclatura do pacote de Microsoft Business Solutions CRM software hotfix e atualização

Propriedades

ID do artigo: 949732 - Última revisão: quinta-feira, 12 de fevereiro de 2009 - Revisão: 3.0
A informação contida neste artigo aplica-se a:
  • Microsoft Dynamics CRM 4.0
Palavras-chave: 
kbmt kbfix kbautohotfix kbexpertiseinter kbmbsworkflow kbmbscustomization kbmbsmigrate kbqfe kbhotfixserver KB949732 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 949732

Submeter comentários