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The Async service stops unexpectedly or you cannot start the Async service after you import an organization from another Microsoft Dynamics CRM 4.0 deployment

Article ID:949844
Last Review:April 7, 2008
Revision:1.0
Source: Microsoft Support

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RAPID PUBLISHING ARTICLES PROVIDE INFORMATION DIRECTLY FROM WITHIN THE MICROSOFT SUPPORT ORGANIZATION. THE INFORMATION THAT IS CONTAINED HEREIN IS CREATED IN RESPONSE TO EMERGING OR UNIQUE TOPICS, OR IS INTENDED TO SUPPLEMENT OTHER KNOWLEDGE BASE INFORMATION.
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SYMPTOMS

Consider the following scenario in Microsoft Dynamics CRM 4.0. You import an organization from another Microsoft Dynamics CRM 4.0 deployment in Deployment Manager. Then, you start the Async service. In this scenario, you experience one of the following symptoms:
The Async service stops after a period of time. Additionally, the following error message is logged in the event viewer:
Host ComputerName: failed while monitoring asynchronous operations queue. Exception: System.InvalidOperationException: Timeout expired. The timeout period elapsed prior to obtaining a connection from the pool. This may have occurred because all pooled connections were in use and max pool size was reached.
at System.Data.ProviderBase.DbConnectionFactory.GetConnection(DbConnection owningConnection)
at System.Data.ProviderBase.DbConnectionClosed.OpenConnection(DbConnection outerConnection, DbConnectionFactory connectionFactory)
at System.Data.SqlClient.SqlConnection.Open()
at Microsoft.Crm.CrmDbConnection.Open()
at Microsoft.Crm.Asynchronous.JobDataAccess.RetrieveSqlServerName(Guid orgId)
at Microsoft.Crm.Asynchronous.JobDataAccess.ExecuteSelect(IDbCommand selectCommand, String traceFormat)
at Microsoft.Crm.Asynchronous.JobDataAccess.GetNextJob(List`1 maintenanceOrgs, DateTime startCycleTime)
at Microsoft.Crm.Asynchronous.JobDataAccess.SelectJob(DateTime startCycleTime)
at Microsoft.Crm.Asynchronous.JobManager.OnOrgDatabaseMaintenanceTimerEvent(Object sender, ElapsedEventArgs e)
at Microsoft.Crm.Asynchronous.Timer.InvokeElapsed()
at Microsoft.Crm.Asynchronous.Timer.TimerProcessor.ExecuteTimers(Object data)
at System.Threading.ThreadHelper.ThreadStart_Context(Object state)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
at System.Threading.ThreadHelper.ThreadStart(Object obj)"
The Async service cannot be started when you try to start the service in the Service Management Console. Additionally, you receive the following error message:
Could not start the Microsoft Asynchronous Processing Service service on Local Computer.
Error 1053: The service did not respond to the start or control request in a timely fashion.
If you check the CrmAsyncService.exe process in Windows Task Manager, the memory and the CPU time of the CrmAsyncService.exe process is highly consumed.

In the Microsoft SQL server in which you have installed the Microsoft Dynamics CRM databases, the memory and the CPU time of the SQL process is also highly consumed.

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CAUSE

This problem occurs because Microsoft Dynamics CRM 4.0 uses the name of the SQL server that is in the organization table of the mscrm_config database when Microsoft Dynamics CRM 4.0 tries to connect to the SQL server. If the name is lowercase, the Async service cannot correctly process the jobs in the ScaleGroupOrganizationMaintenanceJobs table. The SqlServerName name must be the same as the value that is returned by the @@servername global variable.

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STATUS

Microsoft is aware of this issue and a hotfix is being worked on. This KB will be updated after the hotfix is completed.

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DISCLAIMER

MICROSOFT AND/OR ITS SUPPLIERS MAKE NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY, THE RELIABILITY OR THE ACCURACY OF THE INFORMATION THAT IS CONTAINED IN THE DOCUMENTS AND THE RELATED GRAPHICS PUBLISHED ON THIS WEB SITE (THE “MATERIALS”) FOR ANY PURPOSE.

THE MATERIALS MAY INCLUDE TECHNICAL INACCURACIES OR TYPOGRAPHICAL ERRORS AND MAY BE REVISED AT ANY TIME WITHOUT NOTICE. TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, MICROSOFT AND/OR ITS SUPPLIERS DISCLAIM AND EXCLUDE ALL REPRESENTATIONS, WARRANTIES, AND CONDITIONS WHETHER EXPRESS, IMPLIED OR STATUTORY, INCLUDING BUT NOT LIMITED TO REPRESENTATIONS, WARRANTIES, OR CONDITIONS OF TITLE, NON-INFRINGEMENT, SATISFACTORY CONDITION OR QUALITY, MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE, WITH RESPECT TO THE MATERIALS.

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APPLIES TO
Microsoft Dynamics CRM 4.0

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Keywords: 
kberrmsg kbexpertiseadvanced kbtshoot kbprb kbnomt kbexpertisebeginner kbmbsmigrate kbexpertiseinter KB949844

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