The "Get Programs" dialog box displays a blank program list if you open this dialog box shortly after you start a Windows Vista-based computer that has Configuration Manager 2007 Agent installed

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Article ID: 949863 - View products that this article applies to.
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SYMPTOMS

In a Microsoft System Center Configuration Manager 2007 environment, you have the Configuration Manager Agent installed on a Windows Vista-based client computer. Shortly after you start the computer, you open the Programs and Features item in Control Panel. Then, you click Install a program from the network to open the Get Programs dialog box. However, the Get Programs dialog box displays a blank program list.

This problem occurs only if you open the program list Get Programs dialog box shortly after you start the computer. For example, it occurs when you open the dialog box two minutes after you start the computer. Additionally, this problem occurs even after you close and then reopen the Programs and Features item in Control Panel.

CAUSE

This problem occurs because a timing issue occurs between the SMS Agent Host service (Ccmexec.exe) process and the SMSARPPub.dll module that is loaded in the Explorer.exe process.

RESOLUTION

To resolve this problem, apply this hotfix on Configuration Manager 2007 site servers. After you apply this hotfix, you may still see a blank program list in the Get Programs dialog box if you open the dialog box shortly after you start the computer. However, the program list is correct if you reopen the Get Programs dialog box several minutes later.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
System Center Configuration Manager 2007, x86-based version
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Sccm2007ac-rtm-kb949863-x86.mspNot Applicable2,214,40031-Dec-200719:00Not Applicable
Smsarppub.dll4.0.5931.12556,24831-Dec-200719:00x86
Smsarppub.dll4.0.5931.125522,68031-Dec-200719:00IA-64
Smsarppub.dll4.0.5931.125212,40831-Dec-200719:00x64
System Center Configuration Manager 2007, x64-based version
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Sccm2007ac-rtm-kb949863-x86.mspNot Applicable2,214,40031-Dec-200719:00Not Applicable
Smsarppub.dll4.0.5931.125522,68031-Dec-200719:00IA-64
Smsarppub.dll4.0.5931.125212,40831-Dec-200719:00x64
Smsarppub.dll4.0.5931.12556,24831-Dec-200719:00x86

WORKAROUND

Workaround 1

After you start the Windows Vista-based computer, wait several minutes before you open the Get Programs dialog box.

Workaround 2

End the Explorer.exe process and then start a new instance of Explorer.exe. To do this, follow these steps:
  1. Press CTRL+ALT+DEL.
  2. Click Start Task Manager.
  3. On the Processes tab, click the explorer.exe process in the process list, and then click End Process.
  4. When you are prompted to confirm, click End Process. After you do this, the desktop disappears.
  5. On the File menu, click New Task (Run...), type explorer, and then click OK.
  6. Exit Task Manager.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 949863 - Last Review: October 8, 2011 - Revision: 2.0
APPLIES TO
  • Microsoft System Center Configuration Manager 2007
Keywords: 
kbautohotfix kbexpertiseinter kbbug kbfix kbqfe KB949863

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