ID do artigo: 949969 - Última revisão: terça-feira, 3 de junho de 2008 - Revisão: 1.1

Algumas tabelas de partição de dados que excedem o período de retenção de dados não são groomed do banco de dados Audit Collection Services no Operations Manager 2007

Download do hotfix está disponívelDownload do Hotfix Disponível
Visualizar e solicitar downloads de hotfix
Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Recolher tudo

Sintomas

Considere o seguinte cenário:
  • Você usar o recurso de ACS (Serviços de coleta de auditoria) no Microsoft System Center Operations Manager 2007 para coletar eventos de segurança de computadores gerenciados.
  • Configurar banco de dados limpeza diretivas para o banco de dados ACS.
No entanto, algumas tabelas de partição de dados que excedem o período de retenção de dados não são groomed do banco de dados conforme o esperado. Com o passar do tempo, o banco de dados ACS pode ficar sem espaço em disco.

Quando esse problema ocorre, você pode descobrir que essas tabelas de partição com um status de 1.

Causa

Esse problema ocorre por um ou mais dos seguintes motivos:
  • Quando uma partição está fechando, ACS tenta para calcular o último tempo de inserção de evento para a partição. ACS usa a última vez inserção evento para determinar se a partição é ainda dentro do período de retenção. No entanto, a operação de cálculo pode tempo limite se a partição for muito grande. Nessa situação, ACS salva um horário inválido para o último campo de tempo de inserção de evento.
  • ACS marca o status de partição para 1 (significa que o status de partição é "em transição") quando uma partição está fechando. ACS define o status de partição como 2 (Isso significa que o status de partição é "fechado") somente após a reindexação. No entanto, a operação re-indexing pode expirar se a partição for muito grande. Nessa situação, a partição permanece no status "em transição" indefinidamente.

Resolução

Atualizar informações

Para resolver esse problema, obtenha a versão mais recente do Microsoft System Center Operations Manager 2007. Para obter mais informações, consulte para este site da Microsoft: http://www.microsoft.com/systemcenter/operationsmanager/en/us/how-to-buy.aspx (http://www.microsoft.com/systemcenter/operationsmanager/en/us/how-to-buy.aspx)

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibido, envie uma solicitação para suporte e atendimento ao cliente Microsoft para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Instruções de instalação do hotfix

Para aplicar esse hotfix, execute essas etapas:
  1. Copie o seguinte arquivo do pacote de hotfix para uma pasta local ou para uma pasta compartilhada. Em seguida, execute este arquivo:
    SystemCenterOperationsManager2007-SP1-KB949969-X86-X64-ENU.MSI
  2. Por padrão, esse hotfix está instalado na seguinte pasta:
    %ProgramFiles%\System Utility\Q949969 de Hotfix do Centro de 2007
    A pasta Q949969 contém as seguintes subpastas:
    • Um x 86 subpasta para plataformas x 86
    • Uma subpasta 64 x para plataformas de 64 x
    Abra a subpasta de x 86 ou x 64 subpasta, conforme apropriado para sua situação.
  3. Localize o arquivo AdtSrvDll.dll na seguinte pasta:
    %WINDIR%\system32\Security\AdtServer
  4. Verifique se a versão do arquivo AdtSrvDll.dll é maior que ou igual a versão 6.0.6278.0 e menor que versão 6.0.6278.7. Para fazer isso, clique com o botão direito no arquivo de AdtSrvDll.dll no Windows Explorer e, em seguida, clique em Propriedades . O campo de versão do arquivo na guia versão exibe a versão do arquivo.

    Observação Se a versão do arquivo for maior que ou igual a versão 6.0.6278.7, este arquivo já contém o hotfix atual. Se a versão do arquivo for menor que versão 6.0.6278.0, não é possível aplicar esse hotfix.
  5. No servidor de coletor ACS, pare o serviço de coleção de auditoria do Gerenciador de operações.
  6. Copie os seguintes arquivos da pasta Q949969 para a pasta AdtServer que localizou na etapa 3.
    • AdtSrvdll.dll
    • DbClosePartition.sql
    • DbCreatePartition.sql
    Quando você fizer isso, você substitua os arquivos existentes com os arquivos de hotfix.
  7. No servidor que hospeda o ACS banco de dados ou que tem uma conexão com o banco de dados ACS, abra o SQL Server Management Studio.
  8. No SQL Server Management Studio, se conectar ao banco de dados ACS. Por padrão, o banco de dados ACS for chamado "OperationsManagerAC."
  9. No SQL Server Management Studio, abra uma nova consulta e, em seguida, execute as seguintes instruções:
    OperationsManagerAC de uso
    Atualizar dtPartition definir status = 2 onde status = 1
  10. Verificar se você recebe a seguinte mensagem no painel de resultados:
    (n linhas afetadas)
  11. Reinicie o serviço coleta de auditoria de Gerenciador do operações, que você parou na etapa 5.

Comportamento de hotfix de postagem

Depois de aplicar esse hotfix, o ACS usa a hora de fechamento de partição em vez de na última vez inserção evento para determinar se uma partição excede o período de retenção. Além disso, quando uma partição está fechando, o status da partição é definido de 0 diretamente como 2, em vez de que está sendo definido como 1.

Pré-requisitos

Para aplicar esse hotfix, você deve ter os seguintes pré-requisitos instalados no computador:
  • System Center Operations Manager 2007 Service Pack 1
  • Coletor ACS

Requisitos de reinicialização

Não é necessário reiniciar o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes.

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas no horário de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
System Center Operations Manager 2007, versão com base em 86 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Adtsrvdll.dll6.0.6278.7374,32813 De maio de 200808: 38x 86
Dbclosepartition.SQLNão aplicável4,50327 De março de 200806: 01Não aplicável
Dbcreatepartition.SQLNão aplicável19,56927 De março de 200806: 01Não aplicável
System Center Operations Manager 2007, versão com base em 64 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Adtsrvdll.dll6.0.6278.7566,32813 De maio de 200808: 38x 64
Dbclosepartition.SQLNão aplicável4,50325 De abril de 200801: 21Não aplicável
Dbcreatepartition.SQLNão aplicável19,56925 De abril de 200801: 21Não aplicável

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".Esse problema foi corrigido primeiro no Microsoft System Center Operations Manager 2007 R2.

Mais Informações

Serviços de coleta de auditoria

Serviços de coleta de auditoria (ACS) é uma solução que coleta e armazena eventos do log de eventos de segurança em computadores monitorados. Eventos são armazenados em um banco de dados ACS separado no Microsoft SQL Server 2005. Em seguida, você pode usar um componente de relatório do ACS separado para gerar relatórios dos dados armazenados do ACS. Para obter mais informações, visite o seguinte site da Microsoft TechNet:
http://technet.microsoft.com/en-us/library/bb381258.aspx (http://technet.microsoft.com/en-us/library/bb381258.aspx)
Para obter mais informações sobre terminologia de atualização de software, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684  (http://support.microsoft.com/kb/824684/LN/ ) Descrição da terminologia padrão que é usada para descrever as atualizações de software

Mais Informações

Para uma lista de problemas corrigidos no Microsoft System Center Operations Manager 2007 R2, consulte o seguinte artigo na base de dados de Conhecimento Microsoft:
971410  (http://support.microsoft.com/kb/971410/ ) Lista de problemas corrigidos no System Center Operations Manager 2007 R2

A informação contida neste artigo aplica-se a:
  • Microsoft System Center Operations Manager 2007
Palavras-chave: 
kbmt kbautohotfix kbexpertiseinter kbbug kbfix kbhotfixserver kbqfe KB949969 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 949969  (http://support.microsoft.com/kb/949969/en-us/ )