Some files may be unrecoverable when a hard drive is removed incorrectly or when a hard drive experiences a physical failure on a home server that is running Windows Home Server Power Pack 1

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Article ID: 950193 - View products that this article applies to.
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SYMPTOMS

You have a home server that is running Windows Home Server Power Pack 1. When a hard drive is reported as missing from a health notification in the Windows Home Server Console, files that are in shared folders may be unrecoverable if the shared folders have Folder Duplication enabled.

This issue occurs for one of the following reasons:
  • A hard drive on the home server was removed incorrectly.
  • A hardware failure has occurred on a hard drive.
To avoid this issue, you must use the Remove a Hard Drive Wizard before you physically remove any hard drives from your home server. The Remove a Hard Drive Wizard is available on the Server Storage tab of the Windows Home Server Console.

CAUSE

Windows Home Server helps protect users from the incorrect removal of a hard drive or the physical failure of a hard drive. A bug was discovered that relates to how Windows Home Server Power Pack 1 manages file duplication when a hard drive is incorrectly removed or when a hard drive experiences a hardware failure.

RESOLUTION

An update for Windows Home Server is available on the Microsoft Windows Update Web site.

Update information

How to obtain this update

If the Automatic Updates feature is enabled on your home server, the update will be automatically downloaded to your Windows Home Server computer through Windows Update. Or, in the Windows Home Server Console, you can click Update Now on the General page of your home server Settings.

Prerequisites

To apply this update, you must have Windows Home Server Power Pack 1 installed.

Restart requirement

Your home server will restart automatically after this update is installed from Windows Update.

Update replacement information

This update does not replace a previously released update.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 950193 - Last Review: September 23, 2008 - Revision: 1.0
APPLIES TO
  • Windows Home Server
Keywords: 
kbexpertisebeginner kbexpertiseinter kbbug kbfix kbqfe KB950193

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