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Article ID: 950256 - Last Review: March 19, 2008 - Revision: 1.1

Error message when you install Microsoft Dynamics CRM 4.0: "Microsoft.Crm.CrmReportingException: The request failed with HTTP status 401: Unauthorized. ---> System.Net.WebException: The request failed with HTTP status 401: Unauthorized"

Source: Microsoft Support

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SYMPTOMS

When you install Microsoft Dynamics CRM 4.0, you receive the following error message:

Microsoft.Crm.CrmReportingException: The request failed with HTTP status 401: Unauthorized. ---> System.Net.WebException: The request failed with HTTP status 401: Unauthorized. at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall) at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters) at Microsoft.Crm.ReportingServices2005.ReportingService2005.FindItems(String Folder, BooleanOperatorEnum BooleanOperator, SearchCondition[] Conditions) at Microsoft.Crm.Reporting.ReportServer.FindItemByName(String searchRoot, String name, ItemTypeEnum itemType) --- End of inner exception stack trace --- at Microsoft.Crm.Reporting.ReportServer.FindItemByName(String searchRoot, String name, ItemTypeEnum itemType) at Microsoft.Crm.Reporting.ReportServer.validateRSUrl() at Microsoft.Crm.Reporting.ReportServer.validateServer() at Microsoft.Crm.Setup.Server.ExistingRSValidator.InternalCheck(IDictionary parameters)

CAUSE

This problem can occur if there are Kerberos authentication issues in the environment. This may be caused by invalid Service Principal Names (SPNs), which would affect the authentication to the Microsoft SQL Server Reporting Services.

RESOLUTION

To resolve this problem, configure your environment to trust for Kerberos Delegation by using the following white paper:

"Additional Setup Tasks Required if Reporting Services Is Installed on Different Server"

This white paper explains how to configure Active Directory to trust for Kerberos Delegation. To download this white paper, visit the following Web site. http://www.microsoft.com/downloads/details.aspx?FamilyID=51bf9f20-bd00-4759-8378-b38eefda7b99 (http://www.microsoft.com/downloads/details.aspx?FamilyID=51bf9f20-bd00-4759-8378-b38eefda7b99)

MORE INFORMATION

For more information about how to configure SQL Server 2005 Analysis Services to use Kerberos authentication, click the following article number to view the article in the Microsoft Knowledge Base:
917409  (http://support.microsoft.com/kb/917409/ ) How to configure SQL Server 2005 Analysis Services to use Kerberos authentication

For more information about Kerberos authentication and troubleshooting delegation issues , click the following article number to view the article in the Microsoft Knowledge Base:
907272  (http://support.microsoft.com/kb/907272/ ) Kerberos authentication and troubleshooting delegation issues


For more information about how to configure a Report Server Scale-Out Deployment (Reporting Services Configuration), visit the following Web site: http://msdn2.microsoft.com/en-us/library/ms159114.aspx (http://msdn2.microsoft.com/en-us/library/ms159114.aspx)

For more information about Kerberos authentication for load balanced Web sites, visit the following Web site: http://technet.microsoft.com/en-us/library/cc757299.aspx (http://technet.microsoft.com/en-us/library/cc757299.aspx)

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APPLIES TO
  • Microsoft Dynamics CRM 4.0
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