Article ID: 950416 - Last Review: June 11, 2009 - Revision: 2.1

System Jobs that are triggered in Microsoft Dynamics CRM are not processed and remain in a waiting state and Outlook clients cannot connect to the Microsoft Dynamics CRM Server

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SYMPTOMS

System Jobs that are triggered in Microsoft Dynamics CRM are not processed and remain in a waiting state. Also the Microsoft Dynamics CRM Clients for Outlook will not connect to the Microsoft Dynamics CRM Server.

CAUSE

This problem occurs because of the following causes:

Cause 1

The Async service cannot connect to the server. By default, the AsyncSDKRootDomain field in the DeploymentProperties table is left blank. This means, when the Async service tries to connect to the server, it uses the loopback address of 127.0.0.1. However, the CRM Web site is now using an assigned IP address, the Async service cannot connect to the server.

Cause 2

The Microsoft CRM Asynchronous Processing Service cannot connect to the Microsoft Dynamics CRM Web site after the required SSL setting was enabled on the Web site.

RESOLUTION

Resolution for Cause 1

To resolve this problem, follow these steps:
  1. Make sure that a HOST (A) record has been created in DNS and point to the IP address assigned to the CRM Web site.
  2. Download the Deployment Configuration tool.

    For more information, click the following article number to view the article in the Microsoft Knowledge Base:
    949079  (http://support.microsoft.com/kb/949079/ ) How to use the Microsoft Dynamics CRM Deployment Configuration tool for Microsoft Dynamics CRM 4.0
  3. Extract the Deployment Configuration tool, and put it in the location on the CRM server.
  4. Back up the MSCRM_Config and OrgName_MSCRM databases.
  5. At command prompt, path out to the directory that contains the microsoft.crm.deploymentconfigtool.exe file, and then run the following commands to correct this setting:
    microsoft.crm.deploymentconfigtool asyncsettings update -sdkrootdomain:<IPADDRESSOFTHECRMWEBSITE>
    microsoft.crm.deploymentconfigtool addresssettings update -webapprootdomain:<IPADDRESSOFTHECRMWEBSITE>
    microsoft.crm.deploymentconfigtool addresssettings update -sdkrootdomain:<IPADDRESSOFTHECRMWEBSITE>
    
    Note <IPADDRESSOFTHECRMWEBSITE> is a placeholder for the actual IP address that is assigned to the CRM Web site.

    To confirm the IP address, follow these steps:
    1. Open IIS Manager and locate the CRM Web site.
    2. Right-click the CRM Web site, and then click Properties.
    3. On the Web Site tab, notice the IP Address that is set in the IP Address field.
    So, the command should resemble the following:
    microsoft.crm.deploymentconfigtool asyncsettings update -sdkrootdomain: 192.167.0.0
    microsoft.crm.deploymentconfigtool addresssettings update -webapprootdomain: 192.167.0.0
    microsoft.crm.deploymentconfigtool addresssettings update -sdkrootdomain: 192.167.0.0
    
  6. Reset IIS. To do this, click Start, click Run, type iisreset, and then click OK.
  7. Existing Microsoft CRM Outlook clients may not reconnect to the server. To correct this problem, follow these steps:
    1. Close Outlook on the Microsoft Dynamics CRM client computer.
    2. Click Start, point to All Programs, point to Microsoft Dynamics CRM, and then click Configuration Wizard.
    3. Follow the configuration wizard and make sure that the new name of the HOST record mentioned in step 1 is defined.
  8. Make sure that Kerberos is passing correctly.
  9. Make sure that you add the IP address and the new HOST name in the Local intranet zone of the Internet Explorer options. To do this, follow these steps:
    1. Open Internet Explorer.
    2. On the Tools menu, click Internet Options.
    3. On the Security tab, click Local Intranet, and then click Sites.
    4. Click Advanced.
    5. In the Add this Web site to the zone field, enter the CRM IP address, HOST name, and FQDN of the HOST name. For example, http://crmwebsiteipaddress.
    6. Click Add.
    7. Close the Local intranet window.
Resolution for Cause 2

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows
To resolve this problem, follow these steps:
  1. Click Start, click Run, type regedit in the Open box, and then click OK.
  2. Locate and then click to select the following registry subkey:
    HKEY_LOCAL_MACHINE\Software\Microsoft\MSCRM
  3. Right-click LocalSdkPort, and then click Modify.
  4. In the Value data box, type 443, and then click OK.

    Note If you use a different port, type the port you use for SSL.
  5. Right-click ServerUrl, and then click Modify.
  6. In the Value data box, type https://crmservername/MSCRMServices, and then click OK.
  7. On the File menu, click Exit to exit Registry Editor.
  8. Click Start, click Run and type in IISRESET in the Open box and then click OK to reset IIS.
  9. For each of the Microsoft Dynamics CRM Clients for Outlook you will need to run the configuration wizard to reconfigure the clients with the https URL since SSL is now required.

    A second option would be to update each of the client registry subkeys to contain https in the HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient registry hive. The following are the registry subkeys:
    • DiscoveryURL
    • ExtranetDiscoveryURL
    • ExtranetServerURL
    • ExtranetWebAppURL
    • IntranetDiscoveryURL
    • IntranetServerUrl
    • IntranetWebAppUrl
    • ServerURL
    • WebAppURL

REFERENCES

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
947423  (http://support.microsoft.com/kb/947423/ ) How to update the Microsoft Dynamics CRM Web site port after you install Microsoft Dynamics CRM 4.0

APPLIES TO
  • Microsoft Dynamics CRM 4.0
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