Artigo: 950416 - Última revisão: quinta-feira, 11 de Junho de 2009 - Revisão: 2.1

Tarefas de sistema que disparou no Microsoft Dynamics CRM não serão processadas e permanecem no estado de espera e clientes do Outlook não é possível estabelecer ligação com o Microsoft Dynamics CRM Server

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Sintomas

Tarefas de sistema são accionadas no Microsoft Dynamics CRM não serão processadas e permanecem em estado de espera. Também a clientes do Microsoft Dynamics CRM para Outlook não irá ligar ao Microsoft Dynamics CRM Server.

Causa

Este problema ocorre devido às seguintes causas:

Causa 1

O serviço assíncrono não é possível ligar ao servidor. Por predefinição, o campo de AsyncSDKRootDomain na tabela DeploymentProperties é deixado em branco. Isto significa, quando o serviço assíncrono tenta ligar ao servidor utiliza o endereço de loopback 127.0.0.1. No entanto, o Web site do CRM agora utiliza um endereço IP atribuído, o serviço assíncrono não é possível ligar ao servidor.

Causa 2

O serviço do Microsoft assíncrona processamento CRM não consegue ligar ao site do Microsoft Dynamics CRM depois da definição de SSL necessária foi activada no Web site.

Resolução

resolução para a causa 1

Para resolver este problema, siga estes passos:
  1. Certifique-se de que foi criado um registo de anfitrião (A) no DNS e aponte para o endereço IP atribuído o Web site do CRM.
  2. Transfira a ferramenta configuração de implementação.

    Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
    949079  (http://support.microsoft.com/kb/949079/ ) Como utilizar a ferramenta de configuração de implementação do Microsoft Dynamics CRM para Microsoft Dynamics CRM 4.0
  3. Extraia a ferramenta ' Configuração de implementação e colocá-la na localização no servidor do CRM.
  4. Cópia de segurança de bases de dados MSCRM_Config e OrgName_MSCRM.
  5. Na linha de comandos, caminho saída para o directório que contém o ficheiro microsoft.crm.deploymentconfigtool.exe e, em seguida, execute os seguintes comandos para corrigir esta definição: actualizar asyncsettings -
    microsoft.crm.deploymentconfigtool asyncsettings update -sdkrootdomain:<IPADDRESSOFTHECRMWEBSITE>
    microsoft.crm.deploymentconfigtool addresssettings update -webapprootdomain:<IPADDRESSOFTHECRMWEBSITE>
    microsoft.crm.deploymentconfigtool addresssettings update -sdkrootdomain:<IPADDRESSOFTHECRMWEBSITE>
    
    Nota <ipaddressofthecrmwebsite> é um marcador para o endereço IP real atribuído ao Web site do CRM.

    Para confirmar o endereço IP, siga estes passos:
    1. Abra O Gestor de IIS e localize o Web site do CRM.
    2. Clique com o botão direito do rato no CRM Web site e, em seguida, clique em Propriedades .
    3. No separador Web Site , repare o endereço IP que está definido no campo Endereço IP .
    Assim, o comando deverá assemelhar-se o seguinte:
    microsoft.crm.deploymentconfigtool asyncsettings update -sdkrootdomain: 192.167.0.0
    microsoft.crm.deploymentconfigtool addresssettings update -webapprootdomain: 192.167.0.0
    microsoft.crm.deploymentconfigtool addresssettings update -sdkrootdomain: 192.167.0.0
    
  6. Reinicie o IIS. Para o fazer, clique em Iniciar , clique em Executar , escreva iisreset e, em seguida, clique em OK .
  7. Clientes do Microsoft CRM Outlook existentes não podem religar ao servidor. Para corrigir este problema, siga estes passos:
    1. Feche o Outlook no computador de cliente do Microsoft Dynamics CRM.
    2. Clique em Iniciar , aponte para Todos os programas , aponte para Microsoft Dynamics CRM e, em seguida, clique em Assistente de configuração .
    3. Siga o Assistente de configuração e certifique-se de que o novo nome do anfitrião registo mencionado no passo 1 está definido.
  8. Certifique-se de que Kerberos é transmitir correctamente.
  9. Certifique-se que adiciona o endereço IP e o novo nome de anfitrião na zona intranet local de opções do Internet Explorer. Para o fazer, siga estes passos:
    1. Abra o Internet Explorer.
    2. No menu Ferramentas , clique em Opções da Internet .
    3. No separador segurança , clique em Intranet Local e, em seguida, clique em sites .
    4. Clique em Avançadas .
    5. No campo Adicionar este Web site à zona , introduza o endereço IP CRM, o nome HOST e o FQDN do nome do HOST. Por exemplo, http://crmwebsiteipaddress.
    6. Clique em Adicionar .
    7. Feche a janela de intranet local.
resolução para a causa 2

importante Esta secção, método ou tarefa contém passos que indicam como modificar o registo. No entanto, poderão ocorrer problemas graves se modificar o registo de forma incorrecta. Por conseguinte, certifique-se de que segue estes passos cuidadosamente. Criar uma para protecção adicional, cópia de segurança do registo antes de o modificar. Em seguida, pode restaurar o registo se ocorrer um problema. Para obter mais informações sobre como efectuar uma cópia de segurança e restaurar o registo, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) Como efectuar uma cópia de segurança e restaurar o registo no Windows
Para resolver este problema, siga estes passos:
  1. Clique em Iniciar , clique em Executar , escreva regedit na caixa Abrir e, em seguida, clique em OK .
  2. Localize e, em seguida, clique para seleccionar a seguinte subchave do registo:
    HKEY_LOCAL_MACHINE\Software\Microsoft\MSCRM
  3. Clique com o botão direito do rato LocalSdkPort e, em seguida, clique em Modificar .
  4. Na caixa dados do valor , escreva 443 e, em seguida, clique em OK .

    Nota Se utilizar uma porta diferente, escreva a porta utilizada para SSL.
  5. Clique com o botão direito do rato ServerUrl e, em seguida, clique em Modificar .
  6. Na caixa dados do valor , escreva https:// crmservername / MSCRMServices e, em seguida, clique em OK .
  7. No menu ficheiro , clique em Sair para sair do Editor de registo.
  8. Clique em Iniciar , clique em Executar e escreva IISRESET na caixa Abrir e, em seguida, clique em OK para repor o IIS.
  9. Para cada a clientes do Microsoft Dynamics CRM para Outlook, terá de executar o Assistente de configuração para reconfigurar os clientes com o URL de https, uma vez que o SSL é agora necessário.

    Segunda opção seria actualizar cada uma das subchaves de registo cliente para conter https no ramo de registo HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient. Seguem-se as subchaves de registo:
    • DiscoveryURL
    • ExtranetDiscoveryURL
    • ExtranetServerURL
    • ExtranetWebAppURL
    • IntranetDiscoveryURL
    • IntranetServerUrl
    • IntranetWebAppUrl
    • ServerURL
    • WebAppURL

Referências

Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
947423  (http://support.microsoft.com/kb/947423/ ) Como actualizar a porta de site Web Microsoft Dynamics CRM depois de instalar o Microsoft Dynamics CRM 4.0

A informação contida neste artigo aplica-se a:
  • Microsoft Dynamics CRM 4.0
Palavras-chave: 
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