ID do artigo: 950416 - Última revisão: quinta-feira, 11 de junho de 2009 - Revisão: 2.1

Trabalhos de sistema que disparou no Microsoft Dynamics CRM não são processados e permanecem em um estado de espera e os clientes Outlook não é possível conectar-se o servidor do Microsoft Dynamics CRM

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Sintomas

Trabalhos de sistema que disparou no Microsoft Dynamics CRM não são processados e permanecem em um estado de espera. Também se os de clientes o Microsoft Dynamics CRM para Outlook não conectará ao servidor do Microsoft Dynamics CRM.

Causa

Esse problema ocorre devido as seguintes causas:

causa 1

O serviço assíncrono não é possível se conectar ao servidor. Por padrão, o campo AsyncSDKRootDomain na tabela DeploymentProperties for deixado em branco. Isso significa que, quando o serviço assíncrono tenta se conectar ao servidor, ele usa o endereço de auto-retorno 127.0.0.1. No entanto, o site do CRM agora está usando um endereço IP atribuído, o serviço assíncrono não é possível conectar ao servidor.

causa 2

O serviço processamento do Microsoft CRM assíncrona não é possível conectar ao site a Web do Microsoft Dynamics CRM após a configuração de SSL necessária foi ativada no site da Web.

Resolução

resolução para a causa 1

Para resolver esse problema, execute essas etapas:
  1. Certifique-se de que um registro de HOST (A) foi criado no DNS e aponte para o endereço IP atribuído ao site do CRM.
  2. Baixe a ferramenta Configuração da implantação.

    Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
    949079  (http://support.microsoft.com/kb/949079/ ) Como usar o Microsoft Dynamics CRM Deployment Configuration tool para Microsoft Dynamics CRM 4.0
  3. Extraia a ferramenta Configuração da implantação e colocá-lo no local no servidor do CRM.
  4. Fazer backup de bancos de dados MSCRM_Config e OrgName_MSCRM.
  5. No prompt de comando, caminho saída para o diretório que contém o arquivo microsoft.crm.deploymentconfigtool.exe e execute os seguintes comandos para corrigir essa configuração: asyncsettings atualizar -
    microsoft.crm.deploymentconfigtool asyncsettings update -sdkrootdomain:<IPADDRESSOFTHECRMWEBSITE>
    microsoft.crm.deploymentconfigtool addresssettings update -webapprootdomain:<IPADDRESSOFTHECRMWEBSITE>
    microsoft.crm.deploymentconfigtool addresssettings update -sdkrootdomain:<IPADDRESSOFTHECRMWEBSITE>
    
    Observação <ipaddressofthecrmwebsite> é um espaço reservado para o endereço IP real que é atribuído ao site do CRM.

    Para confirmar o endereço IP, execute estas etapas:
    1. Abra O Gerenciador do IIS e localize o site do CRM.
    2. Clique com o botão direito do mouse o site do CRM e, em seguida, clique em Propriedades .
    3. Na guia Site , observe o endereço IP que é definido no campo Endereço IP .
    Assim, o comando deve ter o seguinte aspecto:
    microsoft.crm.deploymentconfigtool asyncsettings update -sdkrootdomain: 192.167.0.0
    microsoft.crm.deploymentconfigtool addresssettings update -webapprootdomain: 192.167.0.0
    microsoft.crm.deploymentconfigtool addresssettings update -sdkrootdomain: 192.167.0.0
    
  6. Redefina o IIS. Para fazer isso, clique em Iniciar , clique em Executar , digite iisreset e, em seguida, clique em OK .
  7. Clientes existentes do Microsoft CRM para Outlook não poderá reconectar ao servidor. Para corrigir esse problema, execute essas etapas:
    1. Feche o Outlook no computador cliente Microsoft Dynamics CRM.
    2. Clique em Iniciar , aponte para Todos os programas , aponte para Microsoft Dynamics CRM e, em seguida, clique em Assistente de configuração .
    3. Siga o Assistente de configuração e certifique-se que o novo nome do registro HOST mencionado na etapa 1 está definido.
  8. Certifique-se que o Kerberos está passando corretamente.
  9. Certifique-se de que você adicionar o endereço IP e o novo nome HOST na zona intranet local de opções do Internet Explorer. Para fazer isso, execute as seguintes etapas:
    1. Abra o Internet Explorer.
    2. No menu Ferramentas , clique em Opções da Internet .
    3. Na guia segurança , clique em Intranet Local e, em seguida, clique em sites .
    4. Clique em Avançadas .
    5. No campo Adicionar este site à zona , digite o endereço IP do CRM, nome HOST e o FQDN do nome do HOST. Por exemplo, http://crmwebsiteipaddress.
    6. Clique em Adicionar .
    7. Feche a janela de intranet local.
resolução para a causa 2

importante Esta seção, método ou tarefa contém etapas que informam sobre como modificar o registro. No entanto, sérios problemas poderão ocorrer se você modificar o registro incorretamente. Por isso, certifique-se que você execute essas etapas cuidadosamente. Para proteção adicional, fazer backup do registro antes de modificá-lo. Em seguida, você pode restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup e restaurar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
322756  (http://support.microsoft.com/kb/322756/ ) Como fazer backup e restaurar o registro no Windows
Para resolver esse problema, execute essas etapas:
  1. Clique em Iniciar , clique em Executar , digite regedit na caixa Abrir e, em seguida, clique em OK .
  2. Localize e, em seguida, clique para selecionar a seguinte subchave do Registro:
    HKEY_LOCAL_MACHINE\Software\Microsoft\MSCRM
  3. Clique com o botão direito do mouse LocalSdkPort e, em seguida, clique em Modificar .
  4. Na caixa dados do valor , digite 443 e, em seguida, clique em OK .

    Observação Se você usar uma porta diferente, digite a porta usada para SSL.
  5. Clique com o botão direito do mouse ServerUrl e, em seguida, clique em Modificar .
  6. Na caixa dados do valor , digite https:// crmservername / MSCRMServices e em seguida, clique em OK .
  7. No menu arquivo , clique em Sair para sair do Editor do Registro.
  8. Clique em Iniciar , clique em Executar e digite IISRESET na caixa Abrir e, em seguida, clique em OK para redefinir o IIS.
  9. Para cada um dos clientes de CRM do Microsoft Dynamics para Outlook, você precisará executar o Assistente de configuração para reconfigurar os clientes com a URL de https como o SSL é agora necessário.

    Uma segunda opção seria atualizar cada uma das subchaves cliente para conter https no hive do Registro HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient. A seguir estão as subchaves do Registro:
    • DiscoveryURL
    • ExtranetDiscoveryURL
    • ExtranetServerURL
    • ExtranetWebAppURL
    • IntranetDiscoveryURL
    • IntranetServerUrl
    • IntranetWebAppUrl
    • ServerURL
    • WebAppURL

Referências

Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
947423  (http://support.microsoft.com/kb/947423/ ) Como atualizar a porta de site Web do Microsoft Dynamics CRM após a instalação do Microsoft Dynamics CRM 4.0

A informação contida neste artigo aplica-se a:
  • Microsoft Dynamics CRM 4.0
Palavras-chave: 
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Clique aqui para ver a versão em Inglês deste artigo: 950416  (http://support.microsoft.com/kb/950416/en-us/ )