Der Bericht "Anforderung Komponenten installiert" angibt, dass die Visual C++-Runtime-Komponenten bei der Installation von Microsoft Dynamics CRM 4.0 fehlen

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 950421 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Alles erweitern | Alles schließen

Auf dieser Seite

Problembeschreibung

Wenn Sie Microsoft Dynamics CRM 4.0 installieren, wird im Bericht "installierte Komponenten der Anforderung" angegeben, dass die Microsoft Visual C++-Runtime-Komponenten fehlen. Die Visual C++-Runtime-Komponenten sind jedoch bereits auf dem Computer installiert auf denen Microsoft Dynamics CRM installiert.

Ursache

Dieses Problem tritt auf, da das Setup-Programm von Microsoft Dynamics CRM die Visual C++-Runtime-Komponenten installieren muss, selbst wenn die Komponenten bereits installiert sind.

Lösung

Um dieses Problem zu beheben, verwenden Sie eine der folgenden Methoden.

Methode 1

Wenn der Computer über eine Internetverbindung verfügt, können Sie die Meldung ignorieren. Das Setup-Programm von Microsoft Dynamics CRM 4.0 automatisch downloadet und installiert die Visual C++-Runtime-Komponenten.

Methode 2

Wenn Sie Microsoft Dynamics CRM für Microsoft Office Outlook, Microsoft SQL Server Reporting Services Data Connector und e-Mail-Router auf einem Computer, die nicht über eine Internetverbindung verfügt installieren müssen, gehen Sie folgendermaßen vor.

Wie installiere ich Microsoft Dynamics CRM für Microsoft Office Outlook

  1. Erstellen Sie auf einem anderen Computer, die eine Internetverbindung verfügt einen Ordner mit dem Namen ClientInstall.
  2. Laden Sie die Microsoft Dynamics CRM 4.0 Client. Bei Verwendung von Microsoft Dynamics CRM 4.0 On-Premise Herunterladen der Microsoft Dynamics CRM 4.0 nach Installationsdateien Microsoft Office Outlook für Microsoft Dynamics CRM 4.0 Online. Besuchen Sie hierzu die folgende Microsoft-Website:
    http://www.Microsoft.com/downloads/details.aspx?displaylang=de & FamilyID =?FamilyID = 60c4a6cc-59 d 7-416e-9f44-0ae8ff249768 & DisplayLang = de
    Wenn Sie Microsoft Dynamics CRM Online verwenden, für Microsoft Office Outlook unterladen Sie Microsoft Dynamics CRM Online her Installationsdateien. Besuchen Sie hierzu die folgende Microsoft-Website:
    http://www.Microsoft.com/downloads/details.aspx?displaylang=de & FamilyID =?FamilyID = e8e6c81a-b7b2-4e57-8599-604967617396 & DisplayLang = de
  3. Extrahieren der Installationsdateien in einen Ordner mit dem Namen Client, und dann diesen Ordner in den Ordner, den Sie in Schritt 1 erstellt haben.
  4. Downloaden Sie "Visual C++ 2005 SP1 Redistributable" Paket aus dem Microsoft Downloadcenter. Gehen Sie dazu folgendermaßen vor:
    1. Die folgende Microsoft-Website, und suchen Sie nach "Visual C++ 2005 SP1 Redistributable Package:"
      http://www.Microsoft.com/downloads/search.ASP?
    2. Laden Sie die 32-Bit-Version oder die 64-Bit-Version über die "Visual C++ 2005 SP1 Redistributable" Paket, das Betriebssystem des Clients entspricht.
    Hinweis Sie erhalten auch das "Visual C++ 2005 SP1 Redistributable" Paket von der Microsoft Dynamics CRM 4.0 Installations-DVD.
  5. Erstellen Sie die folgende Ordnerstruktur in den Ordner, den Sie in Schritt 1 erstellt haben:
    \Redist\i386\VcRedist
    Hinweis Sie können nicht diesen Schritt überspringen, da das Setup-Programm des Pakets "Visual C++ 2005 SP1 Redistributable" installierten-Status nicht erkennen kann.
  6. Setzen Sie die heruntergeladenen Dateien in Schritt 4 in den Ordner, den Sie in Schritt 5 erstellt haben. Können nun entweder den Ordner, den Sie in Schritt 1 auf CD erstellt brennen oder können Sie den Ordner auf einer Netzwerkfreigabe, auf die Benutzer zugreifen können.

Bitte beachten Sie:

Wenn Sie versuchen, Microsoft Dynamics CRM 4.0 für Microsoft Office Outlook mit Offline-Zugriff zu installieren, auf einem Computer mit Windows 7 die keinen Zugang zum Internet, Sie müssen die folgenden Schritte ausführen.

1. Erstellen Sie 1. einen Ordner namens ClientInstall.

2. Vom Installationsmedium verschieben Sie den gesamten Client-Ordner hier.

(3) Erstellen Sie einen Ordner namens Redist, in den Ordner ClientInstall.

4. Vom Installationsmedium verschieben Sie den gesamten i386-Ordner in den Redist-Ordner.

E-Mail-Router installieren

  1. Erstellen Sie auf einem anderen Computer, die eine Internetverbindung verfügt einen Ordner mit dem Namen "E-Mail-Router CRM 4.0".
  2. Download der Microsoft Dynamics CRM 4.0 E-mail-Router. Besuchen Sie hierzu die folgende Microsoft-Website:
    http://www.Microsoft.com/downloads/details.aspx?displaylang=de & FamilyID =?FamilyId = E1358499-3FDB-45B8-ADF0-7585F758277E & Displaylang = de
  3. Extrahieren Sie die Installationsdateien in den Ordner, den Sie in Schritt 1 erstellt haben.
  4. Downloaden Sie "Visual C++ 2005 SP1 Redistributable" Paket aus dem Microsoft Downloadcenter. Gehen Sie dazu folgendermaßen vor:
    1. Die folgende Microsoft-Website, und suchen Sie nach "Visual C++ 2005 SP1 Redistributable":
      http://www.Microsoft.com/downloads/search.ASP?
    2. Laden Sie die 32-Bit-Version oder die 64-Bit-Version des "Visual C++ 2005 SP1 Redistributable" Pakets, das die CRM-Sprachversion.

      Hinweis Sie erhalten auch das "Visual C++ 2005 SP1 Redistributable" Paket von der Microsoft Dynamics CRM 4.0 Installations-DVD.
  5. Setzen Sie das Paket "Visual C++ 2005 SP1 Redistributable" in einen neuen Ordner mit dem Namen VcRedist, und dann kopieren Sie und fügen Sie ihn in den Ordner "E-mail-Router CRM 4.0".
  6. Kopieren Sie den Ordner "E-mail-Router CRM 4.0", auf dem Desktop des Computers, der keine Internetverbindung haben, und führen Sie die Setupexchange.msi-Datei.

SRS Data Connector installieren

  1. Auf einem anderen Computer mit eine Internetverbindung, das "Visual C++ 2005 SP1 Redistributable" Paket aus dem Microsoft Download Center herunterladen. Gehen Sie dazu folgendermaßen vor:
    1. Die folgende Microsoft-Website, und suchen Sie nach "Visual C++ 2005 SP1 Redistributable":
      http://www.Microsoft.com/downloads/search.ASP?
    2. Laden Sie die 32-Bit-Version oder die 64-Bit-Version des "Visual C++ 2005 SP1 Redistributable" Pakets, das die CRM-Sprachversion.

      Hinweis Sie erhalten auch das "Visual C++ 2005 SP1 Redistributable" Paket von der Microsoft Dynamics CRM 4.0 Installations-DVD.
  2. Setzen Sie das "Visual C++ 2005 SP1 Redistributable" Paket in einen neuen Ordner mit dem Namen VcRedist.
  3. Kopieren Sie den Ordner SRSDataConnector aus der Microsoft Dynamics CRM 4.0 Installations-DVD, und fügen Sie ihn auf dem Desktop des Computers, die nicht über eine Internetverbindung verfügt.
  4. Kopieren Sie den VcRedist-Ordner in den Ordner SRSDataConnector, und führen Sie die SRSDataConnector.msi-Datei.

Eigenschaften

Artikel-ID: 950421 - Geändert am: Donnerstag, 8. März 2012 - Version: 0.1
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Dynamics CRM 4.0
Keywords: 
kbmbsinstallation kbexpertisebeginner kbtshoot kbmbsmigrate kbprb kbexpertiseinter kbmt KB950421 KbMtde
Maschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 950421
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com