Error message when a user clicks the hyperlink in the invitation e-mail that is generated when you add the user to a group in Windows SharePoint Services 3.0 or in SharePoint Portal Server 2007

Article translations Article translations
Article ID: 950442 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

You use the Send welcome e-mail to new users option to add a user account to a SharePoint group in Microsoft Windows SharePoint Services 3.0 or in Microsoft Office SharePoint Portal Server 2007. After you do this, the user receives an invitation e-mail that includes a hyperlink to the group home page. However, when the user clicks the hyperlink, the user receives the following error message:

In Internet Explorer 6
The page cannot be displayed.
In Windows Internet Explorer 7
The address is not valid.
For example, the invitation e-mail that is generated resembles the following message:
Welcome to the 'Group_Name' SharePoint group. Display_Name (SHAREPOINT\Account_ID) has added you to the 'Group_Name' group for this SharePoint site. Group description: Use this group to give people contribute permissions to the SharePoint site: Site_Name
In this example, the Site_Name entry is the hyperlink that causes the error.

CAUSE

This issue occurs because the hyperlink is generated as a relative URL. The following two examples show this in more detail.

Example 1

If the group home page is located at the root of the Web site that is named http://SharePoint_Site_Name, the generated hyperlink resembles the following:
/
This generates the following address in the Web browser:
http:///
Example 2

If the group home page is located at a Web site that is named http://SharePoint_Site_Name/Test, the generated hyperlink resembles the following:
/Test
This generates the following address in the Web browser:
http:///test

RESOLUTION

If you are using Windows SharePoint Services 3.0 or SharePoint Portal Server 2007, follow the steps in the "Install Windows SharePoint Services 3.0 SP1" section to resolve this issue.

This issue reoccurs if you install any hotfix or update that is post-Windows SharePoint Services 3.0 Service Pack 1 (SP1). In this case, follow the steps in the "Workaround" section to work around the issue.

Install Windows SharePoint Services 3.0 SP1

You can resolve this issue by installing Windows SharePoint Services 3.0 SP1. After you install this service pack, the hyperlink is not generated in the invitation message. The title of the site is displayed as plain text in the message.

To download Windows SharePoint Services 3.0 SP1, visit the following Microsoft Web site:
http://www.microsoft.com/downloads/details.aspx?FamilyID=4191a531-a2e9-45e4-b71e-5b0b17108bd2&displaylang=en

WORKAROUND

To work around this issue, remove the additional slash mark (/) in the address bar of the Web browser, and then add the name of the SharePoint Web site. The following examples show how to do this.

Important If you do not know the name of the SharePoint Web site, contact the administrator of the Web site.

Example 1

After you receive the error message, use the following URL in the Web browser:
http://SharePoint_Site_Name
Example 2

After you receive the error message, use the following URL in the Web browser:
http://SharePoint_Site_Name/test/

STATUS

Microsoft is researching this problem and will post more information in this article when the information becomes available.

Properties

Article ID: 950442 - Last Review: April 21, 2008 - Revision: 1.0
APPLIES TO
  • Microsoft Windows SharePoint Services 3.0
  • Microsoft Office SharePoint Server 2007
Keywords: 
kberrorsandwarnings kbemail kberrmsg kbtshoot kbexpertiseadvanced KB950442

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com