Synchrone Plug-Ins reagieren nicht auf die Ereignisse, die in Microsoft Dynamics CRM 4.0 ausgelöst werden

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 950542 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Alles erweitern | Alles schließen

Problembeschreibung

Wenn Sie synchrone Plug-ins in einer Microsoft Dynamics bereitstellen CRM 4.0-Server darauf konfiguriert ist, verwenden Sie ein Host-Header, führen Sie die synchrone Plug-ins reagiert nicht auf die Ereignisse, die ausgelöst werden Microsoft Dynamics CRM 4.0.

Im Ereignis-Viewer und Plattform-Ablaufverfolgungen können Fehler, die etwa wie folgt angezeigt werden:
  • Stack-Trace-Info: [WebException: die Anforderung ist mit HTTP-Status 400: Ungültige Anforderung.]
    am Microsoft.Crm.Extensibility.SdkTypeProxyCrmServiceWrapper.InternalInvoke (MethodInfo, MethodInfo, Object [] Parameters)
    am Microsoft.Crm.Extensibility.SdkTypeProxyCrmServiceWrapper.Execute (Object Request)
  • System.Net.WebException: Die Anforderung ist fehlgeschlagen mit HTTP-Status 404: nicht gefunden.
    am Microsoft.Crm.Extensibility.PluginStep.Execute (PipelineExecutionContext-Kontext)
    am Microsoft.Crm.Extensibility.Pipelin.Execute (PipelineExecutionContext-Kontext)

Ursache

Dieses Problem tritt auf, weil die URL des dieCrmServiceObjekt im Software Development Kit (SDK)-proxy ähnelt dem folgende URL:
"http://localhost"
Aus diesem Grund Microsoft Dynamics CRM 4.0 unterstützt. den Host-Header nicht ordnungsgemäß behandelt werden.

Lösung

Dieses Problem ist das neueste kumulative Update-Rollup für Microsoft Dynamics CRM 4.0 behoben. Weitere Informationen finden Sie in folgendem Artikel der Microsoft Knowledge Base anzuzeigen:
949256Microsoft Dynamics CRM 4.0-Updates und hotfixes

Außerdem erstellen Sie einen LocalSdkHost-Registrierungsschlüssel auf dem Microsoft Dynamics CRM 4.0-Server. Gehen Sie hierzu folgendermaßen vor:
  1. Klicken Sie aufStart, klicken Sie aufAusführen, TypRegedit, und klicken Sie dann aufOK.
  2. Suchen Sie den folgenden Registrierungsunterschlüssel:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM
  3. Mit der rechten MaustasteMSCRM, klicken Sie aufNeue, und klicken Sie dann aufString-Wert.
  4. In derNameGeben Sie im FeldLocalSdkHost.
  5. Mit der rechten MaustasteLocalSdkHost, und klicken Sie dann aufÄndern.
  6. In derWertein geben Sie den Namen des Microsoft Dynamics CRM-Server oder den Host-Header, und klicken Sie dann aufOK.

    HinweisGeben Sie http:// oder die Portnummer.
  7. Suchen Sie den LocalSdkPort-Schlüssel an derselben Position. Stellen Sie sicher, dass der Port, der aufgelistet ist den Port entspricht, der für die CRM-Website verwendet wird.
  8. Wenn der Wert des Schlüssels LocalSdkPort falsch ist, mit der rechten MaustasteLocalSdkPort, und klicken Sie dann aufÄndern. Geben Sie die richtige Port-Nummer ein, und klicken Sie dann aufOK.

Status

Microsoft hat bestätigt, dass dies ein Problem in Microsoft-Produkten handelt, aufgeführt sind im Abschnitt "Betrifft".

Weitere Informationen

Weitere Informationen zu den Terminologie, das Standardbegriffen bei Microsoft Softwareupdates verwendet wird, klicken Sie auf die folgende Artikelnummern, um die betreffenden Artikel in der Microsoft Knowledge Base anzuzeigen:
824684Beschreibung der Standardterminologie, die zum Beschreiben von Softwareupdates von Microsoft verwendet wird
887283Microsoft Business Solutions CRM-Softwarehotfix und Update Packen Namensstandards

Eigenschaften

Artikel-ID: 950542 - Geändert am: Montag, 21. März 2011 - Version: 1.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Dynamics CRM 4.0
Keywords: 
kbautohotfix kbfix kbexpertiseinter kbmbsmigrate kbqfe kbhotfixserver kbmt KB950542 KbMtde
Maschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 950542
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com