Sincrónicos plug-ins no responden a los eventos que se desencadenan en Microsoft Dynamics CRM 4.0

Seleccione idioma Seleccione idioma
Id. de artículo: 950542 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

Síntomas

Cuando se implementación sincrónicos de los complementos en un Microsoft Dynamics Servidor de CRM 4.0 que está configurado para utilizar un hacer de encabezado de host, los plug-ins sincrónicos no responder a los eventos que se desencadenan en Microsoft Dynamics CRM 4.0.

Pueden aparecer en las trazas de plataforma y el Visor de sucesos errores similares a los siguientes:
  • Información de seguimiento de pila: [WebException: error en la solicitud con el estado HTTP 400: solicitud incorrecta.]
    en Microsoft.Crm.Extensibility.SdkTypeProxyCrmServiceWrapper.InternalInvoke (MethodInfo methodInfo, parámetros de objeto [])
    en Microsoft.Crm.Extensibility.SdkTypeProxyCrmServiceWrapper.Execute (solicitud de objeto)
  • System.Net.WebException: Error en la solicitud con el estado HTTP 404: no se encontró.
    en Microsoft.Crm.Extensibility.PluginStep.Execute (PipelineExecutionContext de contexto)
    en Microsoft.Crm.Extensibility.Pipelin.Execute (PipelineExecutionContext de contexto)

Causa

Este problema se produce porque la dirección URL de elCrmServiceobjeto en el proxy del Kit de desarrollo de Software (SDK) es similar a la dirección URL siguiente:
http://localhost
Por lo tanto, Microsoft Dynamics CRM 4.0 no controla correctamente el encabezado de host.

Solución

Este problema se corrige en el paquete de continuación de la actualización acumulativa más reciente para Microsoft Dynamics CRM 4.0. Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
949256Revisiones y actualizaciones de Microsoft Dynamics CRM 4.0

Además, puede crear una clave de registro LocalSdkHost en el servidor de Microsoft Dynamics CRM 4.0. Para ello, siga estos pasos:
  1. Haga clic enInicio, haga clic enEjecutar, tipoRegedity, a continuación, haga clic enACEPTAR.
  2. Busque la siguiente subclave del registro:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM
  3. Con el botón secundarioMSCRM, haga clic enNuevoy, a continuación, haga clic enValor de cadena.
  4. En elNombrecuadro, escribaLocalSdkHost.
  5. Con el botón secundarioLocalSdkHosty, a continuación, haga clic enModificar.
  6. En elValorEscriba el nombre del servidor Microsoft Dynamics CRM o el encabezado de host y, a continuación, haga clic enACEPTAR.

    NotaNo se especifica http:// o el número de puerto.
  7. Busque la clave LocalSdkPort en la misma ubicación. Compruebe que el puerto que aparece en la lista coincide con el puerto que se utiliza para el sitio Web de CRM.
  8. Si el valor de la clave de LocalSdkPort es incorrecto, con el botón secundarioLocalSdkPorty, a continuación, haga clic enModificar. Escriba el número de puerto correcto y, a continuación, haga clic enACEPTAR.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Se refiere a:".

Más información

Para obtener más información acerca de la terminología que se utiliza para describir las actualizaciones de software de Microsoft, haga clic en el números de artículo siguientes para verlos en Microsoft Knowledge Base:
824684Descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft
887283Estándares de nomenclatura de paquete de actualizaciones y revisiones de software de Microsoft Business Solutions CRM

Propiedades

Id. de artículo: 950542 - Última revisión: lunes, 21 de marzo de 2011 - Versión: 1.0
La información de este artículo se refiere a:
  • Microsoft Dynamics CRM 4.0
Palabras clave: 
kbautohotfix kbfix kbexpertiseinter kbmbsmigrate kbqfe kbhotfixserver kbmt KB950542 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 950542

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com