Síncronos de plug-ins não responder a eventos disparados no Microsoft Dynamics CRM 4. 0

Traduções deste artigo Traduções deste artigo
ID do artigo: 950542 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Sintomas

Quando você implanta o plug-ins síncronas em um Microsoft Dynamics Servidor de CRM 4. 0 é configurado para usar um Faça do cabeçalho de host, os plug-ins síncronos não responder a eventos disparados no Microsoft Dynamics CRM 4. 0.

Erros semelhantes aos seguintes podem ser encontrados nos rastreamentos de plataforma e o Visualizador de eventos:
  • Informações de rastreamento de pilha: [WebException: Falha na solicitação com status HTTP 400: solicitação inválida.]
    em Microsoft.Crm.Extensibility.SdkTypeProxyCrmServiceWrapper.InternalInvoke (MethodInfo methodInfo, parâmetros do objeto [])
    em Microsoft.Crm.Extensibility.SdkTypeProxyCrmServiceWrapper.Execute (solicitação de objeto)
  • System.NET.WebException: A solicitação falhou com status HTTP 404: não foi encontrado.
    em Microsoft.Crm.Extensibility.PluginStep.Execute (PipelineExecutionContext contexto)
    em Microsoft.Crm.Extensibility.Pipelin.Execute (PipelineExecutionContext contexto)

Causa

Esse problema ocorre porque a URL do oCrmServiceobjeto no proxy Software Development Kit (SDK) é semelhante a seguinte URL:
http://localhost
Portanto, Microsoft Dynamics CRM 4. 0 oferece não lidar corretamente com o cabeçalho do host.

Resolução

Esse problema foi corrigido no mais recente cumulativo para o Microsoft Dynamics CRM 4. 0. Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
949256Os hotfixes e atualizações do Microsoft Dynamics CRM 4. 0

Além disso, crie uma chave de registro LocalSdkHost no servidor do Microsoft Dynamics CRM 4. 0. Para fazer isso, execute estas etapas:
  1. Clique emIniciar, clique emExecutar, tipoRegedite, em seguida, clique emOK.
  2. Localize a seguinte subchave do registro:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM
  3. Com o botão direitoMICROSOFT CRM, clique emNovoe, em seguida, clique emValor de seqüência de caracteres.
  4. NoNomecaixa, digiteLocalSdkHost.
  5. Com o botão direitoLocalSdkHoste, em seguida, clique emModificar.
  6. NoValorcaixa, digite o nome do servidor do Microsoft Dynamics CRM ou o cabeçalho do host e, em seguida, clique emOK.

    ObservaçãoNão especifique http:// ou o número da porta.
  7. Localize a chave LocalSdkPort no mesmo local. Verifique se a porta listado corresponde a porta que está sendo usada para o site do CRM.
  8. Se o valor da chave LocalSdkPort estiver incorreto, clique com o botão direitoLocalSdkPorte, em seguida, clique emModificar. Digite o número de porta correto e clique emOK.

Situação

Microsoft confirmou que se trata de um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

Para obter mais informações sobre o terminologia usada para descrever as atualizações de software Microsoft, clique no números abaixo para ler os artigos na Base de dados de Conhecimento da Microsoft:
824684Descrição da terminologia padrão usada para descrever as atualizações de software da Microsoft
887283Padrões de nomeação do pacote de atualização e o hotfix de software Microsoft Business Solutions CRM

Propriedades

ID do artigo: 950542 - Última revisão: segunda-feira, 21 de março de 2011 - Revisão: 1.0
A informação contida neste artigo aplica-se a:
  • Microsoft Dynamics CRM 4.0
Palavras-chave: 
kbautohotfix kbfix kbexpertiseinter kbmbsmigrate kbqfe kbhotfixserver kbmt KB950542 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 950542

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com