Article ID: 950616 - Last Review: April 2, 2008 - Revision: 1.1

An audio application that uses the Portcls.sys file may stop responding when you run the audio application on a computer that is running Windows XP

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SYMPTOMS

On a computer that is running Windows XP, you perform an audio stress test by running an audio application that uses the Portcls.sys file. When you do this, the audio application may stop responding.

CAUSE

This problem occurs when a thread of the Portcls.sys file tries to reacquire a spin-lock if an I/O request packet (IRP) is canceled at certain points in its processing. The thread has two locks. Therefore, a deadlock results.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Windows XP Service Pack 2 (SP2) must be installed on the computer.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
322389  (http://support.microsoft.com/kb/322389/ ) How to obtain the latest Windows XP service pack

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP with Service Pack 2, x86-based editions
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File nameFile versionFile sizeDateTimePlatform
Portcls.sys5.1.2600.3337146,04821-Mar-200809:32x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

APPLIES TO
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Service Pack 3
Keywords: 
kbautohotfix kbexpertiseinter kbhotfixserver kbqfe KB950616