Код статьи: 950616 - Последнее изменение :: 11 октября 2011 г. - Редакция: 5.0

Аудио приложения, использующего файл Portcls.sys может перестать отвечать при запуске аудио приложения на компьютере под управлением Windows XP

Экстренное исправление доступно для загрузкиЗагрузка исправления доступна
Просмотр и запрос на загрузку исправления
Совет по использованию системыЭта статья относится к операционной системе, отличной от установленной на вашем компьютере. Содержимое, не относящееся к используемой системе, отключено.

На этой странице

Развернуть все | Свернуть все

Проблема

На компьютере под управлением Windows XP выполнять аудио нагрузочного тестирования, запустив аудио приложение, использующее файл Portcls.sys. При этом аудио приложение может перестать отвечать на запросы.

Причина

Эта проблема возникает, когда поток файла Portcls.sys пытается повторить запрос спин блокировки, если пакет запроса ввода-вывода (IRP) прекращена по точки, определенные во время обработки. Поток имеет две блокировки. Таким образом Результаты взаимоблокировки.

Решение

Сведения об исправлении

Корпорация Майкрософт выпустила исправление. Однако данное исправление предназначено для устранения проблемы, описанной в этой статье. Данное исправление только в тех системах, в которых обнаружена эта специфическая неполадка. Это исправление может проходить дополнительное тестирование. Таким образом Если вы не представляет особой эта проблема, рекомендуется отложить ее решение до выхода ближайшего пакета обновления, содержащего это исправление.

Если исправление доступно для загрузки, имеется раздел «Исправление доступно для загрузки» в верхней части статьи базы знаний. Если этот раздел не отображается, обратитесь в службу и службу поддержки для получения исправления.

Примечание Если возникают другие проблемы или необходимо устранить неполадки, возможно создать отдельный запрос на обслуживание. Затраты на обычные службы поддержки будут применяться дополнительные вопросы и проблемы, не связанные с данным исправлением, оплачиваются. Для получения полного списка телефонов службы поддержки и обслуживания клиентов корпорации Майкрософт или создать отдельный запрос посетите следующий веб-узел корпорации Майкрософт:
http://support.Microsoft.com/contactus/?ws=Support (http://support.microsoft.com/contactus/?ws=support)
Примечание В форме «Исправление доступно для загрузки» отображаются языки, для которых доступно исправление. Если язык не отображается, значит исправления недоступна для данного языка.

Необходимые условия

Windows XP с пакетом обновления 2 (SP2) необходимо установить на компьютер.

Для получения дополнительных сведений щелкните следующий номер статьи базы Microsoft База знаний:
322389  (http://support.microsoft.com/kb/322389/ ) Как получить последний пакет обновления для Windows XP

Необходимость перезагрузки

Необходимо перезагрузить компьютер после установки этого исправления.

Сведения о замене исправлений

Это исправление не заменяет ранее выпущенные исправление.

Сведения о файлах

Английская версия данного исправления содержит файл атрибуты (или более поздними), приведенные в следующей таблице. Дата и время для файлов указаны в формате UTC (UTC). При просмотре сведений о файле, он преобразуется в локальное время. Для узнать разницу между временем по Гринвичу и местным временем, воспользуйтесь Время Зона на вкладке Дата и время элемент в элементе управления Панель.
Windows XP С пакетом обновления 2, x 86-разрядных выпусков
Свернуть эту таблицуРазвернуть эту таблицу
Имя файлаВерсия файлаФайл РазмерДатаВремяПлатформа
Portcls.sys5.1.2600.3337146,04821 Марта 2008 г.09: 32X86

Статус

Корпорация Майкрософт подтверждает, что это проблема в продуктах Майкрософт, перечисленных в разделе «Относится к».

Информация в данной статье относится к следующим продуктам.
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Service Pack 3
Ключевые слова: 
kbautohotfix kbexpertiseinter kbhotfixserver kbqfe kbmt KB950616 KbMtru
Переведено с помощью машинного переводаПереведено с помощью машинного перевода
ВНИМАНИЕ! Перевод данной статьи был выполнен не человеком, а с помощью программы машинного перевода, разработанной корпорацией Майкрософт. Корпорация Майкрософт предлагает вам статьи, переведенные как людьми, так и средствами машинного перевода, чтобы у вас была возможность ознакомиться со статьями базы знаний KB на родном языке. Однако машинный перевод не всегда идеален. Он может содержать смысловые, синтаксические и грамматические ошибки, подобно тому как иностранец делает ошибки, пытаясь говорить на вашем языке. Корпорация Майкрософт не несет ответственности за неточности, ошибки и возможный ущерб, причиненный в результате неправильного перевода или его использования. Корпорация Майкрософт также часто обновляет средства машинного перевода.
Эта статья на английском языке:950616  (http://support.microsoft.com/kb/950616/en-us/ )