FIX: BizTalk Server 2006 R2 does not display the correct MDN Status in an AS2 message and the correlated MDN status report when the MDN contains the error "unexpected-processing-error"

Article translations Article translations
Article ID: 950673 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

Consider the following scenario:
  • In Microsoft BizTalk Server 2006 R2, you use the AS2EDISend or the AS2Send send pipeline to send Applicability Statement 2 (AS2) messages to your trading partner.
  • On the AS2 Properties configuration page for the partner, in the Party as AS2 Message Receiver tab, you enable the Request MDN setting and specify the AS2-To field to contain a name that differs from the partner name.
  • When BizTalk Server 2006 R2 sends out an AS2 message to the partner, the Message Disposition Notification (MDN) response that is sent from the partner contains a message that resembles the following:

    The EDI message is meant for <the specified AS2-To name> not for us. [<the correct partner name>]'

  • The MDN contains "processed/Error: unexpected-processing-error" in the Disposition field. Also, the MDN does not contain the Received-content-MIC extension field in the HTTP header.
In this scenario, BizTalk Server 2006 R2 does not recognize the error "unexpected-processing-error" in the MDN. If AS2 reporting is enabled, the MDN status column displays "Error: Integrity check failed" in the AS2 message and correlated MDN statusreport instead of "unexpected-processing-error".

CAUSE

This problem occurs because of an error in the AS2 components of BizTalk Server 2006 R2.

RESOLUTION

After you apply this hotfix, the AS2 message and the correlated MDN statusreport displays the correct MDN Status.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: -
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have BizTalk Server 2006 R2 installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Microsoft.biztalk.edi.ediintpipelines.dll3.6.1479.273,72821-Jul-200816:51x86
Microsoft.biztalk.ediint.pipelinecomponents.dll3.6.1479.2122,88021-Jul-200816:50x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about MDN messages, visit the following Microsoft Developer Network (MSDN) Web site:
http://msdn.microsoft.com/en-us/library/bb245967%28BTS.20%29.aspx

For more information about how BizTalk Server 2006 R2 sends AS2 messages, visit the following Microsoft Developer Network (MSDN) Web site:
http://msdn.microsoft.com/en-us/library/bb246012%28BTS.20%29.aspx

For more information about AS2 messages and correlated MDN status reports, visit the following Microsoft Developer Network (MSDN) Web site:
http://msdn.microsoft.com/en-us/library/bb727808%28BTS.20%29.aspx

Properties

Article ID: 950673 - Last Review: October 8, 2011 - Revision: 2.0
APPLIES TO
  • Microsoft BizTalk Server 2006 R2 Branch Edition
  • Microsoft BizTalk Server 2006 R2 Developer Edition
  • Microsoft BizTalk Server 2006 R2 Enterprise Edition
  • Microsoft BizTalk Server 2006 R2 Standard Edition
Keywords: 
kbbtspipeline kbbiztalk2006r2sp1fix kbautohotfix kbexpertiseadvanced kbsurveynew kbqfe KB950673

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com