As regras de fluxo de trabalho já não executar quando utiliza a implementação do Gestor de organização Assistente para importar uma organização no Microsoft Dynamics CRM 4.0

Traduções de Artigos Traduções de Artigos
Artigo: 950680 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Sintomas

No Microsoft Dynamics CRM 4.0., desactive e, em seguida, elimine uma organização. Quando utiliza a implementação do Gestor de organização Assistente para importar uma organização, as regras de fluxo de trabalho já não executar. Além disso, a seguinte mensagem de erro é registada no Visualizador de eventos:
Recebeu acesso organização {B0C47547-14B8-DC11-AFCA-0013724BA161} excepção de SQL. Excepção: Microsoft.Crm.Metadata.EntityMetadataNotFoundException: A entidade com ObjectTypeCode = 0 não foi encontrada a MetadataCache.
em Microsoft.Crm.Metadata.DynamicMetadataCache.GetEntity (Int32 entityCode)
em Microsoft.Crm.Asynchronous.QueueDataAccess.GetEntityLogicalNameFromObjectTypeCode (Int32 objectTypeCode)
em Microsoft.Crm.Asynchronous.QueueDataAccess.GetLookup (objecto objectId objectIdName de cadeia, Int32 objectDsc, Int32 objectTypeCode)
em Microsoft.Crm.Asynchronous.QueueDataAccess. <> c__DisplayClass2. <selectevents> b__0(Object[] values)
em Microsoft.Crm.Asynchronous.DataAccessBase.ExecuteSqlCommandAndProcessRecords (comando IDbCommand, RecordProcessor recordProcessor)
em Microsoft.Crm.Asynchronous.QueueDataAccess.SelectEvents (Int32 numberOfEvents)
Se visualizar a tabela AsyncOperationBase e a tabela BulkDeleteFailureBase na base de dados organização que importou, repare que todos os valores na coluna RegardingObjectId um GUID é utilizado para o identificador de organizationid da organização base de dados.

Causa

Este problema ocorre porque a tabela AsyncOperationbase é incorrectamente actualizada quando importa uma organização.

Resolução

Este problema é corrigido no conjunto de actualização cumulativa mais recente do Microsoft Dynamics CRM 4.0. Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
949256O Microsoft Dynamics CRM 4.0 actualizações e correcções

Mais Informação

Para obter mais informações sobre a terminologia utilizada para descrever actualizações de software da Microsoft, clique números de artigo que se seguem para visualizar os artigos na base de dados de conhecimento da Microsoft:
824684Descrição da terminologia padrão utilizada para descrever actualizações de software da Microsoft
887283Padrões de nomenclatura do pacote de Microsoft Business Solutions CRM software hotfix e atualização

Propriedades

Artigo: 950680 - Última revisão: 12 de fevereiro de 2009 - Revisão: 4.0
A informação contida neste artigo aplica-se a:
  • Microsoft Dynamics CRM 4.0
Palavras-chave: 
kbmt kbautohotfix kbexpertiseinter kbmbsmigrate kbqfe kbhotfixserver kberrmsg KB950680 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 950680

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com