ID do artigo: 950757 - Última revisão: quinta-feira, 22 de janeiro de 2009 - Revisão: 2.0

Remetentes de email não recebem uma indicação de que algumas mensagens tem sido mantidas pelo Exchange Server 2003 até que o serviço SMTP, o serviço Microsoft Exchange Information Store, ou o servidor do Exchange é reiniciado

Download do hotfix está disponívelDownload do Hotfix Disponível
Visualizar e solicitar downloads de hotfix
Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Recolher tudo

Sintomas

Em um ambiente Exchange Server 2003, após o SMTP serviço for reiniciado, o serviço de armazenamento é reiniciado, ou o servidor for reiniciado, os destinatários de email podem receber mensagens antigas que foram enviadas vários dias antes. Ou, os remetentes de email podem receber o relatório de não-entrega (NDR) mensagens para mensagens de email atrasada que eles enviados anteriormente.

Quando esse problema ocorre, essas mensagens não são visíveis no SMTP filas no Exchange System Manager. No entanto, essas mensagens são visíveis SMTP Temp tabelas no armazenamento de caixa de correio. Além disso, os remetentes de email não são exibida uma indicação de que as mensagens mantidas pelo servidor do Exchange Server 2003 até que recebam mensagens NDR quando um dos serviços é reiniciado ou quando o servidor for reiniciado.

Causa

Quando o armazenamento é iniciado, o GuidTimestamp é gerado no lado do armazenamento e passada para driver de armazenamento (IIS) (Drviis) através de um proxy. No entanto, em alguns casos, as informações que contém o GuidTimestamp são enviadas para o driver de armazenamento duas vezes e o IIS recebe um carimbo de hora diferentes que recebe o armazenamento. Quando uma nova mensagem é processada, os carimbos de armazenamento e envia as mensagens para a fila de envio, e em seguida, o GuidTimeStamp for alterada no lado do IIS. Às vezes, as mensagens não são entregues para o próximo salto na primeira tentativa porque um host SMTP remoto tem "Greylisting" habilitada. Nesse caso, o host SMTP envia uma mensagem de erro temporários (4.7.1) volta ao remetente que indica que o remetente deve repetir a transmissão de uma mensagem em alguns minutos. Nesse cenário, a mensagem é definida como um estado de "repetição" pelo serviço SMTP. Quando a ? tentativa ? acontece o carimbo de hora na mensagem é comparado com a hora do driver de armazenamento. Quando há uma incompatibilidade, a mensagem é considerada inválida e não entregues até que o serviço SMTP ou IIS for reiniciado.

Resolução

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior deste artigo do Knowledge Base. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Esse hotfix exige o Microsoft Exchange Server 2003 Service Pack 2 seja instalado no servidor devido às dependências do arquivo.
Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
836993   (http://support.microsoft.com/kb/836993/ ) Como obter os service packs mais recentes para o Exchange Server 2003

Requisitos de reinicialização

O servidor deve ser reiniciado se o processo Wmiprvse.exe está sendo executado.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes.

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos são listadas na hora universal coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempo
Drviis.dll6.5.7654.2135.68017 De julho de 200817: 56
Exsmtp.dll6.5.7654.2407,55217 De julho de 200818: 14
GWART.dll6.5.7654.266,56017 De julho de 200816: 48
Phatcat.dll6.5.7654.2504,32017 De julho de 200802: 52
Reapi.dll6.5.7654.2848,89617 De julho de 200818: 14

Mais Informações

Para obter mais informações sobre como usar o utilitário Mfcmapi.exe para exibir e trabalhar com mensagens em SMTP TempTables, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
906557  (http://support.microsoft.com/kb/906557/ ) Como usar o utilitário Mfcmapi.exe para exibir e trabalhar com mensagens em TempTables o SMTP no Exchange 2000 Server e no Exchange Server 2003
Para obter mais informações sobre o problema ocioso mensagens em um servidor SMTP do Windows Server 2003, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
934709   (http://support.microsoft.com/kb/934709/ ) Em um servidor gateway de SMTP baseado no Windows Server 2003, algumas mensagens podem permanecer na pasta de fila até que o serviço SMTP seja reiniciado

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

A informação contida neste artigo aplica-se a:
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange Server 2003 Enterprise Edition
Palavras-chave: 
kbmt kbfix kbexpertiseadvanced kbhotfixserver kbqfe kbautohotfix KB950757 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 950757  (http://support.microsoft.com/kb/950757/en-us/ )