Recibirá un rendimiento deficiente al utilizar el protocolo de SMB 2.0 para realizar operaciones relacionadas con la red, such as migración de ADMT en equipos que ejecutan Windows Server 2008 o Windows Vista

Seleccione idioma Seleccione idioma
Id. de artículo: 950836 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Encontrará un rendimiento deficiente en un equipo que ejecuta Windows Server 2008 o Windows Vista cuando realiza operaciones relacionadas con la red. Estas operaciones relacionadas con la red se incluyen cuando copia un archivo compartido, mover un archivo compartido, o utilizar la herramienta de migración para Active Directory (ADMT).

Por ejemplo, el controlador de dominio origen o destino está ejecutando Windows Server 2008. En este ejemplo, una migración de ADMT toma tres veces más de una migración entre dos controladores de dominio que ejecutan versiones anteriores a Windows Server 2008.

En otro ejemplo, el origen y el destino los controladores de dominio ejecutan Windows Server 2008. En este ejemplo, una migración de ADMT tarda más de seis veces que una migración entre dos controladores de dominio son ambos anteriores de a Windows versiones ejecución Server 2008.

Causa

Operaciones relacionadas con la red en Windows Vista y en Windows Server 2008 se basan en mensajes bloque de servidor (SMB) 2.0. Cuando un servidor SMB 2.0 recibe una solicitud que tardará un largo tiempo en procesar, el servidor procesa la solicitud de forma diferente. En este caso, el servidor envía una respuesta provisional al cliente y, a continuación, el servidor se cambia a procesar la solicitud asincrónicamente. Sin embargo, el servidor SMB 2.0 sincrónicamente espera TCP ofrecer esta respuesta provisional. Este comportamiento puede producir un retraso de 200 milisegundos debido del intervalo de respuesta ACK de TCP. Por lo tanto, este retraso, el rendimiento deficiente mencionado en la sección "Síntomas".

Solución

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir sólo el problema está descrita en este artículo. Aplicar esta revisión sólo a los sistemas que experimenten el problema se describe en este artículo. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.


Importantes las revisiones de Windows Vista y Windows Server 2008 se incluyen en los paquetes mismos. Sin embargo, sólo uno de estos productos puede aparecer en la página ? solicitud de revisión ?. Para solicitar el paquete de hotfix que se aplica a Windows Vista y Windows Server 2008, simplemente seleccione el producto que aparece en la página.

Requisitos previos

Para aplicar esta revisión, el equipo debe estar ejecutando uno de los sistemas operativos siguientes:
  • Windows Vista Service Pack 1 (SP1)
  • Windows Server 2008

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.
Para todas las versiones basadas en 86 de Windows Vista y de Windows Server 2008 en x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataformaRequisito de SP
Srvnet.sys6.0.6001.2236698,81602-Feb-200916: 03x 86SP1
Srv2.sys6.0.6001.18206144,89602-Feb-200903: 39x 86SP1
Srv2.sys6.0.6001.22366144,89602-Feb-200916: 03x 86SP1
Para todas versiones de 64 de Windows Vista y de Windows Server 2008 x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataformaRequisito de SP
Srvnet.sys6.0.6001.22366141,31202-Feb-200903: 44x 64SP1
Srv2.sys6.0.6001.18206174,59202-Feb-200903: 55x 64SP1
Srv2.sys6.0.6001.22366174,59202-Feb-200903: 44x 64SP1
Para todas las versiones basadas en Itanium de Windows Server 2008
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataformaRequisito de SP
Srvnet.sys6.0.6001.22366286,20802-Feb-200902: 20IA-64SP1
Srv2.sys6.0.6001.18206465,40802-Feb-200902: 30IA-64SP1
Srv2.sys6.0.6001.22366465,92002-Feb-200902: 20IA-64SP1

Solución

Para evitar este problema, deshabilite SMB 2.0. Para ello, siga estos pasos:

importante Esta sección, el método o la tarea contiene pasos que indican cómo modificar el registro. Sin embargo, pueden producirse problemas graves si modifica incorrectamente el registro. Por tanto, asegúrese de que siga estos pasos cuidadosamente. Realice una para agregar protección, copia de seguridad del registro antes de modificarlo. A continuación, puede restaurar el registro si se produce un problema. Para obtener más información acerca de cómo realizar una copia de seguridad y restaurar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756Cómo realizar una copia de seguridad y restaurar el registro de Windows
  1. Haga clic en Inicio , escriba regedit en el cuadro Iniciar búsqueda y, a continuación, presione ENTRAR.
  2. Busque y haga clic en la siguiente subclave del Registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters
  3. En el menú Edición , seleccione nuevo y, a continuación, haga clic en Valor DWORD .
  4. Escriba SMB2 y, a continuación, presione ENTRAR.
  5. En el menú Edición , haga clic en Modificar .
  6. Escriba 0 (cero) y, a continuación, haga clic en Aceptar .
  7. Editor de registro de salida.
  8. Reinicie el equipo.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

Para obtener más información acerca de las nuevas características de redes en Windows Server 2008 y en Windows Vista, como SMB 2.0, visite el siguiente sitio Web de Microsoft:
http://technet.microsoft.com/en-us/library/bb726965.aspx
Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684 Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 950836 - Última revisión: miércoles, 8 de julio de 2009 - Versión: 1.0
La información de este artículo se refiere a:
  • Windows Server 2008 for Itanium-Based Systems
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
  • Windows Server 2008 Datacenter
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Business
  • Windows Vista Business 64-bit edition
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
Palabras clave: 
kbmt kbautohotfix kbexpertiseadvanced kbfix kbsurveynew kbqfe kbhotfixserver KB950836 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 950836

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com