Você encontrar um desempenho ruim quando você usa o protocolo SMB 2.0 para executar operações relacionadas à rede, como a migração do ADMT, em computadores que estão executando o Windows Server 2008 ou o Windows Vista

Traduções deste artigo Traduções deste artigo
ID do artigo: 950836 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Encontrar baixo desempenho em um computador que está executando o Windows Server 2008 ou Windows Vista quando você executa operações relacionadas à rede. Essas operações relacionadas à rede incluem quando você copia um arquivo compartilhado, mova um arquivo compartilhado, ou use a ferramenta de migração do Active Directory (ADMT).

Por exemplo, o controlador de domínio origem ou destino está executando o Windows Server 2008. Neste exemplo, uma migração do ADMT demora três vezes mais do que uma migração entre dois controladores de domínio que estejam executando versões anteriores ao Windows Server 2008.

Em outro exemplo, controladores de domínio de origem e de destino estiverem executando o Windows Server 2008. Neste exemplo, uma migração do ADMT demora mais de seis vezes que uma migração entre dois controladores de domínio que são dois antes do Windows em execução versões Server 2008.

Causa

Operações relacionadas à rede no Windows Vista e no Windows Server 2008 são baseadas no SMB (Server Message Block) 2.0. Quando um servidor SMB 2.0 recebe uma solicitação que irá levar muito tempo para processar, o servidor processa a solicitação de forma diferente. Nesse caso, o servidor enviará uma resposta provisória para o cliente e, em seguida, o servidor alterna para o processamento da solicitação assíncrona. No entanto, o servidor SMB 2.0 aguarda síncrona TCP fornecer essa resposta provisória. Esse comportamento pode produzir um atraso de 200 milissegundos por causa do intervalo de resposta de ACK do TCP. Portanto, esse atraso faz com que o desempenho ruim mencionado na seção "Sintomas".

Resolução

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina a corrigir somente o problema é que descrito neste artigo. Aplicar esta correcção apenas para sistemas que apresentarem o problema é descrita neste artigo. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.


Hotfixes do Windows Vista e Windows Server 2008 importantes estão incluídos nos pacotes de mesmos. No entanto, somente um desses produtos pode ser listado na página ? Hotfix solicitação ?. Para solicitar o pacote de hotfix que se aplica ao Windows Vista e Windows Server 2008, basta selecione o produto que está listado na página.

Pré-requisitos

Para aplicar esse hotfix, seu computador deve estar executando um dos seguintes sistemas operacionais:
  • Windows Vista Service Pack 1 (SP1)
  • Windows Server 2008

Requisitos de reinicialização

Reinicie o computador após aplicar esse hotfix.

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas no horário de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
Para todas as versões com base em 86 do Windows Vista e do Windows Server 2008 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaRequisito de SP
Srvnet.sys6.0.6001.2236698,81602-Fevereiro de 200903: 16x 86SP1
Srv2.sys6.0.6001.18206144.89602-Fevereiro de 200903: 39x 86SP1
Srv2.sys6.0.6001.22366144.89602-Fevereiro de 200903: 16x 86SP1
Para todas as versões com base em 64 do Windows Vista e do Windows Server 2008 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaRequisito de SP
Srvnet.sys6.0.6001.22366141,31202-Fevereiro de 200903: 44x 64SP1
Srv2.sys6.0.6001.18206174,59202-Fevereiro de 200903: 55x 64SP1
Srv2.sys6.0.6001.22366174,59202-Fevereiro de 200903: 44x 64SP1
Para todas as versões baseadas em Itanium do Windows Server 2008
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaRequisito de SP
Srvnet.sys6.0.6001.22366286,20802-Fevereiro de 200902: 20IA-64SP1
Srv2.sys6.0.6001.18206465,40802-Fevereiro de 200902: 30IA-64SP1
Srv2.sys6.0.6001.22366465,92002-Fevereiro de 200902: 20IA-64SP1

Como Contornar

Para contornar esse problema, desative o SMB 2.0. Para fazer isso, execute as seguintes etapas:

importante Esta seção, método ou tarefa contém etapas que informam sobre como modificar o registro. No entanto, sérios problemas poderão ocorrer se você modificar o registro incorretamente. Por isso, certifique-se que você execute essas etapas cuidadosamente. Para proteção adicional, fazer backup do registro antes de modificá-lo. Em seguida, você pode restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup e restaurar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
322756Como fazer backup e restaurar o registro no Windows
  1. Clique em Iniciar , digite regedit na caixa Iniciar procura e, em seguida, pressione ENTER.
  2. Localize e, em seguida, clique na seguinte subchave do Registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters
  3. No menu Editar , aponte para novo e, em seguida, clique em Valor DWORD .
  4. Digite SMB2 e, em seguida, pressione ENTER.
  5. No menu Editar , clique em Modificar .
  6. Digite 0 (zero) e, em seguida, clique em OK .
  7. Feche o Editor do Registro.
  8. Reinicie o computador.

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

Para obter mais informações sobre novos recursos de rede no Windows Server 2008 e no Windows Vista, como o SMB 2.0, visite o seguinte site da Microsoft:
http://technet.microsoft.com/en-us/library/bb726965.aspx
Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684 Descrição da terminologia padrão que é usada para descrever as atualizações de software

Propriedades

ID do artigo: 950836 - Última revisão: quarta-feira, 8 de julho de 2009 - Revisão: 1.0
A informação contida neste artigo aplica-se a:
  • Windows Server 2008 for Itanium-Based Systems
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
  • Windows Server 2008 Datacenter
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Business
  • Windows Vista Business 64-bit edition
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
Palavras-chave: 
kbmt kbautohotfix kbexpertiseadvanced kbfix kbsurveynew kbqfe kbhotfixserver KB950836 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 950836

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com