Artigo: 951039 - Última revisão: sexta-feira, 2 de Maio de 2008 - Revisão: 1.0

Mensagem de erro quando tenta actualizar o Windows Server 2003 para Windows Server 2008: "Programa de configuração detectou que está instalado neste computador para actualizar o servidor, desinstalar este componente extensões de servidor do FrontPage"

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Reduzir tudo

Sintomas

Quando tenta actualizar a partir do Windows Server 2003 para o Windows Server 2008, poderá receber a seguinte mensagem de erro:
O programa de configuração detectou que extensões de servidor do FrontPage está instalado neste computador. Para actualizar o servidor, desinstale este componente.

Causa

A actualização pára se as extensões de servidor Microsoft FrontPage já estão instaladas no Windows Server 2003.

Resolução

Para resolver este problema, desinstale as extensões de servidor do FrontPage, efectuar a actualização e reinstale as extensões de servidor do FrontPage. Para o fazer, utilize um dos seguintes métodos.

Método 1: Utilizar o item Adicionar ou remover programas no painel de controlo

  1. No painel de controlo, faça duplo clique em Adicionar ou remover programas .
  2. Clique a entrada de extensões de servidor FrontPage.
  3. Clique em Remover .
  4. Efectue a actualização.
  5. Se for necessário, reinstale as extensões de servidor do FrontPage.

Método 2: Modificar o registo

importante Esta secção, método ou tarefa contém passos que indicam como modificar o registo. No entanto, poderão ocorrer problemas graves se modificar o registo de forma incorrecta. Por conseguinte, certifique-se de que segue estes passos cuidadosamente. Criar uma para protecção adicional, cópia de segurança do registo antes de o modificar. Em seguida, pode restaurar o registo se ocorrer um problema. Para obter mais informações sobre como efectuar uma cópia de segurança e restaurar o registo, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) Como efectuar uma cópia de segurança e restaurar o registo no Windows
  1. Inicie o Editor de registo.
  2. Localize e, em seguida, clique na seguinte subchave do registo:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\5.0\Setup Packages "Microsoft Windows" ="<x.x.x.xxxx>"
    Nota Nesta subchave do registo, <x.x.x.xxxx> representa um número de versão.
  3. No menu ficheiro , clique em Eliminar e, em seguida, clique em Sim para aceitar a eliminação.
  4. Efectue a actualização.
  5. Se for necessário, reinstale as extensões de servidor do FrontPage. Se as extensões de servidor do FrontPage não estiverem instaladas, as extensões podem ser instaladas como parte de outro programa.

Referências

Para mais informações sobre o Windows Server 2008, visite o seguinte site da Web da Microsoft TechNet:
http://technet.microsoft.com/en-us/windowsserver/2008/default.aspx (http://technet.microsoft.com/en-us/windowsserver/2008/default.aspx)

A informação contida neste artigo aplica-se a:
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
Palavras-chave: 
kbmt kbuninstall kbextension kbupgrade kbmessagebox kbprb kbtshoot kbexpertiseadvanced KB951039 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 951039  (http://support.microsoft.com/kb/951039/en-us/ )