ID do artigo: 951039 - Última revisão: sexta-feira, 2 de maio de 2008 - Revisão: 1.0

Mensagem de erro ao tentar atualizar o Windows Server 2003 para o Windows Server 2008: "O programa de instalação detectou que extensões de servidor do FrontPage está instalada neste computador para atualizar o servidor, desinstalar esse componente"

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Recolher tudo

Sintomas

Ao tentar atualizar do Windows Server 2003 para o Windows Server 2008, você receberá a seguinte mensagem de erro:
O programa de instalação detectou que o extensões de servidor do FrontPage está instalado neste computador. Para atualizar seu servidor, desinstale esse componente.

Causa

A atualização pára se as extensões de servidor do Microsoft FrontPage já estão instaladas no Windows Server 2003.

Resolução

Para resolver esse problema, desinstale as extensões de servidor do FrontPage, executar a atualização e, em seguida, reinstale as extensões de servidor do FrontPage. Para fazer isso, use um dos seguintes métodos.

Método 1: Usar o item Adicionar ou remover programas no painel de controle

  1. No painel de controle, clique duas vezes em Adicionar ou remover programas .
  2. Clique na entrada extensões de servidor do FrontPage.
  3. Clique em Remover .
  4. Execute a atualização.
  5. Reinstale as extensões de servidor do FrontPage, se necessário.

Método 2: Modificar o registro

importante Esta seção, método ou tarefa contém etapas que informam sobre como modificar o registro. No entanto, sérios problemas poderão ocorrer se você modificar o registro incorretamente. Por isso, certifique-se que você execute essas etapas cuidadosamente. Para proteção adicional, fazer backup do registro antes de modificá-lo. Em seguida, você pode restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup e restaurar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
322756  (http://support.microsoft.com/kb/322756/ ) Como fazer backup e restaurar o registro no Windows
  1. Inicie o Editor do Registro.
  2. Localize e, em seguida, clique na seguinte subchave do Registro:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\5.0\Setup Packages "Microsoft Windows" ="<x.x.x.xxxx>"
    Observação Nessa subchave do Registro, <x.x.x.xxxx> representa um número de versão.
  3. No menu arquivo , clique em Excluir e clique em Sim para aceitar a exclusão.
  4. Execute a atualização.
  5. Reinstale as extensões de servidor do FrontPage, se necessário. Se as extensões de servidor do FrontPage não estiverem instaladas, as extensões podem ser instaladas como parte de outro programa.

Referências

Para obter mais informações sobre o Windows Server 2008, visite o seguinte site da Microsoft TechNet:
http://technet.microsoft.com/en-us/windowsserver/2008/default.aspx (http://technet.microsoft.com/en-us/windowsserver/2008/default.aspx)

A informação contida neste artigo aplica-se a:
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
Palavras-chave: 
kbmt kbuninstall kbextension kbupgrade kbmessagebox kbprb kbtshoot kbexpertiseadvanced KB951039 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 951039  (http://support.microsoft.com/kb/951039/en-us/ )