Error message when you delete cases from a queue or when you assign records in Microsoft Dynamics CRM 4.0: "Record is unavailable" or "More than one user queue was found for the given object"

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Article ID: 951178 - View products that this article applies to.
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SYMPTOMS

You upgrade to Microsoft Dynamics CRM 4.0. When you delete cases from a queue, or when you assign records, you receive one of the following error messages.
Error message 1
Record is unavailable.
Error message 2
More than one user queue was found for the given object.
If you have enabled platform tracing, you receive an error message that resembles the following error message:
Error: Exception of type 'System.Web.HttpUnhandledException' was thrown.
Error Number: 0x80040216
Error Message: More than one user queue was found for the given object.
Error Details: More than one user queue was found for the given object.
>MessageProcessor fail to process message 'Assign' for 'entityname'.
Crm Exception: Message: More than one user queue was found for the given object., ErrorCode: -2147220970

CAUSE

This problem occurs because an SQL database trigger was created for an earlier version of Microsoft Dynamics CRM. After you upgrade to Microsoft Dynamics CRM 4.0, the trigger is no longer necessary. However, the trigger is not removed from the database. Therefore, the queue item records are not deleted appropriately. Additionally, the trigger also causes problems when you assign records that have a relationship to the queue item entity. For example, you assign the following records:
  • Accounts
  • Contacts
  • E-mails

RESOLUTION

This problem is fixed in the latest cumulative update rollup for Microsoft Dynamics CRM 4.0. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
949256 Microsoft Dynamics CRM 4.0 updates and hotfixes

Properties

Article ID: 951178 - Last Review: February 12, 2009 - Revision: 2.0
APPLIES TO
  • Microsoft Dynamics CRM 4.0
Keywords: 
kberrmsg kbfix kbmbsmigrate kbqfe kbexpertiseinter KB951178

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