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Error message when you try to go offline in the Microsoft Dynamics CRM 4.0 client for Outlook with Offline Access: "Failed move data for entity"

Article ID:951179
Last Review:April 22, 2008
Revision:1.3
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SYMPTOMS

When you try to go offline in the Microsoft Dynamics CRM 4.0 client for Microsoft Office Outlook with Offline Access, you receive the following error message:
Failed move data for entity 'Entity_Name' during action action {Action_Number}, countRows={Row_Number}.
This problem occurs if the following conditions are true:
You install the Multilingual User Interface Pack (MUI) on the computer that runs the Microsoft Dynamics CRM 4.0 server components.
You install the MUI on the computer that runs the Microsoft Dynamics CRM 4.0 client for Outlook with Offline Access.
You enable a language on the computer that runs the Microsoft Dynamics CRM 4.0 server components.
The Microsoft Dynamics CRM 4.0 client for Outlook with Offline Access uses a localized version of Microsoft SQL Server Express Edition.
This problem occurs if a SQL Server error message contains additional single quotation marks. For example, the following error message contains additional single quotation marks:
Impossible d'insérer une ligne de clé en double dans l'objet '%1!' avec un index unique '%2!'.

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CAUSE

This problem occurs because Microsoft Dynamics CRM 4.0 uses single quotation marks to parse the index name from the SQL Server error message that you receive when you have duplicate objects. However, SQL Server error messages in some languages contain additional single quotation marks.

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RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Client_i386.mspNot applicable655,87205-Apr-200801:39Not applicable
Config.xmlNot applicable28405-Apr-200801:40Not applicable
Crmupdatewrapper.exe4.0.7333.1017439,31205-Apr-200801:35x86
Crmupdatewrapper.exe.configNot applicable14801-Dec-200713:33Not applicable
Microsoft.crm.dll4.0.7333.1017918,54405-Apr-200801:35x86
Microsoft.crm.setup.common.dll4.0.7333.1017533,52005-Apr-200801:35x86
Microsoft.crm.setup.database.common.dll4.0.7333.101770,67205-Apr-200801:34x86
Microsoft.crm.setup.databaseinstaller.dll4.0.7333.101774,76805-Apr-200801:34x86
Microsoft.crm.tools.logging.dll4.0.7333.101723,05605-Apr-200801:34x86
Microsoft.windowsinstaller.dll4.0.7333.1017119,82405-Apr-200801:34x86
Eula.rtfNot applicable101,38501-Dec-200713:34Not applicable
Microsoft.crm.application.outlook.offlinesync.dll4.0.7333.1017132,11205-Apr-200801:34x86

Installation information

Install this hotfix on computers that are running the Microsoft Dynamics CRM 4.0 client for Outlook with Offline Access.

Prerequisites

You must have Microsoft Dynamics CRM 4.0 installed to apply this hotfix.

Restart requirement

If you are prompted to restart the computer, you must restart the computer after you apply this hotfix.

Removal information

To remove this hotfix from a computer that is running Windows Server 2003, Windows XP, or Microsoft Windows 2000, use Add or Remove Programs in Control Panel.

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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
938065 (http://support.microsoft.com/kb/938065/) Error message when you try to go offline in the Microsoft Dynamics CRM client for Outlook: "Failed move data for entity"
For more information about software update terminology, click the following article numbers to view the articles in the Microsoft Knowledge Base:
824684 (http://support.microsoft.com/kb/824684/) Description of the standard terminology that is used to describe Microsoft software updates
887283 (http://support.microsoft.com/kb/887283/) Microsoft Business Solutions CRM software hotfix and update package naming standards

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APPLIES TO
Microsoft Dynamics CRM 4.0
Microsoft CRM client for Microsoft Office Outlook, when used with:
  Microsoft Dynamics CRM 4.0

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Keywords: 
kbautohotfix kberrmsg kbmbslanguagepacks kbmbsmigrate kbqfe kbhotfixserver KB951179

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