Error message when you try to go offline in the Microsoft Dynamics CRM 4.0 client for Outlook with Offline Access: "Failed move data for entity"

Article translations Article translations
Article ID: 951179 - View products that this article applies to.
Expand all | Collapse all

SYMPTOMS

When you try to go offline in the Microsoft Dynamics CRM 4.0 client for Microsoft Office Outlook with Offline Access, you receive the following error message:
Failed move data for entity 'Entity_Name' during action action {Action_Number}, countRows={Row_Number}.
This problem occurs if the following conditions are true:
  • You install the Multilingual User Interface Pack (MUI) on the computer that runs the Microsoft Dynamics CRM 4.0 server components.
  • You install the MUI on the computer that runs the Microsoft Dynamics CRM 4.0 client for Outlook with Offline Access.
  • You enable a language on the computer that runs the Microsoft Dynamics CRM 4.0 server components.
  • The Microsoft Dynamics CRM 4.0 client for Outlook with Offline Access uses a localized version of Microsoft SQL Server Express Edition.
This problem occurs if a SQL Server error message contains additional single quotation marks. For example, the following error message contains additional single quotation marks:
Impossible d'insérer une ligne de clé en double dans l'objet '%1!' avec un index unique '%2!'.

CAUSE

This problem occurs because Microsoft Dynamics CRM 4.0 uses single quotation marks to parse the index name from the SQL Server error message that you receive when you have duplicate objects. However, SQL Server error messages in some languages contain additional single quotation marks.

RESOLUTION

This problem is fixed in the latest cumulative update rollup for Microsoft Dynamics CRM 4.0. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
949256 Microsoft Dynamics CRM 4.0 updates and hotfixes

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
938065 Error message when you try to go offline in the Microsoft Dynamics CRM client for Outlook: "Failed move data for entity"
For more information about software update terminology, click the following article numbers to view the articles in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
887283 Microsoft Business Solutions CRM software hotfix and update package naming standards

Properties

Article ID: 951179 - Last Review: January 20, 2012 - Revision: 3.2
APPLIES TO
  • Microsoft Dynamics CRM 4.0
  • Microsoft CRM client for Microsoft Office Outlook, when used with:
    • Microsoft Dynamics CRM 4.0
Keywords: 
kbautohotfix kberrmsg kbmbslanguagepacks kbmbsmigrate kbqfe kbhotfixserver KB951179

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com