Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

When you start Business Portal for Microsoft Dynamics GP 10.0 or Business Portal for Microsoft Dynamics SL 7.0 on Windows Vista, you are prompted several times to install the MBFWebBehaviors ActiveX control. After you click Install multiple times, you receive the following error message:

Object does not support this method.

Cause

This problem is caused because the MBFWebBehaviors ActiveX control is installed incorrectly on Windows Vista when the User Account Control (UAC) is disabled. The MBFWebBehaviors ActiveX control is part of the Result Viewer functionality.

Resolution

To resolve this problem, use one of these methods:

  • In Windows Vista, turn on the UAC. To do this, follow these steps:

    1. Click Start, and then click Control Panel.

    2. Use one of the following methods:

      • If you are using Control Panel Home View in Control Panel, follow these steps:

        1. Click User Accounts, and then click User Accounts again.

        2. Click Turn User Access Control On or Off.

        3. Click to clear the Use User Account Access Control (UAC) to help protect your computer check box.

        4. Click OK.

      • If you are using Classic View in Control Panel, follow these steps:

        1. Click User Accounts, and then click Turn User Access Control On or Off.

        2. Click to clear the Use User Account Access Control (UAC) to help protect your computer check box.

        3. Click OK.


    3. When you are prompted, restart the computer.



      Note When you install Microsoft Dynamics GP, make sure that you use a logon account that has a local administrator role on the computer.

  • Use Systems Management Server (SMS) to push an .msi file to the client workstation to install the ActiveX control.

    Note This Web site provides an example of how to push an .msi file to the client workstation.

  • In Windows Vista, manually install the ActiveX control on the client workstation. To do this, follow these steps:

    1. On the Business Portal CD, locate the PreReqs\ActiveXControl folder.

    2. Double-click BusinessPortal-ActiveX.msi to install the components on the client workstation.

References

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×