Messaggio di errore quando si tenta di installare un hotfix o un aggiornamento in un computer che esegue Windows XP: "Non si dispone dell'autorizzazione per l'aggiornamento di Windows XP"

Traduzione articoli Traduzione articoli
Identificativo articolo: 951244 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

Sintomi

Quando si tenta di installare un hotfix o un aggiornamento su un computer in cui è in esecuzione Windows XP, l'operazione non viene eseguita e viene visualizzato un messaggio di errore analogo al seguente:
Non si dispone dell'autorizzazione per l'aggiornamento di Windows XP. Contattare l'amministratore del sistema.

Cause

Questo problema può verificarsi in presenza di una delle seguenti condizioni:
  • Non si è connessi al computer come utente con autorizzazioni di amministratore locale.
  • Le impostazioni di Criteri di gruppo del dominio applicate al computer sono troppo restrittive e non consentono all'utente del dominio di installare un hotfix o un aggiornamento.

Risoluzione

Per risolvere il problema, attenersi alla seguente procedura:
  1. Verificare che l'utente che tenta di installare l'hotfix o l'aggiornamento disponga delle autorizzazioni di amministratore locale. Per effettuare questa operazione, attenersi alla seguente procedura:
    1. Fare clic sul pulsante Start, quindi scegliere Esegui.
    2. Copiare e incollare, o digitare, il seguente comando nella casella Apri, quindi premere INVIO:
      compmgmt.msc
    3. Espandere Utilità di sistema.
    4. Espandere Utenti e gruppi locali.
    5. Fare clic su Gruppi.
    6. Fare clic con il pulsante destro del mouse su Administrators, quindi scegliere Proprietà.
    7. Verificare che l'utente sia un membro del gruppo Administrators, quindi scegliere OK.
  2. Verificare che le impostazioni di Criteri di gruppo del dominio non siano troppo restrittive per installare un hotfix o un aggiornamento. Per effettuare questa operazione, attenersi alla seguente procedura:
    1. Fare clic sul pulsante Start, scegliere Tutti i programmi, Strumenti di amministrazione, quindi Utenti e computer di Active Directory.
    2. Fare clic con il pulsante destro del mouse sul dominio, quindi scegliere Proprietà.
    3. Fare clic sulla scheda Criteri di gruppo.
    4. Fare clic su Criterio dominio predefinito, quindi scegliere Modifica.
    5. Espandere Configurazione computer.
    6. Espandere Impostazioni di Windows.
    7. Espandere Impostazioni protezione.
    8. Espandere Criteri locali.
    9. Fare doppio clic su Assegnazione diritti utente.
    10. Individuare i seguenti criteri, quindi aggiungere il gruppo Administrators a ogni criterio:
      • Backup di file e directory
      • Ripristino di file e directory
      • Gestione file registro di controllo e di protezione
      • Acquisizione proprietà di file o di altri oggetti
      • Debug di programmi
    11. Chiudere la finestra di dialogo Criteri di gruppo, quindi la finestra di dialogo Utenti e computer di Active Directory.
  3. Fare clic sul pulsante Start, quindi scegliere Esegui.
  4. Copiare e incollare, o digitare, il seguente comando nella casella Apri, quindi premere INVIO:
    cmd
  5. Al prompt dei comandi digitare i comandi riportati di seguito, premendo INVIO dopo ciascun comando:
    gpupdate /force

    exit
  6. Se viene chiesto di riavviare il computer, scegliere .

Riferimenti

Per ulteriori informazioni su un problema analogo per i computer che eseguono Microsoft Dynamics CRM 3.0, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
934280 Messaggio di errore quando si tenta di installare un hotfix o un aggiornamento in un computer che esegue Microsoft Dynamics CRM 3.0: "Non si dispone dell'autorizzazione per l'aggiornamento di Windows XP" (in inglese)

Proprietà

Identificativo articolo: 951244 - Ultima modifica: giovedì 14 agosto 2008 - Revisione: 2.1
Le informazioni in questo articolo si applicano a:
  • Microsoft Windows XP Service Pack 3
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Media Center Edition 2005
  • Microsoft Windows XP Tablet PC Edition
  • Microsoft Windows XP Professional x64 Edition
  • Microsoft Windows XP 64-Bit Edition Version 2003
  • Microsoft Windows XP Professional 64-Bit Edition (Itanium)
Chiavi: 
kbinstallation kbexpertisebeginner kberrmsg kbtshoot kbprb KB951244
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com