A scheduled task does not run as expected if a command-line argument is enclosed in quotation marks on a computer that is running Windows Server 2008 or Windows Vista SP1

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Article ID: 951246 - View products that this article applies to.
Support for Windows Vista Service Pack 1 (SP1) ends on July 12, 2011. To continue receiving security updates for Windows, make sure you're running Windows Vista with Service Pack 2 (SP2). For more information, refer to this Microsoft web page: Support is ending for some versions of Windows.
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SYMPTOMS

Consider the following scenario:
  • You create a scheduled task on a computer that is running Windows Server 2008 or Windows Vista Service Pack 1 (SP1).
  • One or more command-line arguments in this scheduled task are enclosed in quotation marks.
In this scenario, the scheduled task does not run as expected. Additionally, a value of 0x1 appears in the Last Run Result column.

For example, assume that you create a scheduled task by running the following command-line argument:
schtasks /create /tn "Test Scheduled Task" /tr "c:\temp.bat \"1-Jan-70 8:00:00\"" /sc daily /st 03:15:00 /ru System
The scheduled task fails after it starts at 03:15. However, if you delete the quotation marks around "1-Jan-70 8:00:00," the scheduled task runs successfully.

Note The issue does not occur in Windows Vista or in Windows Server 2003.

CAUSE

This problem occurs because Task Scheduler cannot correctly parse quotation marks in a command line.

RESOLUTION

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 or Windows Vista SP1.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2008 x86
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Taskeng.exe6.0.6001.22153169,98409-Apr-200801:55x86
Taskeng.mofNot Applicable2,25418-Dec-200721:21Not Applicable
Windows Server 2008 IA-64
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Taskeng.exe6.0.6001.22153518,65609-Apr-200802:07IA-64
Taskeng.mofNot Applicable2,25418-Dec-200721:22Not Applicable
Windows Server 2008 x64
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Taskeng.exe6.0.6001.22153265,21609-Apr-200802:22x64
Taskeng.mofNot Applicable2,25418-Dec-200721:21Not Applicable
Windows Vista Service Pack 1 x86
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Taskeng.exe6.0.6001.22153169,98409-Apr-200801:55x86
Taskeng.mofNot Applicable2,25418-Dec-200721:21Not Applicable
Windows Vista Service Pack 1 IA-64
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Taskeng.exe6.0.6001.22153518,65609-Apr-200802:07IA-64
Taskeng.mofNot Applicable2,25418-Dec-200721:22Not Applicable
Windows Vista Service Pack 1 x64
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Taskeng.exe6.0.6001.22153265,21609-Apr-200802:22x64
Taskeng.mofNot Applicable2,25418-Dec-200721:21Not Applicable

WORKAROUND

To work around this problem, manually delete the quotation marks from the "Add arguments" section of the properties for the scheduled task.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 951246 - Last Review: October 8, 2011 - Revision: 3.0
APPLIES TO
  • Windows Server 2008 Standard
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Datacenter
  • Windows Server 2008 for Itanium-Based Systems
  • Windows Server 2008 Standard without Hyper-V
  • Windows Server 2008 Enterprise without Hyper-V
  • Windows Server 2008 Datacenter without Hyper-V
  • Windows Vista Service Pack 1, when used with:
    • Windows Vista Home Basic
    • Windows Vista Home Premium
    • Windows Vista Business
    • Windows Vista Enterprise
    • Windows Vista Ultimate
    • Windows Vista Home Basic 64-bit Edition
    • Windows Vista Home Premium 64-bit Edition
    • Windows Vista Enterprise 64-bit Edition
    • Windows Vista Ultimate 64-bit Edition
Keywords: 
kbautohotfix kbexpertiseinter kbqfe KB951246

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