Article ID: 951319 - Last Review: February 12, 2009 - Revision: 3.0

You receive error messages when you create an appointment in Microsoft Dynamics CRM 4.0

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SYMPTOMS

When you create an appointment in Microsoft Dynamics CRM 4.0, you receive the following error message:
Platform Error ====================================
>Crm Exception: Message: Creating Entity with an invalid parent. Entity: ActivityParty, ReferencingAttribute:partyid, ErrorCode: -2147220987
>Crm Exception: Message: Invalid Party Object Type 10, ErrorCode: -2147207930
>MessageProcessor fail to process message 'Book' for 'appointment'.
>ExecutionContext not in use (OnErrorRequest) for organization {5761BB2D-F17C-46DC-BC53-F0675CEB1A67}
>Exception in Application WebServices. See the following trace error for more information.

User Error ====================================
Error: Exception has been thrown by the target of an invocation.
Error Number: 0x80043506 Error Message: Invalid Party Object Type 10
Error Details: Invalid Party Object Type 10
Source File: Not available
Line Number: Not available
Request URL: http://crm:5555/Dubai/AppWebServices/ActivitiesWebService.asmx
Stack Trace Info: [CrmException: Invalid Party Object Type 10] at Microsoft.Crm.ObjectModel.ActivityPartyService.Create(IBusinessEntity entity, ExecutionContext context) at Microsoft.Crm.ObjectModel.CommunicationActivityServiceBase.CreateCommunicationParties(BusinessEntityMoniker moniker, CommunicationActivity activity, ExecutionContext context)

CAUSE

This problem occurs because the lookup control that is used to select attendees is not filtered correctly when you create the appointment. The lookup control may let you select a record type that you should be unable to select.

RESOLUTION

This problem is fixed in the latest cumulative update rollup for Microsoft Dynamics CRM 4.0. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
949256  (http://support.microsoft.com/kb/949256/ ) Microsoft Dynamics CRM 4.0 updates and hotfixes

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
887283  (http://support.microsoft.com/kb/887283/ ) Microsoft Business Solutions CRM software hotfix and update package naming standards

APPLIES TO
  • Microsoft Dynamics CRM 4.0
Keywords: 
kberrmsg kbautohotfix kbfix kbexpertiseinter kbmbsmigrate kbqfe kbhotfixserver KB951319
 

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