La utilidad ntdsutil.exe en Windows Server 2003 escribe demasiados vínculos a archivos .ldf durante un proceso de restauración autoritaria

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Síntomas

Tenga en cuenta la situación siguiente. Utilice la utilidad ntdsutil.exe para recuperar objetos o atributos en un bosque de Active Directory basado en Windows Server 2003. Al restaurar los objetos, la utilidad ntdsutil.exe crea archivos .ldf. Estos archivos se importan en los dominios del bosque para que pueda obtener todos los vínculos a los objetos restaurados.

Sin embargo, cuando inspeccionar los archivos .ldf de los objetos vinculados, encontrará que el número de vínculos que se restauran en un archivo de .ldf supera el número de objetos que existen en la copia de seguridad para el dominio correspondiente. Estos archivos .ldf incorrectamente incluyen todos los vínculos, como los vínculos que se han quitado del intervalo de duración de objetos de desecho.

En este caso, los usuarios permanecen en grupos a los que ya no deben pertenecen. Esto puede causar un problema de seguridad.

Causa

Cuando la utilidad ntdsutil.exe crea la lista de los vínculos, la lista incluye incorrectamente los vínculos que se han quitado del intervalo de duración de objetos de desecho. Sin embargo, la lista sólo debería incluir los vínculos que existen realmente en la copia de seguridad.

Solución

Información de revisiones

Si tiene que ejecutar una restauración autoritaria en caso de emergencia, instale la revisión en modo de restauración DS después de restaurar el estado del sistema.

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Para instalar este hotfix, debe tener Windows Server 2003 Service Pack 1 o Windows Server 2003 Service Pack 2 instalado en el equipo.

Requisito de reinicio

No es necesario reiniciar el equipo después de aplicar este hotfix.

Información acerca de la sustitución de la revisión

Esta revisión no sustituye a ninguna otro publicada previamente.

Información del registro

Para utilizar esta revisión, no es necesario realizar cambios en el registro.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.
Windows Server 2003 con SP1, versiones basadas en 86 en x
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Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataformaRequisito de SP
Ntdsutil.exe5.2.3790.3144312,32022 De mayo de 200817: 23x 86SP1
W03a2409.dll5.2.3790.309029.69614 De febrero de 200809: 41x 86SP1
Windows Server 2003 con SP2, versiones basadas en 86 en x
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Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Ntdsutil.exe5.2.3790.4299312,32022 De mayo de 200809: 56x 86
Windows Server 2003 con SP1, versiones basadas en Itanium
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Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataformaRequisito de SPTipo de servicio
Ntdsutil.exe5.2.3790.3144804,86422 De mayo de 200818: 16IA-64SP1No aplicable
W03a2409.dll5.2.3790.309028.67222 De mayo de 200818: 16IA-64SP1No aplicable
Wntdsutil.exe5.2.3790.3144312,32022 De mayo de 200818: 16x 86SP1GUAU
Ww03a2409.dll5.2.3790.309029.69622 De mayo de 200818: 16x 86SP1GUAU
Windows Server 2003 con SP2, versiones basadas en Itanium
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Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataformaRequisito de SPTipo de servicio
Ntdsutil.exe5.2.3790.4299804,86422 De mayo de 200818: 28IA-64SP2No aplicable
Wntdsutil.exe5.2.3790.4299312,32022 De mayo de 200818: 28x 86SP2GUAU
Windows Server 2003 y Windows XP, versiones de 64 x
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Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataformaRequisito de SPTipo de servicio
Ntdsutil.exe5.2.3790.3144502,27222 De mayo de 200818: 15x 64SP1No aplicable
W03a2409.dll5.2.3790.309030.20822 De mayo de 200818: 16x 64SP1No aplicable
Wntdsutil.exe5.2.3790.3144312,32022 De mayo de 200818: 16x 86SP1GUAU
Ww03a2409.dll5.2.3790.309029.69622 De mayo de 200818: 16x 86SP1GUAU
Windows Server 2003 con SP2 y Windows XP con SP2, versiones basadas en 64 x
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Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataformaRequisito de SPTipo de servicio
Ntdsutil.exe5.2.3790.4299502,27222 De mayo de 200818: 29x 64SP2No aplicable
Wntdsutil.exe5.2.3790.4299312,32022 De mayo de 200818: 29x 86SP2GUAU

Solución

Para evitar este problema, quite manualmente los vínculos problemáticos de los archivos .ldf.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
840001Cómo restaurar cuentas de usuario eliminadas y sus pertenencias a grupos en Active Directory
Para obtener más información acerca de la terminología relativa de la actualización de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Soporte técnico para x 64 versiones de Microsoft Windows

Si su hardware venía con una edición x 64 de Microsoft Windows ya instalada, el fabricante del hardware proporciona soporte técnico y asistencia para la edición de 64 bits de Windows. En este caso, el fabricante del hardware proporciona soporte técnico porque incluyó una edición x 64 de Windows con el hardware. El fabricante del hardware podría haber personalizado instalación de la edición x 64 de Windows con componentes únicos. Esos componentes exclusivos podrían incluir controladores de dispositivo específicos o configuraciones opcionales para maximizar el rendimiento del hardware. Si necesita ayuda técnica para una edición x 64 de Windows, Microsoft ofrecerá asistencia de esfuerzo razonable. Sin embargo, es posible que deba contactar directamente con el fabricante. El fabricante es el mejor cualificado para proporcionar el soporte técnico del software que él mismo instaló en el hardware. Si adquirió una edición x 64 de Windows, como una edición x 64 de Windows Server 2003 por separado, póngase en contacto Microsoft para obtener soporte técnico.

Para información de producto acerca de Windows XP Professional x 64 Edition, visite el siguiente sitio Web de Microsoft:
http://www.microsoft.com/windowsxp/64bit/default.mspx
Para información de producto acerca de x 64 de Windows Server 2003, visite el siguiente sitio Web de Microsoft:
http://www.microsoft.com/windowsserver2003/64bit/x64/default.mspx

Pasos para reproducir el problema

  1. Dos dominios basados en Windows Server 2003 (domain1 y domain2) existen en un bosque. El nivel funcional del bosque se configura como Windows Server 2003.
  2. Existe la cuenta de usuario user1 en domain1. Los grupos, group1 y group2, existe en el domain2. La cuenta de usuario user1 es un miembro de group1 y group2.
  3. Quite la cuenta de usuario user1 del grupo group2.
  4. Hacer copia de seguridad del sistema estado en un controlador de dominio de domain1.
  5. Eliminar la cuenta de usuario user1.
  6. Realizar una restauración autoritaria para restaurar la cuenta de usuario user1 mediante la utilidad ntdtutil.exe. Se genera un archivo de .ldf en este proceso. Este archivo debe importarse domain2.
En el archivo .ldf, encontrará que la cuenta de usuario user1 tiene que agregarse en group2. No es el comportamiento esperado, porque se quitan de cuenta de usuario user1 del grupo group2 cuando hizo copia de seguridad del estado del sistema en el paso 4 en un controlador de dominio de domain1.

Propiedades

Id. de artículo: 951320 - Última revisión: martes, 10 de junio de 2008 - Versión: 1.0
La información de este artículo se refiere a:
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows XP Professional x64 Edition
Palabras clave: 
kbmt kbautohotfix kbexpertiseadvanced kbfix kbqfe kbhotfixserver KB951320 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 951320

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