Help and Support

After you log on to a Windows Vista-based computer that has the Desktop folder redirected, you see a black screen for 30 to 120 seconds before the desktop or the Start menu appears

Article ID:951324
Last Review:June 24, 2008
Revision:2.0

SYMPTOMS

Consider the following scenario:
On a Windows Vista-based computer, you redirect the Desktop folder to a network redirection folder.
You enable the Always Available offline option to make the Desktop folder available offline.
The computer is connected to a network that does not contain the redirection folder.
You restart the computer, and then you enter your user credentials on the Welcome screen to log on to the computer.
In this scenario, you see a black screen for 30 to 120 seconds before the desktop or the Start menu appears.

Back to the top

CAUSE

During the logon process, Windows Vista switches from the Welcome screen to the desktop either when Windows Explorer is ready or when the desktop switching time-out interval has passed. Additionally, when client-side caching tries to access the redirected Desktop folder from a network share that is inaccessible, the system must wait for the network time-out interval to pass. (The network time-out interval is longer than the desktop switching time-out interval.) Therefore, Windows Vista switches from the Welcome screen to a blank screen to wait for the network time-out interval to pass before the desktop appears.

Back to the top

WORKAROUND

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 (http://support.microsoft.com/kb/322756/) How to back up and restore the registry in Windows
To work around this issue, extend the desktop switching time-out interval by modifying a registry key. After you do this, you will see the Welcome screen instead of a blank screen while you wait for the network time-out interval to pass.

To extend the desktop switching time-out interval, follow these steps:
1.Click Start, type regedit in the Start Search box, and then press ENTER.
2.Locate the following registry subkey:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System
3.Right-click System, point to New, and then click DWORD Value.
4.Type DelayedDesktopSwitchtime-out, and then press ENTER.
5.Double-click the DelayedDesktopSwitchtime-out registry entry.
6.In the Value data box, type 45, and then click OK.
7.Exit Registry Editor.

Back to the top


APPLIES TO
Windows Vista Enterprise 64-bit Edition
Windows Vista Ultimate 64-bit Edition
Windows Vista Business
Windows Vista Business 64-bit Edition
Windows Vista Enterprise
Windows Vista Ultimate

Back to the top

Keywords: 
kbexpertiseadvanced kbtshoot kbprb KB951324

Back to the top

Article Translations

 

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.