Windows XP Service Pack 3-based computers in a private network that uses Internet Connection Sharing may lose network connectivity after you change the network adapter settings of the private adapter on the Internet Connection Sharing computer

Traductions disponibles Traductions disponibles
Numéro d'article: 951446 - Voir les produits auxquels s'applique cet article
Agrandir tout | Réduire tout

Sommaire

Symptômes

On a Windows XP Service Pack 3 (SP3)-based computer that is part of a private network, you configure Internet Connection Sharing and Windows Firewall. Then, you perform one of the following actions:
  • You enable or you disable the private network adapter that is configured for Internet Connection Sharing.
  • You remove and then you reconnect the network cable of the private network adapter that is configured for Internet Connection Sharing.
  • You change the IP address of the private network adapter that is configured for Internet Connection Sharing.
Then, you notice that other Windows XP SP3-based computers that are configured to use Internet Connection Sharing lose network connectivity. Also, computers that are newly added to the private network cannot obtain a private IP address.

Cause

This issue occurs because Internet Connection Sharing loses the firewall port exception configurations when you change the network adapter settings on the Internet Connection Sharing host. Therefore, all the data packets from the private network are dropped.

Résolution

Pour résoudre ce problème, appliquez l'une des méthodes suivantes.

Method 1: Use the "net start sharedaccess" command to restart the "Windows Firewall/Internet Connection Sharing" service

  1. Cliquez sur Démarrer , cliquez sur Exécuter , tapez cmd et appuyez sur ENTRÉE.
  2. At the command prompt, type the following command, and then press ENTER to stop the SharedAccess service:
    sc stop sharedaccess
  3. At the command prompt, type the following command, and then press ENTER to start the SharedAccess service:
    sc start sharedaccess
  4. At the command prompt, type exit, and then press ENTER to close the Command Prompt window.

Method 2: Use Microsoft Management Console to restart the "Windows Firewall/Internet Connection Sharing" service

  1. Click Start, click Run, type Services.msc, and then press ENTER.
  2. In the details pane, locate and right-click Windows Firewall/Internet Connection Sharing (ICS), and then click Restart.
  3. Close the Services snap-in.

Propriétés

Numéro d'article: 951446 - Dernière mise à jour: mardi 6 mai 2008 - Version: 2.1
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows XP Service Pack 3
Mots-clés : 
kbmt kbexpertiseinter kbtshoot kbprb KB951446 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 951446
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com