Sie können keine Verbindung mit einem Remotecomputer herstellen oder eine Remoteanwendung starten, wenn Sie den Webzugriff der Terminaldienste oder den Remotewebarbeitsbereich auf einem Windows XP SP3-basierten oder Windows Small Business Server 2003 SP1-basierten Computer verwenden.

Dieser Artikel enthält Problemumgehungen für ein Problem, bei dem Sie keine Verbindung mit einem Remotecomputer herstellen oder eine Remoteanwendung starten können, wenn Sie TS Web Access oder Remote Web Workspace verwenden.

Gilt für: Windows 10 (alle Editionen), Windows Server 2012 R2
Ursprüngliche KB-Nummer: 951607

Symptome

Auf einem Windows XP Service Pack 3 (SP3)-basierten oder Windows Small Business Server 2003 Service Pack 1 (SP1)-basierten Computer treten die folgenden Symptome auf:

  • Wenn Sie versuchen, über die Remotedesktop-Webverbindung (TSWeb) eine Verbindung mit einem Remotecomputer herzustellen, ist die Schaltfläche Verbinden deaktiviert. Die Seite TSWeb kann auch die folgende Warnmeldung enthalten:

    Das Remotedesktop-Webverbindungs-ActiveX-Steuerelement ist nicht installiert. Ohne eine funktionierende installierte Version des Steuerelements kann keine Verbindung hergestellt werden.

    Hinweis

    Wenn Sie versuchen, den Remotedesktopverbindung 6.0-Client zu installieren, erhalten Sie eine Meldung, die besagt, dass er bereits auf dem Computer installiert ist.

  • Wenn Sie die Remotewebarbeitsbereich-Website (RWW) verwenden, um eine Verbindung mit einem Remotecomputer herzustellen, stellen Sie fest, dass Sie das ActiveX-Steuerelement für die Remotedesktopverbindung nicht herunterladen können. Alternativ erhalten Sie die folgende Fehlermeldung:

    Ungültiger Servername.

    Hinweis

    Remotewebarbeitsbereich ist ein Feature, das in Microsoft Windows Small Business Server (Windows SBS) verfügbar ist.

  • Wenn Sie die TsWA-Website (Terminal Services Web Access) verwenden, um eine Verbindung mit einem Remotecomputer herzustellen oder eine Remoteanwendung zu starten, erhalten Sie die folgende Fehlermeldung: Diese Website erfordert den Terminaldiensteclient, der auf diesem System anscheinend nicht installiert ist. Installieren Sie den neuesten Client, und stellen Sie sicher, dass Sie über die neuesten Windows-Updates verfügen, bevor Sie fortfahren.

  • Wenn Sie mithilfe von Windows Home Server auf die Seite Remotezugriffscomputer zugreifen, wird möglicherweise die folgende Fehlermeldung angezeigt: Add-On deaktiviert Diese Webseite fordert ein add-on an, das deaktiviert ist. Klicken Sie hier, um das Add-On zu aktivieren. Wenn Sie außerdem versuchen, eine Verbindung mit Ihrem Windows Home Server oder einem Heimcomputer herzustellen, wird möglicherweise die folgende Fehlermeldung angezeigt:

    Dieses Feature erfordert, dass die Websiteadresse https://my.homeserver.com Ihres Windows Home Servers der Zone Vertrauenswürdige Sites in Internet Explorer hinzugefügt wird. Um die Websiteadresse Ihres Windows Home Servers hinzuzufügen, öffnen Sie das Dialogfeld Internetoptionen von Internet Explorer, klicken Sie auf die Registerkarte Sicherheit. Wählen Sie "Vertrauenswürdige Websites" aus, und klicken Sie auf die Schaltfläche Websites. Fügen Sie die Websiteadresse https://my.homeserver.com mit der Schaltfläche Hinzufügen hinzu, und drücken Sie dann Schließen.

    Hinweis

    Nachdem Sie die Url des Startservers zur Liste der vertrauenswürdigen Websites hinzugefügt haben, erhalten Sie dieselbe Fehlermeldung, und Sie können weiterhin keine Verbindung herstellen.

  • Wenn Sie mithilfe von Website-Remotezugriff auf Ihren Windows Home Server zugreifen, wird möglicherweise die folgende Fehlermeldung angezeigt:

    Add-On deaktiviert Diese Webseite fordert ein add-on an, das deaktiviert ist. Klicken Sie hier, um das Add-On zu aktivieren.

    Wenn Sie versuchen, eine Verbindung mit Ihrem Windows Home Server herzustellen, erhalten Sie möglicherweise die folgende Fehlermeldung: Um eine Remoteverbindung mit Ihrem Heimserver oder Heimcomputer herzustellen, muss das Microsoft Terminal Services Client Control-Add-On oder das Microsoft RDP-Add-On installiert und für Ihren Webbrowser aktiviert sein. Wenn Sie die Installation des Add-Ons abgelehnt haben, aktualisieren Sie die Seite, und installieren Sie sie, wenn Sie dazu aufgefordert werden. Aktivieren Sie dieses Add-On andernfalls über das Symbol Add-Ons verwalten im Webbrowser status Leiste, oder lesen Sie die Dokumentation Ihres Webbrowsers, um zu erfahren, wie Sie dieses Add-On aktivieren.

Ursache

Dieses Problem tritt auf, wenn das ActiveX-Steuerelement für den Remotedesktopverbindungsclient im Webbrowser nicht aktiviert ist. Standardmäßig ist das ActiveX-Steuerelement deaktiviert, nachdem Sie Windows XP Service Pack 3 (SP3) oder Windows Small Business Server 2003 SP1 installiert haben.

Problemumgehung

Gehen Sie folgendermaßen vor, um dieses Problem zu umgehen:

  1. Starten Sie Internet Explorer.

  2. Besuchen Sie die Website, die dieses Problem verursacht.

  3. Wenn Sie Windows Internet Explorer 7 verwenden, führen Sie die folgenden Schritte aus:

    1. Zeigen Sie im Menü Extras auf Add-Ons verwalten, und klicken Sie dann auf Add-Ons aktivieren oder deaktivieren. Das Dialogfeld Add-Ons verwalten wird angezeigt.
    2. Suchen Sie in der Liste der Add-Ins nach dem ActiveX-Steuerelement des Microsoft Terminal Services-Clientsteuerelements oder nach dem ActiveX-Steuerelement des Microsoft RDP-Clients. Wenn Sie das Steuerelement nicht finden können, lesen Sie die Schritte unter "If the control is not displayed in the list of add-ons" (Wenn das Steuerelement nicht in der Liste der Add-Ons angezeigt wird) am Ende dieses Abschnitts.
    3. Klicken Sie auf das Steuerelement, klicken Sie auf Aktivieren, und klicken Sie dann auf OK , um das Dialogfeld Add-Ons verwalten zu schließen.

    Wenn Sie Internet Explorer 6 verwenden, führen Sie die folgenden Schritte aus:

    1. Klicken Sie im Menü Extras auf Add-Ons verwalten. Das Dialogfeld Add-Ons verwalten wird angezeigt.
    2. Suchen Sie in der Liste der Add-Ins nach dem ActiveX-Steuerelement des Microsoft Terminal Services-Clientsteuerelements oder nach dem ActiveX-Steuerelement des Microsoft RDP-Clients. Wenn Sie das Steuerelement nicht finden können, lesen Sie die Schritte unter "If the control is not displayed in the list of add-ons" (Wenn das Steuerelement nicht in der Liste der Add-Ons angezeigt wird) am Ende dieses Abschnitts.
    3. Klicken Sie auf das Steuerelement, klicken Sie auf Aktivieren, und klicken Sie dann auf OK , um das Dialogfeld Add-Ons verwalten zu schließen.
  4. Fügen Sie die Website Ihren vertrauenswürdigen Websites in Internet Explorer hinzu.

  5. Starten Sie Internet Explorer neu.

  6. Versuchen Sie, eine Verbindung mit dem Remotecomputer herzustellen. Oder versuchen Sie, die Remoteanwendung zu starten.

Wenn das Steuerelement nicht in der Liste der Add-Ons angezeigt wird

Manchmal wird das ActiveX-Steuerelement des Microsoft Terminal Services-Clientsteuerelements nicht in der Liste der Add-Ons angezeigt.

Um dieses Problem zu beheben, können Sie die folgenden Schritte ausführen, um zu versuchen, das Steuerelement anzuzeigen, indem Sie internet Explorer auf eine Standardkonfiguration zurücksetzen.

  1. Starten Sie Internet Explorer.
  2. Klicken Sie auf Datei und dann auf Importieren und Exportieren.
  3. Führen Sie die Schritte im Assistenten aus, um Ihre Favoriten zu exportieren.
  4. Klicken Sie auf Extras und dann auf Internetoptionen.
  5. Klicken Sie auf Erweitert und dann auf Zurücksetzen.

Nachdem internet Explorer auf eine Standardkonfiguration zurückgesetzt wurde, versuchen Sie, eine Verbindung mit dem Remotecomputer herzustellen oder die Remoteanwendung zu starten. Wenn es nicht funktioniert, führen Sie die Schritte in der Problemumgehung aus, um das ActiveX-Steuerelement des Microsoft-Terminaldienstclients zu aktivieren. Wenn das Steuerelement immer noch nicht aufgeführt ist, können Sie die Registrierung ändern, um einen Schlüssel zu entfernen, sofern vorhanden.

Wichtig

Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Sie sollten eine Sicherungskopie der Registrierung erstellen, bevor Sie die Registrierung bearbeiten. Sie müssen wissen, wie die Registrierung wiederhergestellt werden kann, wenn ein Problem auftritt. Weitere Informationen zum Sichern, Wiederherstellen und Ändern der Registrierung finden Sie im folgenden Artikel der Microsoft Knowledge Base: 322756 Sichern und Wiederherstellen der Registrierung unter Windows.

Entfernen Sie die folgenden Registrierungsschlüssel, sofern vorhanden:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{7584C670-2274-4EFB-B00B-D6AABA6D3850} HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{971127BB-259F-48C2-BD75-5F97A3331551} HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{9059F30F-4EB1-4BD2-9FDC-36F43A218F4A} HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{4EB89FF4-7F78-4A0F-8B8D-2BF02E94E4B2} HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{4EDCB26C-D24C-4e72-AF07-B576699AC0DE} HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{7390F3D8-0439-4C05-91E3-CF5CB290C3D0}

Nachdem die Registrierungsschlüssel entfernt wurden, beenden Sie internet Explorer und starten sie neu, und versuchen Sie, eine Verbindung mit dem Remotecomputer herzustellen oder die Remoteanwendung erneut zu starten.

Wenn das Problem dadurch nicht behoben wird, können Sie die mstscax.dll-Datei erneut registrieren. Gehen Sie dazu wie folgt vor:

  1. Beenden Sie internet Explorer.

  2. Klicken Sie auf Start, klicken Sie auf Ausführen, und geben Oder kopieren Sie den folgenden Text in das Feld Öffnen ein, und klicken Sie auf OK: %windir%\system32\regsvr32 mstscax.dll

  3. Klicken Sie an der Bestätigungsaufforderung auf OK.

  4. Starten Sie internet Explorer neu, und versuchen Sie, eine Verbindung mit dem Remotecomputer herzustellen oder die Remoteanwendung zu starten.

Weitere Informationen

In Windows XP Service Pack 2 (SP2) mussten Sie die Datei Msrdp.ocx installieren, um das Terminaldienste-ActiveX-Steuerelement zu aktivieren. Windows XP Service Pack 3 (SP3) enthält dieses ActiveX-Steuerelement bereits und installiert es mithilfe der Mstscax.dll-Datei. Dieses ActiveX-Steuerelement ist standardmäßig in Windows XP Service Pack 3 (SP3) deaktiviert.