No se puede conectar a un equipo remoto ni iniciar una aplicación remota cuando se usa El acceso web de Terminal Services o el área de trabajo web remota en un equipo basado en Windows XP SP3 o Windows Small Business Server 2003 SP1

En este artículo se proporcionan soluciones alternativas para un problema en el que no se puede conectar a un equipo remoto ni iniciar una aplicación remota cuando se usa el acceso web de TS o el área de trabajo web remota.

Se aplica a: Windows 10 (todas las ediciones), Windows Server 2012 R2
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Síntomas

En un equipo basado en Windows XP Service Pack 3 (SP3) o Windows Small Business Server 2003 Service Pack 1 (SP1), experimenta los síntomas siguientes:

  • Cuando intenta conectarse a un equipo remoto a través de conexión web de Escritorio remoto (TSWeb), el botón Conectar está deshabilitado. La página TSWeb también puede contener el siguiente mensaje de advertencia:

    El control ActiveX de conexión web de Escritorio remoto no está instalado. No se puede realizar una conexión sin una versión instalada en funcionamiento del control.

    Nota:

    Al intentar instalar el cliente de Conexión a Escritorio remoto 6.0, recibe un mensaje que indica que ya está instalado en el equipo.

  • Cuando se usa el sitio web de Área de trabajo web remota (RWW) para conectarse a un equipo remoto, observa que no puede descargar el control ActiveX Conexión a Escritorio remoto. O bien, recibirá el siguiente mensaje de error:

    Nombre de servidor no válido.

    Nota:

    Área de trabajo web remota es una característica que está disponible en Microsoft Windows Small Business Server (Windows SBS).

  • Cuando se usa el sitio web de Terminal Services Web Access (TSWA) para conectarse a un equipo remoto o iniciar una aplicación remota, recibe el siguiente mensaje de error: Este sitio web requiere el cliente de Terminal Services, que no parece estar instalado en este sistema. Instale el cliente más reciente y asegúrese de que tiene la Novedades de Windows más reciente antes de continuar.

  • Al acceder a la página Equipos de acceso remoto mediante Windows Home Server, puede recibir el siguiente mensaje de error: Complemento deshabilitado Esta página web solicita un complemento deshabilitado. Para habilitar el complemento, haga clic aquí. Además, al intentar conectarse a Windows Home Server o a un equipo doméstico, es posible que reciba el siguiente mensaje de error:

    Esta característica requiere que la dirección https://my.homeserver.com del sitio web de Windows Home Server se agregue a la zona Sitios de confianza en Internet Explorer. Para agregar la dirección del sitio web de Windows Home Server, abra el cuadro de diálogo Opciones de Internet de Internet Explorer, haga clic en la pestaña Seguridad. Seleccione "Sitios de confianza" y haga clic en el botón Sitios. Agregue la dirección https://my.homeserver.com del sitio web con el botón Agregar y, a continuación, presione Cerrar.

    Nota:

    Después de agregar la dirección URL del servidor principal a la lista de sitios de confianza, recibirá el mismo mensaje de error y aún no podrá conectarse.

  • Al acceder a Windows Home Server mediante el acceso remoto del sitio web, es posible que reciba el siguiente mensaje de error:

    Complemento deshabilitado Esta página web solicita un complemento deshabilitado. Para habilitar el complemento, haga clic aquí.

    Además, al intentar conectarse a Windows Home Server, puede recibir el siguiente mensaje de error: Para conectarse a su servidor principal o equipo principal de forma remota, el complemento Control de cliente de Microsoft Terminal Services o el complemento RDP de Microsoft deben estar instalados y habilitados para el explorador web. Si ha rechazado instalar el complemento, actualice la página e instálela cuando se le solicite. De lo contrario, habilite este complemento con el icono Administrar complementos de la barra de estado del explorador web o consulte la documentación del explorador web sobre cómo habilitar este complemento.

Causa

Este problema se produce si el control ActiveX para el cliente de conexión a Escritorio remoto no está habilitado en el explorador web. De forma predeterminada, el control ActiveX está deshabilitado después de instalar Windows XP Service Pack 3 (SP3) o Windows Small Business Server 2003 SP1.

Solución alternativa

Para resolver este problema, siga los siguientes pasos:

  1. Abra Internet Explorer.

  2. Visite el sitio web que está causando este problema.

  3. Si usa Windows Internet Explorer 7, siga estos pasos:

    1. En el menú Herramientas , seleccione Administrar complementos y, a continuación, haga clic en Habilitar o Deshabilitar complementos. Aparece el cuadro de diálogo Administrar complementos .
    2. En la lista de complementos, busque el control ActiveX de Control de cliente de Microsoft Terminal Services o el control ActiveX del control ActiveX del cliente RDP de Microsoft. Si no encuentra el control, consulte los pasos descritos en "Si el control no se muestra en la lista de complementos" al final de esta sección.
    3. Haga clic en el control, haga clic en Habilitary, a continuación, haga clic en Aceptar para cerrar el cuadro de diálogo Administrar complementos.

    Si usa Internet Explorer 6, siga estos pasos:

    1. En el menú Herramientas , haga clic en Administrar complementos. Aparece el cuadro de diálogo Administrar complementos .
    2. En la lista de complementos, busque el control ActiveX de Control de cliente de Microsoft Terminal Services o el control ActiveX del control ActiveX del cliente RDP de Microsoft. Si no encuentra el control, consulte los pasos descritos en "Si el control no se muestra en la lista de complementos" al final de esta sección.
    3. Haga clic en el control, haga clic en Habilitary, a continuación, haga clic en Aceptar para cerrar el cuadro de diálogo Administrar complementos .
  4. Agregue el sitio a los sitios de confianza en Internet Explorer.

  5. Reinicie Internet Explorer.

  6. Intente conectarse al equipo remoto. O bien, intente iniciar la aplicación remota.

Si el control no se muestra en la lista de complementos

A veces, el control ActiveX de Control de cliente de Microsoft Terminal Services no se mostrará en la lista de complementos.

Para solucionar este problema, puede probar los pasos siguientes para intentar mostrar el control restableciendo Internet Explorer a una configuración predeterminada.

  1. Abra Internet Explorer.
  2. Haga clic en Archivoy, a continuación, haga clic en Importar y exportar.
  3. Siga los pasos del asistente para exportar sus Favoritos.
  4. Haga clic en Herramientasy, a continuación, haga clic en Opciones de Internet.
  5. Haga clic en Avanzadasy, a continuación, haga clic en Restablecer.

Una vez que Internet Explorer se haya restablecido a una configuración predeterminada, intente conectarse al equipo remoto o iniciar la aplicación remota. Si no funciona, siga los pasos descritos en la solución alternativa para habilitar el control ActiveX de Control de cliente de Microsoft Terminal Service. Si el control sigue sin aparecer, puede modificar el Registro para quitar una clave, si existe.

Importante

Este artículo contiene información sobre cómo modificar el Registro. Asegúrese de hacer una copia de seguridad del Registro antes de modificarlo. Asegúrese de saber cómo recuperar el registro en caso de producirse algún problema. Para obtener más información sobre cómo realizar copias de seguridad, restaurar y modificar el Registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base: 322756 Copia de seguridad y restauración del Registro en Windows.

Quite las siguientes claves del Registro, si existen:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{7584C670-2274-4EFB-B00B-D6AABA6D3850} HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{971127BB-259F-48C2-BD75-5F97A3331551} HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{9059F30F-4EB1-4BD2-9FDC-36F43A218F4A} HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{4EB89FF4-7F78-4A0F-8B8D-2BF02E94E4B2} HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{4EDCB26C-D24C-4e72-AF07-B576699AC0DE} HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{7390F3D8-0439-4C05-91E3-CF5CB290C3D0}

Una vez que se quiten las claves del Registro, salga y reinicie Internet Explorer e intente conectarse al equipo remoto o volver a iniciar la aplicación remota.

Si esto no resuelve el problema, puede volver a registrar el archivo mstscax.dll. Para ello, siga estos pasos:

  1. Salga de Internet Explorer.

  2. Haga clic en Inicio, en Ejecutar y escriba o copie y pegue el texto siguiente en el cuadro Abrir y haga clic en Aceptar: %windir%\system32\regsvr32 mstscax.dll

  3. En el símbolo del sistema de confirmación, haga clic en Aceptar.

  4. Reinicie Internet Explorer e intente conectarse al equipo remoto o iniciar la aplicación remota.

Más información

En Windows XP Service Pack 2 (SP2), tenía que instalar el archivo Msrdp.ocx para habilitar el control ActiveX de Terminal Services. Windows XP Service Pack 3 (SP3) ya incluye este control ActiveX e lo instala mediante el archivo Mstscax.dll. De forma predeterminada, este control ActiveX está deshabilitado en Windows XP Service Pack 3 (SP3).