No podrá conectarse a un ordenador a distancia o iniciar una aplicación a distancia cuando utilice Terminal Services Web Access o Remote Web Workspace en un ordenador con Windows XP SP3 o Windows Small Business Server 2003 SP1.

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Síntomas

En un ordenador con Windows XP Service Pack 3 (SP3) o Windows Small Business Server 2003 Service Pack 1 (SP1), observará los siguientes síntomas:
  • Cuando intente conectarse a un ordenador a distancia a través de Remote Desktop Web Connection (TSWeb), el botón Conectar estará desactivado. La página TSWeb podrá contener el siguiente mensaje de error:
    El control Remote Desktop Web Connection ActiveX no está instalado. No puede realizarse una conexión sin una versión instalada y operativa del control.
    Nota Cuando intente instalar el cliente Remote Desktop Connection 6.0, recibirá un mensaje que le indicará que dicha función ya se encuentra instalada en el ordenador.
  • Cuando utilice el sitio web Remote Web Workspace (RWW) para conectarse a un ordenador a distancia, observará que no puede descargar el control Remote Desktop Connection ActiveX. O bien recibirá el siguiente mensaje de error.
    Nombre de servidor no válido.
    Nota Remote Web Workspace es una función disponible en Microsoft Windows Small Business Server (Windows SBS).
  • Cuando utilice el sitio Web Terminal Services Web Access (TSWA) para conectarse a un ordenador a distancia o para iniciar una aplicación a distancia, recibirá el siguiente mensaje de error:
    Esta página Web requiere Terminal Service Client, que no parece estar instalado en este sistema. Instale el último cliente y asegúrese de que cuenta con las actualizaciones más recientes de Windows antes de continuar.
  • Cuando acceda a la página Remote Access Computers utilizando Windows Home Server, podrá recibir el siguiente mensaje de error:
    Complemento desactivado. Esta página Web requiere un complemento que se encuentra desactivado. Para activar el complemento haga clic aquí.
    Adicionalmente, cuando intente conectarse a su Windows Home Server o a un ordenador personal, podrá recibir el siguiente mensaje de error:
    Esta función requiere que añada la dirección de la página Web de su Windows Home Server https://my.homeserver.com a la zona de Trusted Sites en Internet Explorer. Para añadir la dirección Web de Windows Home Server abra el cuadro de diálogo de opciones de internet en Internet Explorer, y haga clic en la pestaña de Seguridad. Seleccione "Sitios seguros" y pulse sobre el botón que indica Sitios. Añada la dirección https://my.homeserver.com con el botón de añadir y luego pulse sobre Cerrar.
    Nota Después de añadir la URL del home server URL al listado de sitios personales, recibirá el mismo mensaje de error y no podrá conectarse.
  • Cuando acceda a su Windows Home Server utilizando Website Remote Access, podrá recibir el siguiente mensaje de error:
    Complemento desactivado. Esta página requiere un complemento que se encuentra desactivado. Para activar el complemento haga clic aquí.
    Adicionalmente, cuando intente conectarse a su Windows Home Server, podrá recibir el siguiente mensaje de error:
    Para conectarse a su home server o a su ordenador a distancia, el complemento Microsoft Terminal Services Client Control, o de Microsoft RDP debe estar instalado y activado para su buscador web. Si decide no instalar el complemento, vuelva a cargar la página e instálelo cuando se le solicite. De lo contrario, active el complemento utilizando el icono Administrar complementos en la barra de situación Web, o bien consulte la documentación de su buscador Web sobre cómo activar esta función.

Causa

Este problema se produce si el control ActiveX para el cliente Remote Desktop Connection no está activado en el buscador Web. De forma predeterminada, el control ActiveX está desactivado después de que instale Windows XP Service Pack 3 (SP3) o Windows Small Business Server 2003 SP1.

Solución

Para resolver este problema, siga los siguientes pasos:
  1. Inicie Internet Explorer.
  2. Consulte el sitio web que causa el problema.
  3. Si utiliza Windows Internet Explorer 7, siga los siguientes pasos:
    1. En el menú de Herramientas, pulse sobre Administrar complementos, y luego sobre Activar o Desactivar Complementos. Aparecerá el cuadro de diálodo Administrar Complementos .
    2. En el listado de complementos, busque el control Microsoft Terminal Services Client Control ActiveX o el control de Microsoft RDP client Control ActiveX. Si no puede localizarlo, consulte los pasos a seguir en el apartado "Si el control no se muestra en el listado de complementos" al final de la sección.
    3. Haga clic sobre el control, luego pulse en Activar, y luego sobre OK para cerrar el cuadro de diálogo de Administrar Complementos.

    Si está utilizando Internet Explorer 6, siga los siguientes pasos:
    1. En el menú Herramientas , haga clic en Administrar Complementos. Aparecerá el cuadro de diálogo Administrar Complementos.
    2. En el listado de complementos, busque el control Microsoft Terminal Services Client Control ActiveX o el control Microsoft RDP client Control ActiveX. Si no puede localizarlos, consulte los pasos a seguir en Si el control no se muestra en el listado de complementos, al final de la sección.
    3. Haga clic sobre el control, luego pulse sobre Activar, y por último sobre OK para cerrar el cuadro de diálogo Administrar Complementos .
  4. Añada el sitio a sus Sitios Preferidos en Internet Explorer.
  5. Reinicie Internet Explorer.
  6. Intente conectarse al ordenador a distancia. O bien, intente iniciar la aplicación a distancia.

Si el control no se muestra en el listado de complementos

A veces el control Microsoft Terminal Services Client Control ActiveX no se muestra en el listado de complementos. Para que podamos solucionar su problema, remítase a la sección "Solucionarlo en mi lugar". Si prefiere solucionar el problema usted mismo, diríjase a la sección "Solucionarlo por mí mismo".

Solucionarlo en mi lugar

Para solucionar el problema de forma automática, haga clic en el vínculo Solucionar este problema. A continuación, en el cuadro de diálogo Descarga de archivos, haga clic en Ejecutar y siga los pasos del asistente.

Solucionar este problema
Microsoft Fix it 50391

Nota: es posible que el asistente sólo esté disponible en inglés. Sin embargo, la corrección automática también funciona para las versiones de Windows en otros idiomas.

Note: si no se encuentra en el equipo al que afecta el problema, puede guardar la solución automática en una unidad de memoria flash o en un CD para poderla ejecutar en el equipo que tiene el problema.

Solucionarlo por mí mismo

Para solucionar el problema usted mismo si el control no se muestra, puede probar a seguir los siguientes pasos para tratar de mostrar el control restableciendo Internet Explorer a una configuración predeterminada anterior.
  1. Inicie Internet Explorer.
  2. Haga clic en File, y luego en Importar y Exportar.
  3. Siga los pasos indicados en las instrucciones para exportar sus Favoritos.
  4. Haga clic en Herramientas, y luego en Opciones de Internet.
  5. Haga clic en Avanzado, y luego en Reset.

Una vez que Internet Explorer se haya reiniciado a una configuración anterior, intente conectarse al ordenador a distancia o inicie la aplicación a distancia. Si esto no da resultado, siga los pasos indicados para activar el control Microsoft Terminal Service Cliente Control ActiveX. Si el control continúa sin aparecer en el listado, puede modificar el registro para eliminar cualquier contraseña, en caso de existir.

Importante Este artículo contiene información acerca de cómo modificar el registro. Asegúrese de hacer una copia de respaldo del registro antes de modificarlo. Asegúrese de saber cómo recuperar el registro en caso de producirse algún problema. Para mayor informción acerca de cómo realizar una copia de respaldo, recuperar y modificar un registro, haga clic en el siguiente artículo para leerlo en la base de información de Microsoft:
322756 Cómo realizar una copia de respaldo y recuperar el registro en Windows

Quite las claves del Registro siguientes, si existen:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{7584C670-2274-4EFB-B00B-D6AABA6D3850}HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{971127BB-259F-48C2-BD75-5F97A3331551}HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{9059F30F-4EB1-4BD2-9FDC-36F43A218F4A}HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{4EB89FF4-7F78-4A0F-8B8D-2BF02E94E4B2}HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{4EDCB26C-D24C-4e72-AF07-B576699AC0DE}HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{7390F3D8-0439-4C05-91E3-CF5CB290C3D0}

A continuación salga y reinicie Internet Explorer, e intente conectarse al equipo remoto o inicie de nuevo la aplicación remota.

Si esto no resuelve el problema, puede volver a registrar el archivo mstscax.dll. Para esto siga los siguientes pasos
  1. Salga de Internet Explorer.
  2. Haga clic en Start, luego en Run, y luego escriba o copie y pegue el siguiente texto en la casillaAbrir , finalmente haga clic en OK:
    %windir%\system32\regsvr32 mstscax.dll
  3. En el mensaje de confirmación, haga clic en OK.
  4. Reinicie Internet Explorer, e intente conectarse al ordenador a distancia o iniciar la aplicación a distancia.

Más información

En Windows XP Service Pack 2 (SP2), ha debido instalar el archivo Msrdp.ocx para activar el control Terminal Services ActiveX. Windows XP Service Pack 3 (SP3) incluye el control ActiveX y lo instala utilizando el archivo Mstscax.dll. De forma predeterminada, el control ActiveX está desactivado en Windows XP Service Pack 3 (SP3).

Propiedades

Id. de artículo: 951607 - Última revisión: viernes, 23 de septiembre de 2011 - Versión: 3.0
La información de este artículo se refiere a:
  • Service Pack 3 para Microsoft Windows XP
  • Windows Home Server
  • Windows Small Business Server 2008 Premium
  • Windows Small Business Server 2008 Standard
Palabras clave: 
kbexpertiseinter kbtshoot kbprb kbmsifixme kbfixme KB951607

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