Non è possibile connettersi a un computer remoto o avviare un'applicazione remota quando si usa Accesso Web di Servizi terminal o area di lavoro Web remota in un computer basato su Windows XP SP3 o Windows Small Business Server 2003 SP1

Questo articolo fornisce soluzioni alternative per un problema per cui non è possibile connettersi a un computer remoto o avviare un'applicazione remota quando si usa Accesso Web TS o Area di lavoro Web remota.

Si applica a: Windows 10: tutte le edizioni, Windows Server 2012 R2
Numero KB originale: 951607

Sintomi

In un computer basato su Windows XP Service Pack 3 (SP3) o Windows Small Business Server 2003 Service Pack 1 (SP1) si riscontrano i sintomi seguenti:

  • Quando si tenta di connettersi a un computer remoto tramite Connessione Web Desktop remoto (TSWeb), il pulsante Connetti è disabilitato. La pagina TSWeb può contenere anche il messaggio di avviso seguente:

    Il controllo ActiveX connessione Web Desktop remoto non è installato. Non è possibile effettuare una connessione senza una versione installata funzionante del controllo.

    Nota

    Quando si tenta di installare il client Connessione Desktop remoto 6.0, viene visualizzato un messaggio che indica che è già installato nel computer.

  • Quando si usa il sito Web Dell'area di lavoro Web remota (RWW) per connettersi a un computer remoto, si noti che non è possibile scaricare il controllo ActiveX Connessione Desktop remoto. In alternativa, viene visualizzato il messaggio di errore seguente:

    Nome server non valido.

    Nota

    Area di lavoro Web remota è una funzionalità disponibile in Microsoft Windows Small Business Server (Windows SBS).

  • Quando si usa il sito Web accesso Web di Servizi terminal (TSWA) per connettersi a un computer remoto o per avviare un'applicazione remota, viene visualizzato il messaggio di errore seguente: Questo sito Web richiede il client di Servizi terminal, che non sembra essere installato in questo sistema. Installare il client più recente e assicurarsi di avere il Aggiornamenti Windows più recente prima di continuare.

  • Quando si accede alla pagina Computer di Accesso remoto tramite Windows Home Server, è possibile che venga visualizzato il messaggio di errore seguente: Componente aggiuntivo Disabilitato Questa pagina Web richiede un componente aggiuntivo disabilitato. Per abilitare il componente aggiuntivo, fare clic qui. Inoltre, quando si tenta di connettersi a Windows Home Server o a un computer home, è possibile che venga visualizzato il messaggio di errore seguente:

    Questa funzionalità richiede che l'indirizzo https://my.homeserver.com del sito Web di Windows Home Server venga aggiunto all'area Siti attendibili in Internet Explorer. Per aggiungere l'indirizzo del sito Web di Windows Home Server, aprire la finestra di dialogo Opzioni Internet di Internet Explorer, fare clic sulla scheda Sicurezza. Selezionare "Siti attendibili" e fare clic sul pulsante Siti. Aggiungere l'indirizzo https://my.homeserver.com del sito Web con il pulsante Aggiungi e quindi premere Chiudi.

    Nota

    Dopo aver aggiunto l'URL del server principale all'elenco dei siti attendibili, viene visualizzato lo stesso messaggio di errore e non è ancora possibile connettersi.

  • Quando si accede a Windows Home Server tramite Accesso remoto al sito Web, è possibile che venga visualizzato il messaggio di errore seguente:

    Componente aggiuntivo Disabilitato Questa pagina Web richiede un componente aggiuntivo disabilitato. Per abilitare il componente aggiuntivo, fare clic qui.

    Inoltre, quando si tenta di connettersi a Windows Home Server, è possibile che venga visualizzato il messaggio di errore seguente:Per connettersi al server home o al computer principale in remoto, è necessario installare e abilitare il componente aggiuntivo Controllo client di Microsoft Terminal Services o il componente aggiuntivo Microsoft RDP per il Web browser. Se non è stato possibile installare il componente aggiuntivo, aggiornare la pagina e installarla quando richiesto. In caso contrario, abilitare questo componente aggiuntivo usando l'icona Gestisci componenti aggiuntivi nella barra di stato del Web browser oppure fare riferimento alla documentazione del Web browser su come abilitare questo componente aggiuntivo.

Causa

Questo problema si verifica se il controllo ActiveX per il client Connessione Desktop remoto non è abilitato nel Web browser. Per impostazione predefinita, il controllo ActiveX viene disabilitato dopo l'installazione di Windows XP Service Pack 3 (SP3) o Windows Small Business Server 2003 SP1.

Soluzione alternativa

Per risolvere il problema, attenersi alla seguente procedura:

  1. Avviare Internet Explorer.

  2. Visitare il sito Web che causa questo problema.

  3. Se si usa Windows Internet Explorer 7, seguire questa procedura:

    1. Scegliere Gestisci componenti aggiuntivi dal menu Strumenti e quindi fare clic su Abilita o Disabilita componenti aggiuntivi. Verrà visualizzata la finestra di dialogo Gestisci componenti aggiuntivi .
    2. Nell'elenco dei componenti aggiuntivi cercare il controllo ActiveX Controllo client di Servizi terminal Microsoft o il controllo ActiveX controllo client Microsoft RDP. Se non è possibile trovare il controllo, vedere la procedura descritta in "Se il controllo non è visualizzato nell'elenco dei componenti aggiuntivi" alla fine di questa sezione.
    3. Fare clic sul controllo, fare clic su Abilita e quindi su OK per chiudere la finestra di dialogo Gestisci componenti aggiuntivi.

    Se si usa Internet Explorer 6, seguire questa procedura:

    1. Scegliere Gestisci componenti aggiuntivi dal menu Strumenti. Verrà visualizzata la finestra di dialogo Gestisci componenti aggiuntivi .
    2. Nell'elenco dei componenti aggiuntivi cercare il controllo ActiveX Controllo client di Servizi terminal Microsoft o il controllo ActiveX controllo client Microsoft RDP. Se non è possibile trovare il controllo, vedere la procedura descritta in "Se il controllo non è visualizzato nell'elenco dei componenti aggiuntivi" alla fine di questa sezione.
    3. Fare clic sul controllo, fare clic su Abilita e quindi su OK per chiudere la finestra di dialogo Gestisci componenti aggiuntivi .
  4. Aggiungere il sito ai siti attendibili in Internet Explorer.

  5. Riavviare Internet Explorer.

  6. Provare a connettersi al computer remoto. In alternativa, provare ad avviare l'applicazione remota.

Se il controllo non viene visualizzato nell'elenco dei componenti aggiuntivi

In alcuni casi il controllo ActiveX controllo client di Servizi terminal Microsoft non verrà visualizzato nell'elenco dei componenti aggiuntivi.

Per risolvere questo problema, è possibile provare la procedura seguente per tentare di visualizzare il controllo reimpostando Internet Explorer su una configurazione predefinita.

  1. Avviare Internet Explorer.
  2. Fare clic su File e quindi su Importa ed esporta.
  3. Seguire i passaggi della procedura guidata per esportare i Preferiti.
  4. Fare clic su Strumenti e quindi su Opzioni Internet.
  5. Fare clic su Avanzate e quindi su Reimposta.

Dopo che Internet Explorer è stato reimpostato su una configurazione predefinita, provare a connettersi al computer remoto o avviare l'applicazione remota. Se non funziona, seguire la procedura descritta nella soluzione alternativa per abilitare il controllo ActiveX controllo client del Servizio terminal Microsoft. Se il controllo non è ancora elencato, è possibile modificare il Registro di sistema per rimuovere una chiave, se esistente.

Importante

In questo articolo sono contenute informazioni relative alla modifica del Registro di sistema. Prima di modificare il Registro di sistema, assicurarsi di eseguirne una copia di backup e di sapere come ripristinarlo in caso di problemi. Per altre informazioni su come eseguire il backup, ripristinare e modificare il Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base seguente: 322756 Come eseguire il backup e ripristinare il Registro di sistema in Windows

Rimuovere le chiavi del Registro di sistema seguenti, se presenti:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{7584C670-2274-4EFB-B00B-D6AABA6D3850} HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{971127BB-259F-48C2-BD75-5F97A3331551} HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{9059F30F-4EB1-4BD2-9FDC-36F43A218F4A} HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{4EB89FF4-7F78-4A0F-8B8D-2BF02E94E4B2} HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{4EDCB26C-D24C-4e72-AF07-B576699AC0DE} HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{7390F3D8-0439-4C05-91E3-CF5CB290C3D0}

Dopo aver rimosso le chiavi del Registro di sistema, chiudere e riavviare Internet Explorer e provare a connettersi al computer remoto o avviare di nuovo l'applicazione remota.

Se il problema non viene risolto, è possibile registrare nuovamente il file mstscax.dll. A tal fine, attenersi alla seguente procedura:

  1. Uscire da Internet Explorer.

  2. Fare clic sul pulsante Start, scegliere Esegui e digitare o copiare e incollare il testo seguente nella casella Apri e fare clic su OK: %windir%\system32\regsvr32 mstscax.dll

  3. Al prompt di conferma fare clic su OK.

  4. Riavviare Internet Explorer e provare a connettersi al computer remoto o avviare l'applicazione remota.

Ulteriori informazioni

In Windows XP Service Pack 2 (SP2) è stato necessario installare il file Msrdp.ocx per abilitare il controllo ActiveX di Servizi terminal. Windows XP Service Pack 3 (SP3) include già questo controllo ActiveX e lo installa usando il file Mstscax.dll. Per impostazione predefinita, questo controllo ActiveX è disabilitato in Windows XP Service Pack 3 (SP3).