A 30-second delay occurs during the initialization of some network-based applications or the roaming profiles cannot be loaded intermittently when Windows XP Service Pack 2 starts

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Article ID: 951624 - View products that this article applies to.
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SYMPTOMS

After you install Windows XP Service Pack 2 (SP2), you may encounter one or more of the following symptoms.

Symptom 1

When you start Windows XP, a delay of about 30 seconds occurs during the initialization of some network-based applications.

Symptom 2

The roaming profiles cannot be loaded intermittently. When this problem occurs, the following event is logged in the Application log:

Type: Error
Event: 1521
Source: Userenv
Event Msg:
Windows cannot locate the server copy of your roaming profile and is attempting to log you on with your local profile. Changes to the profile will not be copied to the server when you logoff. Possible causes of this error include network problems or insufficient security rights. If this problem persists, contact your network administrator.
DETAIL - Network path not found

Additionally, the following message is logged in the %SystemRoot%\Debug\UserMode\Userenv.log file:
USERENV(43c.18cc) 07:48:24:604 ReportError: Logging Error <Windows cannot copy file %path to roaming profile% to location %local profile path%. Possible causes of this error include network problems or insufficient security rights. If this problem persists, contact your network administrator.
DETAIL - This network connection does not exist.
In the %Windir%\Pfirewall.log file, you see that packets that correspond to the SMB session of the profile copy are dropped.

CAUSE

When Windows XP SP2 starts, there is a small time between network startup and Windows Firewall startup. To prevent the computer from being attacked during this brief time period, Windows XP SP2 uses the boot-time security policy. As soon as Windows Firewall is active, Windows XP SP2 loads the custom firewall settings and removes the boot-time security policy. This behavior makes your computer less vulnerable to attacks during startup and shutdown operations.

However, the boot-time security policy starts only the network services for basic networking tasks, such as Domain Name System (DNS) and Dynamic Host Configuration Protocol (DHCP). Other network communications are blocked during system startup. When the computer tries to start a network-related service, Service Control Manager takes lots of time to return the results. This behavior occurs even if the service has already been started.

RESOLUTION

A hotfix is available to resolve this issue. This hotfix checks whether the network-related service has been started instead of using Service Control Manager to start the service.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows XP SP2 or Windows XP Service Pack 3 (SP3) installed on the computer.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

Registry information

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows

To use this hotfix, follow these steps:
  1. Click Start, click Run, type regedit, and then press ENTER.
  2. Add a group that is named FirewallGroup into the List entry. To do this follow these steps:
    1. Locate and then click the following registry subkey:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\ServiceGroupOrder
    2. In the details pane, double-click the List entry to open the Edit Multi-String dialog box.
    3. In the Value data box of the dialog box that you opened in step 2b, position the pointer after TDI, and then press ENTER to start a new line in the list.
    4. In the new line, type FirewallGroup, and then click OK.
  3. Add the Group entry in the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess
    To do this, follow these steps:
    1. Locate and then click the following registry subkey:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess
    2. On the Edit menu, point to New, and then click String Value.
    3. Type Group to name the new registry entry, and then press ENTER.
    4. On the Edit menu, click Modify.
    5. Type FirewallGroup, and then click OK.
  4. Add the Group entry in the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\IpNat
    To do this, follow these steps:
    1. Locate and then click the following registry subkey:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\IpNat
    2. On the Edit menu, point to New, and then click String Value.
    3. Type Group to name the new registry entry, and then press ENTER.
    4. On the Edit menu, click Modify.
    5. Type FirewallGroup, and then click OK.
  5. Add the Group entry in the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ALG
    To do this, follow these steps:
    1. Locate and then click the following registry subkey:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ALG
    2. On the Edit menu, point to New, and then click String Value.
    3. Type Group to name the new registry entry, and then press ENTER.
    4. On the Edit menu, click Modify.
    5. Type FirewallGroup, and then click OK.
  6. Add the Group entry in the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NLA
    To do this, follow these steps:
    1. Locate and then click the following registry subkey:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NLA
    2. On the Edit menu, point to New, and then click String Value.
    3. Type Group to name the new registry entry, and then press ENTER.
    4. On the Edit menu, click Modify.
    5. Type FirewallGroup, and then click OK.
  7. Exit Registry Editor.

Additional requirements

To use this hotfix, you must set the startup type for the following services to automatic:
  • The SharedAccess service
  • The Application Layer Gateway service
  • The Network Location Awareness service
  • The IP Network Address Translator service

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP with SP2, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Hnetcfg.dll5.1.2600.3360344,06428-Apr-200814:02x86SP2
Ipnathlp.dll5.1.2600.3360330,75228-Apr-200814:02x86SP2
Windows XP with SP3, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Hnetcfg.dll5.1.2600.5589344,06428-Apr-200814:07x86SP3
Ipnathlp.dll5.1.2600.5589330,75228-Apr-200814:07x86SP3

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
917730 You cannot create a network connection when you are starting a Windows XP Service Pack 2-based computer
895486 Cross-subnet network resources are unavailable for up to 10 minutes after you restart a Microsoft Windows XP Service Pack 2-based client computer
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 951624 - Last Review: October 28, 2009 - Revision: 3.0
APPLIES TO
  • Microsoft Windows XP Service Pack 2, when used with:
    • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Professional
Keywords: 
kbautohotfix kbexpertiseadvanced kbfix kbqfe kbhotfixserver KB951624

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