Error message when you try to log on to Communicator 2007: "Outlook Integration Error"

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Article ID: 951644 - View products that this article applies to.
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Symptoms

When you try to log on to Microsoft Office Communicator 2007 or Microsoft Office Communicator 2007 R2 you receive the following error message:
Outlook Integration Error
Additionally, when you click the message to display the details, you receive the following error message:
There was a problem connecting to Microsoft Office Outlook. The e-mail address used in your default Outlook profile is different from the sign-in address used in Communicator. Change your default Outlook profile to match the sign-in address you are using in Communicator, and then sign out and sign back in to Communicator.

Cause

This issue is caused by the e-mail comparison check in Communicator 2007. If the primary Simple Mail Transfer (SMTP) address on the user object does not match the one in the Microsoft Office Outlook profile, you receive the Outlook integration error message.

Resolution

To resolve this issue, disable the e-mail comparison check. To do this, use one of the following methods.

Method 1



Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows

To have us fix this problem for you, go to the "Fix it for me" section. If you would rather fix this problem yourself, go to the "Let me fix it myself" section.

Fix it for me

To fix this problem automatically, click the Fix this problem link. Then click Run in the File Download dialog box, and follow the steps in this wizard.
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Note This wizard may be in English only; however, the automatic fix also works for other language versions of Windows.

Note If you are not on the computer that has the problem, you can save the automatic fix to a flash drive or to a CD, and then you can run it on the computer that has the problem.

Let me fix it myself

To fix this problem yourself, do the following:
  1. Click Start, and then click Run.
  2. In the Open box, type regedit, and then press ENTER.
  3. Locate and then right-click the following registry subkey:
    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Communicator
  4. Point to New, and then click DWORD Value.
  5. Type DisableEmailComparisonCheck as the name of new registry entry, and then press ENTER.
  6. Double-click DisableEmailComparisonCheck, type 1 in the Value data box, and then click OK.
  7. Exit Registry Editor.

Method 2

  1. Download the Communicator 2007 Documentation Policies package. To download this package, visit the following Microsoft Web site:
    http://www.microsoft.com/downloads/details.aspx?FamilyID=dd3cae08-3153-4c6a-a314-daa79d616248
  2. Install the Communicator 2007 Documentation Policies package. Note the location of the Communicator.adm file.

    Note By default, this file will be located in the "Drive:\Program Files\Microsoft Office Communications Server 2007\Documentation\Communicator 2007 Policies" folder.
  3. Click Start, and then click Run.
  4. In the Open box, type gpedit.msc, and then press ENTER.
  5. In Group Policy Object Editor, expand Computer Configuration, right-click Administrative Templates, point to All Tasks, and then click Add/Remove Templates.
  6. In the Add/Remove Templates dialog box, click Add.
  7. In the Policy Templates dialog box, locate the Communicator.adm file, and then click Open.
  8. In the Add/Remove Templates dialog box, click Close.
  9. In Group Policy Object Editor, expand Computer Configuration, expand Administrative Templates, expand Microsoft Office Communicator Policy Settings, and then click Microsoft Office Communicator Feature policies.
  10. Double-click Disable email comparison check for Outlook PIM integration, click to select the Enabled option, and then click OK.
  11. Close Group Policy Object Editor.

Properties

Article ID: 951644 - Last Review: September 4, 2013 - Revision: 3.0
Applies to
  • Microsoft Office Communicator 2007
Keywords: 
kbtshoot kberrmsg kbexpertisebeginner kbprb kbmsifixme kbfixme KB951644

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