Article ID: 951864 - Last Review: October 7, 2008 - Revision: 1.1

Some users must enter their credentials when they access rights-protected messages even though you have deployed the Rights Management Services (RMS) prelicensing agent on an Exchange Server 2007 SP1-based server

System TipThis article applies to a different operating system than the one you are using. Article content that may not be relevant to you is disabled.
Expand all | Collapse all

SYMPTOMS

In a Microsoft Exchange Server 2007 Service Pack 1 (SP1) environment, you can deploy a Rights Management Services (RMS) prelicensing agent. Therefore, you expect that Outlook users can access rights-protected messages directly instead of having to provide their credentials after they have already logged on to their mailboxes. However, some users must still provide thier credentials when they access the right-protected messages.

CAUSE

During the original prelicensing process, the RMS prelicensing agent tries to use the value of the msExchMasterAccountSID fields to find the home forest for each recipient and to find the address for the each recipient's RMS certification server. This issue occurs when the value msExchMasterAccountSid fields for some users are set to "S-1-5-10" or "self." When this is true, the corresponding checks are not successful. Therefore, the home forest is not returned, and the user cannot be prelicensed on the computer.

RESOLUTION

To resolve this problem, download Update Rollup 4 for Exchange 2007 Service Pack 1. Then, install Update Rollup 4 on the Exchange server. For more information about Update Rollup 4 for Exchange Server 2007 Service Pack 1, see the following Exchange Help topic:
Description of Update Rollup 4 for Exchange Server 2007 Service Pack 1 (http://go.microsoft.com/fwlink/?LinkId=152556)
For more information about how to obtain the latest Exchange service pack or update rollup, see the following Exchange Help topic:
How to Obtain the Latest Service Pack or Update Rollup for Exchange 2007 (http://go.microsoft.com/fwlink/?LinkId=152570)

MORE INFORMATION

For more information about the RMS prelicensing agent, visit the following Web site:
http://technet.microsoft.com/en-us/library/aa996600(EXCHG.80).aspx (http://technet.microsoft.com/en-us/library/aa998031(EXCHG.80).aspx)

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

APPLIES TO
  • Microsoft Exchange Server 2007 Service Pack 1, when used with:
    • Microsoft Exchange Server 2007 Standard Edition
    • Microsoft Exchange Server 2007 Enterprise Edition
Keywords: 
kbhotfixrollup kbfix kbexpertiseadvanced kbqfe KB951864